Apache 2.0.54-10 und Error 403

Dieses Thema: "Apache 2.0.54-10 und Error 403" im Forum "Web- & File-Services" wurde erstellt von MikeA, 14.09.2005.

  1. MikeA

    MikeA Grünschnabel

    Dabei seit:
    14.09.2005
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo, ich habe folgendes Problem und hoffe auf Hilfe von euch.
    Bei dem Zugriff auf die Dokumentenroot funktioniert es.
    Sobald ich aber die Dokumentenroot verlasse, also auch in Unterverzeichnisse, bekomme ich den Fehler 403. Das LOG sagt :
    (13)Permission denied: access to /testfolder/ denied

    Habe schon mit der Berechtigung 777 für das komplette Vezeichnis probiert, aber mit gleichem Ergebnis.

    Die Konfig für die Verzeichnisse sehen so aus:

    DocumentRoot "/var/www/html/"

    <Directory />
    Options FollowSymLinks
    AllowOverride None
    allow from all
    </Directory>

    <Directory "/var/www/html">
    Options Indexes FollowSymLinks
    AllowOverride None
    allow from all <---- hatte ich aus Verzweiflung eigesetzt
    </Directory>

    Habe ich etwas übersehen was mir in die Suppe spuckt ?
    Habe schon viele Threads gelesen, aber kein Tip darin hat geholfen.

    Kann mir vielleicht jemand helfen ?

    Vielen Dank
    Gruß
    Mike
     
  2. Anzeige

    Schau dir mal diesen Ratgeber an. Viele Antworten inkl. passender Shell-Befehle!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. dramen

    dramen Routinier

    Dabei seit:
    13.01.2005
    Beiträge:
    356
    Zustimmungen:
    0
    Ort:
    Wien
    WILLKOMMEN IM BOARD!! :))

    hast du apache danach neu gestartet?
     
  4. dmaphy

    dmaphy Routinier

    Dabei seit:
    16.04.2004
    Beiträge:
    482
    Zustimmungen:
    0
    Ort:
    Hamburg
    bei den berechtigungen braucht man apache nicht neustarten, aber wenn man die config.datei ändert^^
    ich persönlich vermisse folgende zeile:
    Code:
    order allow,deny
    allow from all
    
    o.O
     
  5. MikeA

    MikeA Grünschnabel

    Dabei seit:
    14.09.2005
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo ihr zwei.
    1. Selbstverständlich habe ich den Apache restartet.
    2. habe order allow,deny noch eingetragen und restartet, aber hat dies leider auch nichts gebracht. Immer noch 403 auf die Unterverzeichnisse.
    Ich laufe bald Amok. Das kann doch nicht sein.
    Hab schon mehrere Apache 1.xx aufgesetzt, aber das habe ich noch nicht erlebt.

    Gruß

    Mike
     
  6. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    hast du einen index.php in den unterverzeichnissen ?
    Oder willst du dass die dateien im verzeichniss aufgelistet werden ?
     
  7. MikeA

    MikeA Grünschnabel

    Dabei seit:
    14.09.2005
    Beiträge:
    5
    Zustimmungen:
    0
    Hi,

    es ist eigentlich egal was in dem Unterverzeichnis ist. Ich habe auch eine simple index.html probiert mit dem gleichen Ergebnis.
    Wenn sich die Dateien, egal welches ( htm, html, php...) Format, in der Dokumenten-Root befindet, funktionieren sie. Sobald sie in einem Unterverzeichnis sind, kommt der Fehler 403 forbidden.

    Gruß

    Mike
     
  8. #7 liquidnight, 15.09.2005
    Zuletzt bearbeitet: 15.09.2005
    liquidnight

    liquidnight Routinier

    Dabei seit:
    16.04.2005
    Beiträge:
    430
    Zustimmungen:
    0
    Alle Verzeichnisse (von / abgehend) müssen für den apache-user lesbar sein (und ich glaube auch x-bar, da bin ich mir net ganz sicher)
    es darf sich kein symlink zwischen / und dem docroot befinden.
    wenns immer noch net tut, probier auch mal "AllowOverride all".
    ansonsten: gucksch mal ob man die loglevels hochschrauben kann.

    Wenn dein loglevel auf debug steht, gucksch mal ins logfile rein. es müsste was drinstehen ob es an der erlaubnis am dateisystem mangelt oder ob es wegen einer regel scheitert.

    du könntest versuchen, deinen benutzer unter dem du arbeitest, in die apache gruppe mit einzuhängen. dann dem docroot chmod -Rv g+rwx zu geben.
    Außerdem ein chown -Rv und ein chgrp -Rv

    Danach dürften die Rechteprobleme erledigt sein. Offen ist aber noch die apache-konfiguration.

    gib mal ein bissle mehr infos über die distribution
     
  9. MikeA

    MikeA Grünschnabel

    Dabei seit:
    14.09.2005
    Beiträge:
    5
    Zustimmungen:
    0
    Hi, das hat auch nichts gebracht.
    Der Loglevel steht schon auf debug.
    Symlinks sind keine dazwischen.
    Sonst noch eine Idee ?

    Gruß
    Mike
     
  10. dramen

    dramen Routinier

    Dabei seit:
    13.01.2005
    Beiträge:
    356
    Zustimmungen:
    0
    Ort:
    Wien
    also ich bin nun vor dem gleichen problem gestanden und habe es folgendermaßen gelöst:

    1. chown apache:apache -R /var/www/htdocs (funktioniert auch mit "root")
    2. in der datei /etc/apache2/commonapache.conf habe ich den folgenden abschnitt folgendermaßen umgeändert: (das sind bei mir die zeilen 34-41)

    <Directory />
    Options -All -Multiviews
    AllowOverride None
    <IfModule mod_access.c>
    Order deny,allow
    # Deny from all <----- habe ich einfach auskommentiert
    </IfModule>
    </Directory>
     
  11. MikeA

    MikeA Grünschnabel

    Dabei seit:
    14.09.2005
    Beiträge:
    5
    Zustimmungen:
    0
    Workaround gefunden

    Hi @ all,

    @dramen
    leider hat dein Tip auch nichts gebracht.

    Ich habe aber noch ein paar Tage im Web recherchiert und eine Info gefunden.
    Dort wurden ähnliche Probleme auf die Konfig von SELinux zurückgeführt.
    Ich habe nun SELinux abgeschaltet, und siehe da der Zugriff funktioniert ohne Probleme. Da aber SELinux sicherlich eine sinnvolle Sache ist muß ich mich nun schlau machen damit ich es richtig konfiguriere damit es auch zusammen mit der Apache-Konfig läuft.

    Falls sich schon jemand damit beschäftigt hat und ein Tip für mich hat, wäre ich sehr dankbar.

    Lieben Gruß und nochmals danke für die Hilfe

    Mike
     
  12. maxix

    maxix Eroberer

    Dabei seit:
    16.03.2006
    Beiträge:
    74
    Zustimmungen:
    0
    Falls Ihr das mal abschalten müsst:

    setenforce 0 bzw 1
    oder für die Zukunft /etc/selinux/config

    Nach dem ich gerade 2 Stunden Zeit verbraten habe um herauszufinden warum mein Apache plötzlich mit dem Symbolischen Link nicht mehr mag (13)Permission Denied und ich alle Rechte geprüft hatte, war obiges die Erleuchtung :-)

    Danke
    Gruss
    maxix
     
Thema:

Apache 2.0.54-10 und Error 403

Die Seite wird geladen...

Apache 2.0.54-10 und Error 403 - Ähnliche Themen

  1. Centos und Apache (VirtualHost)

    Centos und Apache (VirtualHost): Hallo, ich bin gerade dabei die Firmenseiten unserer Unternehmensgruppe neu zu gestalten. Insgesammt sind es 3 Unternehmen. Als Server wurde mir...
  2. Apache Software Foundation gibt sich neues Logo

    Apache Software Foundation gibt sich neues Logo: Die Apache Software Foundation hat ihr Webseitendesign überarbeitet und sich ein neues Logo gegeben. Die Organisation sieht sich mit über 350...
  3. Apache Log-Meldung File does not exist

    Apache Log-Meldung File does not exist: Hallo zusammen, in der Logdatei von Apache wird folgende Meldung ausgegeben: … [Thu Jan 07 14:36:03 2016] [error] [client 111.222.333.444] File...
  4. Apache 2.2 Domain u. Sub-Domain auf verschiedenen Ports

    Apache 2.2 Domain u. Sub-Domain auf verschiedenen Ports: Hallo miteinander! Ich knabbere gerade an folgendem Problem: ich möchte, dass Apache auf example.com ausschließlich auf Port 80 antwortet und...
  5. Apache OpenOffice bereitet Veröffentlichung von 4.1.2 vor

    Apache OpenOffice bereitet Veröffentlichung von 4.1.2 vor: Die unter dem Schirm der Apache Foundation entwickelte Bürosuite OpenOffice bereitet die Veröffentlichung der neuen Version 4.1.2 vor. Das Release...