wrong fs type nach Kernelupdate

H

Holodoc

Mitglied
Hallo,

ich habe debian-woody vom 2.2er Kernel auf 2.4.18 geupdatet (via apt-get) und meine lilo mit der rdinit-zeile versehen. So weit so gut, wenn ich jetzt aber boote bekomme ich irgendwann

"mount: wrong fs type, bad option, bad superblock on /dev2/root"

Danach kann entsprechend einiges an Dateien nicht gefunden werden, am Ende ist dann allerdings alles gemountet, nur funzt die halbe Hardware nicht. Vielleicht kann ja jemand helfen...

Gruß
Jens

lilo.conf:

lba32
boot=/dev/hda
root=/dev/hda2
install=/boot/boot-menu.b
map=/boot/map
prompt
delay=100
timeout=100
vga=normal
default=Linux

image=/vmlinuz
initrd=/boot/initrd
label=Linux
read-only

image=/boot/vmlinuzold
label=LinuxOLD
read-only
optional


fstab:

/dev/hda2 / ext2 errors=remount-ro 0 1
/dev/hda5 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy auto user,noauto 0 0
/dev/cdrom /cdrom iso9660 ro,user,noauto 0 0
/dev/hda1 /boot ext2 defaults 0 2
/dev/hda4 /data ext2 defaults 0 2
none /var/shm shm defaults 0 0
 
MTS

MTS

Kaiser
"mount: wrong fs type, bad option, bad superblock on /dev2/root"

/dev2/root verwirrt mich jetzt ziemlich....

in meiner lilo.conf stand das "root=/dev/hda2" auch immer bei jedem image. Aber daran sollte es eignetlich nicht liegen.

du verwendest initrd, hast du denn auch die Ramdisk für den kernel neu erstellt ??
bzw . was genau hast du alles beim kernel update gemacht...
 
H

Holodoc

Mitglied
Original geschrieben von MTS
/dev2/root verwirrt mich jetzt ziemlich....
Mmh, hatte irgendwo gelesen, dass /dev2/root eigentlich normal ist, dass das halt temporär so gemountet wird, warum auch immer das dev2/root heißt :-?

in meiner lilo.conf stand das "root=/dev/hda2" auch immer bei jedem image. Aber daran sollte es eignetlich nicht liegen.
ne :(

du verwendest initrd, hast du denn auch die Ramdisk für den kernel neu erstellt ??
bzw . was genau hast du alles beim kernel update gemacht...
Uh ramdisk neu erstellt ô.0

Also ich hab das Kernelimage gezogen und installiert mit apt, dann hab ich initrd=/boot/initrd in die lilo geschrieben, hab in /boot/ ein s-link /boot/initrd -> initrd.img-2.4.18-1-k7 gesetzt und in die fstab auf Raten einer einzelnen Inetsite noch die letzte Zeile (none /var/shm shm defaults 0 0) reingenommen.

Jo, natürlich lilo gestartet und das war's wohl...
 
Zuletzt bearbeitet:
H

Holodoc

Mitglied
Naja, jetz isses mir auch egal, hab selbst nen 18er kompiliert und nu geht's :)
 

Ähnliche Themen

Zugriff Ubuntu 16.04. auf Freigabe 18.04. LTS nicht möglich

Festplatte auf SD Karte umziehen

Neue Partition unter openSUSE 12.2 erstellen

Rollei Mini Wifi Camcorder

Samba 4 Gast Zugang unter Ubuntu funktioniert nicht

Oben