USE flag mit "*" (-opengl*) geht nicht mit USE="opengl"

Diskutiere USE flag mit "*" (-opengl*) geht nicht mit USE="opengl" im Gentoo Forum im Bereich Linux Distributionen; Hallo, ich habe ein packet bei welches ich mit opengl flag compiliren will, aber wenn ich USE="opengl" als USE Flag angebe passier nichts, es...

  1. #1 GendoIkari, 26.09.2007
    GendoIkari

    GendoIkari Routinier

    Dabei seit:
    04.12.2006
    Beiträge:
    336
    Zustimmungen:
    0
    Ort:
    Dort wo die Sonne aufgeht...
    Hallo,

    ich habe ein packet bei welches ich mit opengl flag compiliren will, aber wenn ich USE="opengl" als USE Flag angebe passier nichts, es steht weiter "-opengl*" da. ;(
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Psyjo

    Psyjo Routinier

    Dabei seit:
    15.11.2005
    Beiträge:
    259
    Zustimmungen:
    0
    Ort:
    Hinter'm Berg
    Ist das Flag eingeklammert?
    Code:
    "(-opengl*)"
    
    wenn ja, dann kannst du das Flag für deine Architektur nicht nutzen.

    Mplayer@AMD64
    Code:
    [...](-vidix) (-win32codecs)[...]
    
    Psyjo
     
  4. nikaya

    nikaya Guest

    Code:
    emerge [B]--newuse[/B] -av <Paket>
     
  5. #4 GendoIkari, 26.09.2007
    Zuletzt bearbeitet: 26.09.2007
    GendoIkari

    GendoIkari Routinier

    Dabei seit:
    04.12.2006
    Beiträge:
    336
    Zustimmungen:
    0
    Ort:
    Dort wo die Sonne aufgeht...
    Ein geklammert ist nichts ,aber schön zu wissen ,was das heißt .
    "emerge --newuse -av " War genau was ich gebraucht hab Danke ;)
    Was hat es eigend lich mit diesen "*" auf sich? Und was bewirkt new use?
     
  6. Psyjo

    Psyjo Routinier

    Dabei seit:
    15.11.2005
    Beiträge:
    259
    Zustimmungen:
    0
    Ort:
    Hinter'm Berg
    Das * bedeutet das dieses Flag neu in diesem Paket vorkommt ;)

    -N/--newuse bewirkt, das Alle Pakete deren UseFlags sich geändert haben, neu gemerg't werden.
     
  7. nikaya

    nikaya Guest

    http://www.gentoo.org/doc/de/handbook/handbook-x86.xml?part=2&chap=1
    Wenn USE-Flags geändert wurden muß immer --newuse (oder -N) zu den Optionen hinzugefügt werden.Ansonsten ignoriert Portage sie.
     
Thema:

USE flag mit "*" (-opengl*) geht nicht mit USE="opengl"

Die Seite wird geladen...

USE flag mit "*" (-opengl*) geht nicht mit USE="opengl" - Ähnliche Themen

  1. Fotos vom Meizu-Flaggschiff Pro 5 mit Ubuntu gesichtet

    Fotos vom Meizu-Flaggschiff Pro 5 mit Ubuntu gesichtet: Auf der Mobilfunk-Webseite GizChina tauchten Fotos des Meizu-Flaggschiffs Pro 5 mit Ubuntu Touch auf. Weiterlesen...
  2. Qt 5.5 Alpha mit Neuauflage von Qt3D

    Qt 5.5 Alpha mit Neuauflage von Qt3D: Die erste Testversion der Version 5.5 der Klassenbibliothek Qt bringt eine überarbeitete Version der Qt3D-Schnittstelle und andere Neuerungen,...
  3. Red Flag Linux vor dem Aus

    Red Flag Linux vor dem Aus: Laut einer Meldung der South China Morning Post schließt die im asiatischen Raum populäre, mit massiver Regierungsunterstützung entwickelte und...
  4. InCoP (Invisible CamOuflage Protocol) 0.2

    InCoP (Invisible CamOuflage Protocol) 0.2: InCoP (Invisible CamOuflage Protocol) enables the communication between secure systems such as NIDS, ideally located in isolated networks. This...
  5. »Linux - Das umfassende Handbuch« in neuer Auflage als OpenBook

    »Linux - Das umfassende Handbuch« in neuer Auflage als OpenBook: Ab sofort steht die aktuelle fünfte Auflage von »Linux - Das umfassende Handbuch« als HTML-Version zur Online-Lektüre und zum Download auf der...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden