USB-Storage Device /SCSI

saiki

Bratwurstgriller
Beiträge
934
Also, ich habe hier an meinem Rechner (mdk9.1) ein kleines Problem.
Ich habe eine Archos Jukebox 6000 (6GB) per USB mit dem Rechner verbunden. Unter usbview wird sie auch angezeigt, das sie vorhanden sei.

Nun will ich sie mounten ('mount -t vfat /dev/sda1 /mnt/removable'), aber da kommt nur:

mount: Gerätedatei /dev/sda1 existiert nicht

Das verwirrt mich allerdings, da im MCC im Hardwaredings unter Festplatten 'sda' steht.

Weiterhin stehen dort 2 identische Geräte 'USB/IDE Bridge (ATA/ATAPI)', allerdings eines unter "Scanner", das andere unter 'Unbekannt/Andere'.

Dann habe ich mal probiert, mittels 'cdrecord -scanbus' etwas herauszufinden. Resultat: cdrecord stürzt ab und läßt sich nicht mehr abbrechen.

Ich habe irgendwie die Vermutung, das es mit dem SCSI-Modul zusammenhängt und/oder das irgendwas 2 mal geladen wird und sich nicht verträgt (2 identische Geräte, unterschiedl. Kat.).

Ich habe aber keine Ahnung, wo ich mit suchen anfangen soll.
Bitte helft mir
;(
 

devilz

Pro*phet
Beiträge
12.245
mach mal in der konsole ein dmesg
und poste mal den output zu dem USB Gerät !
 

saiki

Bratwurstgriller
Beiträge
934
In dmesg steht nichts von einem USB-Gerät, auch nicht von sda.
 

devilz

Pro*phet
Beiträge
12.245
Dann zieh das Gerät mal ab ..... schließ es wieder an ...
und mach gleich mal dmesg ....

Da sollte dann sowas kommen :

scsi1 : SCSI emulation for USB Mass Storage devices
Vendor: Maxtor 4 Model: D060H3 Rev: DAH0
Type: Direct-Access ANSI SCSI revision: 02
Attached scsi disk sda at scsi1, channel 0, id 0, lun 0
SCSI device sda: 120069936 512-byte hdwr sectors (61476 MB)
/dev/scsi/host1/bus0/target0/lun0: p1
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
 

saiki

Bratwurstgriller
Beiträge
934
Also wenn ich die Jukebox abziehe, kommt folgendes:

usb.c: USB disconnect on device 00:02.2-1 address 2


Und das kommt nach dem verbinden:

hub.c: new USB device 00:02.2-1, assigned address 3
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 3


Ich bin ratlos...?(
 

devilz

Pro*phet
Beiträge
12.245
Dann lädt er anscheinend das SCSI Module nicht, oder er erkennt das Device nicht :(
 

saiki

Bratwurstgriller
Beiträge
934
Wie heißt das SCSI-Modul? Ich hatte mal eines (noch aus 9.0er Zeiten) das hies scsi-hostadapter. Das gibt es aber nicht.

lsmod ausgabe (nur die SCSI Sachen, zumindest die, wo ich denke das es welche sind):

scsimon 9344 0 (unused)

usb-storage 72984 0

scsi_mod 103316 3 [sr_mod sd_mod scsimon usb-storage]

usb-ohci 20584 0 (unused)

usbcore 73024 1 [mod_quickcam usb-storage usb-ohci]



PS: Ich hasse Windows, ohne mittlere Maustaste einfügen ist assig, vorallem auf einem Notebook...

PSS: Ich habe noch etwas festgestellt:

1. dmesg:
hub.c: new USB device 00:02.3-1, assigned address 5
scsi0 : SCSI emulation for USB Mass Storage devices
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout
usb_control/bulk_msg: timeout

2: In /dev gibt es kein sda oder sda#.
Das ist irgendwie merkwürdig.
 
Zuletzt bearbeitet:

saiki

Bratwurstgriller
Beiträge
934
Irgendwie gibt dmesg jetzt folgendes aus:

usbdevfs: USBDEVFS_CONTROL failed dev 5 rqt 128 rq 6 len 18 ret -110
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type -1
resize_dma_pool: unknown device type -1
 

devilz

Pro*phet
Beiträge
12.245
mal versucht das generic scsi device zu mounten ?

mount /dev/sg0 ....
 

saiki

Bratwurstgriller
Beiträge
934
Ja, da kommt, das es kein blockorientiertes Gerät sei und es nicht ginge.

'cdrecord -scanbus' bringt jetzt sowas:

Cdrecord 2.0 (i586-mandrake-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

Allerdings hab ich die Jukebox momentan nicht angeschlossen!
 

devilz

Pro*phet
Beiträge
12.245
*lol*

Also du solltest die Box schon angeschlossen haben und zu mounten ...
 

saiki

Bratwurstgriller
Beiträge
934
So, jetzt mal eine positive Nachricht von dmesg:

hub.c: new USB device 00:02.3-1, assigned address 2
scsi0 : SCSI emulation for USB Mass Storage devices
Vendor: TOSHIBA Model: MK6015MAP Rev: U8.1
Type: Direct-Access ANSI SCSI revision: 02
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
SCSI device sda: 11733120 512-byte hdwr sectors (6007 MB)
/dev/scsi/host0/bus0/target0/lun0:


So weit, so gut. Das Teil ist also richtig erkannt worden, aber wie mounte ich es jetzt?

/dev/sda# , /dev/sg# geht nicht.
 

devilz

Pro*phet
Beiträge
12.245
mach mal " ls -Al /dev/scsi/host0/bus0/target0/lun0/"
und poste das hier !
 

saiki

Bratwurstgriller
Beiträge
934
Da steht folgendes da:

insgesamt 0



Mehr nicht. ?( irgendwie bin ich jetzt ganz schön verwirrt ?(

[EDIT]

Ein cat /proc/scsi/usb-storage-0/0 bringt jetzt folgendes, das mich aber noch ratloser macht, den eigentlich sollte es funktionieren:

Host scsi0: usb-storage
Vendor: In-System Design
Product: USB Storage Adapter
Serial Number: C828305AA5E2FF2B
Protocol: ISD200 ATA/ATAPI
Transport: Bulk
GUID: 05ab0031c828305aa5e2ff2b
Attached: Yes
[/EDIT]
 
Zuletzt bearbeitet:

Ähnliche Themen

Festplatte stirbt, dd funktioniert nicht

OpenSuse 11.1 USB Festplatte wird nicht erkannt

Debian Lenny, ATI proprietary, Skystar2, Kaffeine

SCSI Device läßt sich nicht per fstab mounten

4GByte USB Stick lässt sich nicht mounten

Neueste Themen

Oben