Problem mit X

CO²

CO²

Grünschnabel
Hallo

Das hier ist mein erster post hier und ich begrüsse alle recht herzlich. :] So nun zu meinem Problem. Ich habe mandrake 9.1 mit Xfree glaub in der version 1.6.3. Nun also folgendes:
Ich boote Linux und alles verläuft Ordnungsgemäss, bis zu dem Punkt wo X starten sollte. Da stockt kurz das bild auf meinem Monitor und dann lacht mich folgende Fehlermeldung an:
SVGA: Mode 1280 x 1024 needs hsync freq of 75 hz
weitere zeilen mit anderen auflösungen und HZ zahl an dieser stelle...
(**) SVGA: 24bpp not supportet for this Chipset

*** A configured device found but display modes could not be resoled.

Fatal Server error: no screens found

X10: fatal 10 error 104 (connection reset by peer) on X server.

Nun ich habe keine Ahnung was ich dagegen unternehmen könnte... auch zwei neuinstallationen haben, wie sollte es auch anderst sein, nichts gebracht. :D

Ich hoffe ihr könnt mir weiterhelfen.

PS: geiles Forum :respekt:

Gruss CO²

Edit: habe vergessen meine Sytemdaten anzugeben:
Intel pentium 4 2,6 GHZ
Geforce 4 mx 440
256 mb ddr ram
 
Zuletzt bearbeitet:
A

Anzeige

Hallo CO²,

schau mal hier: Problem mit X. Dort wird jeder fündig!
Steve

Steve

13te
du solltest X neu Konifgurieren und zwar manuell.


Steve
 
CO²

CO²

Grünschnabel
also das config file bearbeiten? oder ist da ein script dabei...

[EDIT] hab das config file jetzt... mach mich mal an die arbeit und wenns geht meld ich mich und wenns net geht meld ich mich erst recht lol

Gruss CO²
 
Zuletzt bearbeitet:
CO²

CO²

Grünschnabel
hmm irgendwie schaff ich das nicht... ich kann tun was ich will nichts funzt.. :( aber es muss ja einen weg geben...
 
D

Dr_Ompaa

Hobbyphilosoph
hi CO2 und willkommen im Board :))

Also, schau mal in deiner config File (meistens /etc/X11/XF86Config-4) nach folgendem Abschnitt:

Section "Device"
driver "irgendwas"
...
EndSection


und gib dort als driver "vesa" an

Nun schaust du nach

Section "Screen"
...
DefaultDepth ZAHL
EndSection


und gibst als DefaultDepth 16 an

so, jetzt mal ein glückliches "startx" ^^
 
CO²

CO²

Grünschnabel
danke aber er will immer noch nicht... ;(
Es kommt immer noch die gleiche Meldung...
Mein Momentanes Config File sieht übrigens so aus:

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "/usr/X11R6/lib/modules/extensions/libglx.so"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "de(nodeadkeys)"
Option "XkbCompat" ""
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
HorizSync 30-70
VertRefresh 48-80

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x768" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "1024x768" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "1024x768" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce4 (generic)"
Driver "vesa"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection
 
D

Dr_Ompaa

Hobbyphilosoph
hm ... du kannst mal Folgendes versuchen:

- als driver "nv" nehmen
- vor die Zeilen mit ModeLine ein # setzen (zum auskommentieren)
- vor Load "dbe" ein # setzen
- vor Load "/usr/X11R6/lib/modules/extensions/libglx.so" ein #

viel Glück :))
 
CO²

CO²

Grünschnabel
Super... wird immer besser... ein paar fehler sind weg... danke die hilfe die man hier kriegt ist wirklich erste sahne. :]

Section "Module"
# Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
# Load "/usr/X11R6/lib/modules/extensions/libglx.so"
EndSection

Nun er kann folgende module net laden:

"v4l" extmod"
"type1"
"freetype"

Wisst ihr wie ich den module patch ändern kann?

Gruss CO²
 
Zuletzt bearbeitet:
chb

chb

Steirer
Original geschrieben von CO²


Nun er kann volgende module net laden:

"v4l" extmod"
"type1"
"freetype"

Wisst ihr wie ich den module patch ändern kann?


hmm mach mal

ls /usr/lib/X11R6/modules/fonts

und schau ob da libfreetype.a und libtype1.a drin sind

ls /usr/X11R6/lib/modules/drivers/linux

da sollte v4l_drv.o drin sein - wenn nicht such danach

updatedb (dauert etwas .. )
und dann mach locate libfreetype.a
locate libtype1.a


usw .. und dann wenn du die gefunden hast kopier die in die pfade oben ..
sollte das noch net funktionieren oder sollten die nicht gefunden werden, mußt du wohl XFree neu installieren von den rpms - da gibts was im Mandrake controllcenter bei den rpms da kannst neuinstallieren auswählen bei XFree rpms ..

hth,
chb
 
mario88

mario88

Mitglied
Oder am allerbesten:
Installier den original NVIDIA-Treiber von www.nvidia.com
Da gibts jetzt eh schon nen recht guten "Installer". Dazu brauchst du nur die Kernel-Headers installieren, nen SymLink auf /usr/src/linux machen und die *.run -Datei von NVIDIA ausführen --> das wars. (Dann musst du noch ein paar Zeilen in der /etc/X11/XF86Config-4 anpassen, aber das steht eh in der README.
 

Ähnliche Themen

Ubuntu X / dbus problem

CentOS 6.3 RADIUS - Keine Verbindung möglich

Displayport + externer Monitor zeigt bei startx nichts erst bei DVI

Modulfehler?

Textkonsole mit KMS zu klein

Oben