pppoe einstellen

tpafo

tpafo

Grünschnabel
Hallo,

ich komme von SuSE und habe so meine Probleme beim Konfigurieren von Debian.
Installiert ist Debian Woddy, (Vanilla).
Nun will ich eth0 konfigurieren.
Es wird keine karte gefunden.
Mit modconf werden keine treiber gefunden.
Die Kernel-Module heissen 2.4.18
Modconf versucht im Verz. 2.4.18-4GB zu suchen was nicht existiert.
wenn ich 2.4.18 in 2.4.18-4GB umbenenne werden die treiber zwar gefunden aber
modconf streikt. "es werden treiber für kernerl 2.4.18-4GB gebraucht. die die gefunden werden sind für 2.4.18 kompilliert."

Dann habe ich mal meinen SuSE Kernel mit Modulen ausprobiert. (2.4.18-4GB)
Alles auf die Debian Platte kopiert und los:
pppoeconf: mit suse Kernel findet tap0. (was ist tap0?)
interface wird gescannt aber Fehler angezeigt. Bitte Kabel prüfen!
Befehl: dmesg | grep Eth
zeigt: 8139cp 10/100 PCI Ethernet driver v0.0.7 (Feb 27, 2002)
Der Treiber für meine Karte ist geladen.

Ich komme nicht weiter.
Liegt es an den Kernelmodulen?
An tap0? (was ist tap0?)

vielen Dank für jeden Tip
 
A

Anzeige

devilz

devilz

Pro*phet
Kurztipp: Einstellungen der Netzwerkkarten prüfen

Vielleicht hilft dir das hier weiter :
------------------------------------------
Wie findet man heraus, ob eine Netzwerkkarte im Full-Duplex-Modus läuft, ob sie wirklich 100 Mbit/s macht und nicht nur 10 und so weiter? Und wie stellt man es ggf. um?

Zu letzterem Punkt ist zu sagen, daß die meisten Treibermodule Parameter haben, mit denen man das einstellen kann. Aber die sollten normalerweise nicht notwendig sein, da die Treiber automatisch den passendsten Modus einstellen. Sollte eine Option doch einmal nötig sein, dann muß man sie in /etc/modules.conf einstellen.

Zur ersten Frage lautet die Antwort: Man installiere die Diag-Tools von Donald Becker.

Dann kann man mit "mii-diag" einiges über seine Netzwerkkarte erfahren. Ferner gibt es Chipsatz-spezifische Tools, z.B. via-diag für Karten mit VIA Rhine-Chips. Diese Tools haben u.a. die Optionen -a, -e und -m, die einiges über die Karte anzeigen.

Mit "mii-diag -r eth0" kann man eine neue Autonegotiation anstoßen; mit "mii-diag -A 100baseTX-FD" kann man die Karte von fester Einstellung auf Autonegotiation umstellen. Das -A steht hier für Advertise, also das Bekanntgeben, welchen Modus die Karte unterstützt (alle weniger leistungsfähigen Modi werden dann ebenfalls unterstützt).

Nun noch ein kleiner Dämpfer: Wenn die Karte über einen Hub mit dem Netzwerk verbunden ist, ist prinzipiell nicht mehr als Halbduplex drin. Wenn sie andererseits an einem Switch hängt, sollte Full Duplex über die Autonegotiation ohne Zutun funktionieren.

Ein neueres Programm, ethtool, hat im Prinzip die gleichen Features wie mii-diag und die gleichen Probleme: Noch nicht alle Netzwerktreiber unterstützen das Tool.

Quelle : www.prolinux.de
 
L

lobo

Grünschnabel
Hi,

laut dmesg sieht es so aus, als ob deine Karte schon im Kernel integriert ist, also musst du nur noch 2 Dateien editieren.
in /etc/ppp/pap-secrets
am Ende
"user@t-offline.de" * "passwort"
einfügen.
in /etc/ppp/peers/dsl-provider
ca. Zeile 13 das Wort "user" auskommentieren und
user "user@t-offline.de"
eintragen.
 
MTS

MTS

Kaiser
hi

also ich kann mir nicht vorstellen das die treiber schon im kernel kompiliert sind. Oder hast du deinen eigenen??
was sagt denn dmesg wenn du es ohne die suse module versuchst??
Wenn das ne standard installation ist, ist es aber schon sehr komisch das modprobe im falschen Verzeichnis sucht...
Kompilier dir lieber deinen eigenen kerlnel mit modulen und versuchs dann nochmal.
 
tpafo

tpafo

Grünschnabel
Hat sich erledigt

Der Kernel 2.4.18-4GB ist eine von SuSE abgewandelte Version des
original Linux-Kernel 2.4.18 und somit in Debian nicht enthalten.

Wiso bootet die Debian Distribution einen SuSE Kernel?
Warum sollte Debian einen SuSE Kernel booten lassen?

Was war passiert?

Meine SuSE Distribution läuft auf /dev/hda.
Debian habe ich auf /dev/hdb installiert.

Nachdem ich Debian intalliert hatte und feststellen musste daß die LILO
Konfiguration der Dedian Installation nicht funktionierte, installierte ich
LILO unter SuSE neu.
LILO sitzt bei mir im MBR der /dev/hda!!!
Die Konfiguration zum booten des Debian Kernels auf hdb
benannte ich mit: "/boot/vmlinuz" !!!!!!!!!!
Schwerer Fehler, denn jedes Mal wenn ich im LILO meine Auswahl auf Debian
setzte wurde der SuSE Kernel auf hda gebootet!
Klar daß die Debian Module nicht dazu passten.

Jedenfalls habe ich dann den Debian Kernel auch unter /dev/hda/boot
installiert, womit er dann auch brav bootet!

Der Rest war dann einfach!

Von den "deb" Paketen bin ich begeistert!
Die Werkzeuge, dselect, APT..., ich kenne sicherlich noch nicht alle, sind
genial einfach und machen die Installation sehr bequem.

Ich werde in Kürze komplett auf Debian umsteigen!

Vielen Dank für eure Hilfe!

Gruß
Thomas
 

Ähnliche Themen

Kampf mit Promise TX2200 Raid controller

bttv

DWL-650+ unter Suse 9.1 konfigurieren ?

Häufige RX Errors bei RealTek 8139 Karte

heim netzwerk problem

Sucheingaben

pppoe einstellen

Oben