MySQL Downgrade nach Atomic-Upgrade

W

wodoo

Gast
Hallo Zusammen,

ich habe leider einen etwas doofen Fehler gemacht.

Ich habe auf meinem CentOS:

2.6.18-028stab070.14 #1 SMP Thu Nov 18 16:04:02 MSK 2010 x86_64 x86_64 x86_64 GNU/Linux

die Atomic Updates eingebunden:


und ein yum update gemacht.

Folgende Updates wurden eingespielt (ich benötigte eigentlich nur das PHP-Update):
Updated:
libsepol.i386 0:2.0.36-1.el5.art libsepol.x86_64 0:2.0.36-1.el5.art mysql.x86_64 0:5.1.55-1.el5.art mysql-server.x86_64 0:5.1.55-1.el5.art perl-Archive-Tar.noarch 1:1.39.1-2.el5.art
perl-Font-AFM.noarch 0:1.19-4.el5.art perl-HTML-Format.noarch 0:2.04-6.el5.art perl-HTML-Tree.noarch 1:3.23-9.el5.art php.x86_64 0:5.2.17-1.el5.art php-cli.x86_64 0:5.2.17-1.el5.art
php-common.x86_64 0:5.2.17-1.el5.art php-gd.x86_64 0:5.2.17-1.el5.art php-imap.x86_64 0:5.2.17-1.el5.art php-mbstring.x86_64 0:5.2.17-1.el5.art php-mysql.x86_64 0:5.2.17-1.el5.art
php-pdo.x86_64 0:5.2.17-1.el5.art php-xml.x86_64 0:5.2.17-1.el5.art psa-kronolith.noarch 0:2.1.8-2.el5.art psa-proftpd.x86_64 0:1.3.3c-3.el5.art psa-proftpd-xinetd.x86_64 0:1.3.3c-3.el5.art

Nun lässt sich MySQL nicht mehr starten:

110221 01:56:37 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] option 'innodb-additional-mem-pool-size': signed value 512000 adjusted to 524288
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Warning] /usr/libexec/mysqld: Option '--set-variable' is deprecated. Use --variable-name=value instead.
110221 1:56:37 [Note] Plugin 'ndbcluster' is disabled.
/usr/libexec/mysqld: Table 'mysql.plugin' doesn't exist
110221 1:56:37 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
110221 1:56:37 InnoDB: Initializing buffer pool, size = 2.0M
110221 1:56:37 InnoDB: Completed initialization of buffer pool
110221 1:56:37 InnoDB: Started; log sequence number 0 22291730
110221 1:56:37 [ERROR] /usr/libexec/mysqld: unknown option '--skip-bdb'
110221 1:56:37 [ERROR] Aborting

110221 1:56:37 InnoDB: Starting shutdown...
110221 1:56:42 InnoDB: Shutdown completed; log sequence number 0 22291730
110221 1:56:42 [Note] /usr/libexec/mysqld: Shutdown complete

110221 01:56:42 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended

Wenn ich ein
yum downgrade mysql

machen würde, würden etwa 30 pakete wegen Abhängigkeit mit deinstalliert, das würde wohl massig Ärger geben.

Wie kann ich diese MySQL-Version wieder downgraden ODER den obigen Fehler beheben?

Ich kann kein "mysql_upgrade" durchführen, weil:
mysqlcheck: Got error: 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) when trying to connect
FATAL ERROR: Upgrade failed

Ich hoffe, ihr könnte mir helfen.

Herzlichen Dank!
 

foexle

Kaiser
Beiträge
1.104
Also zum Downgrade kann ich dir leider nichts sagen, aber das sind doch nur einfache Anpassungen in der Config. Steht doch genau da, was falsch ist.
Sind doch nur deprecated Variabeln die du umbenennen musst. Dann sollte das wieder laufen.


Grüße
 

Ähnliche Themen

Ich mag Dovecot nicht ...

X startet nichtmehr

JBidWatcher: Problem bei loading Auctions in Verbindung mit mySQL

Akonadi startet nicht mehr

NagiosGrapher 1.7.1 funktioniert nicht

Oben