Mondorescue über Cron-Job

jgrieb

Jungspund
Beiträge
17
Ich habe Mondorescue auf SUSE 10.3 installiert um mein System zu sichern. Dabei sind 2 Probleme aufgetreten für die ich keine Lösung habe:
1. Problem (das größte)
Von der Konsole funktioniert es soweit, wenn ich das Backup allerdings über einen Cron-Job starten will bricht es jedes Mal ab.
Hier meine mondoarchive.log
PHP:
Time started: Mon Mar 23 15:30:01 2009

running: dmesg -n1 > /dev/mondo.tmp.vAqR8K/mondo-run-prog-thing.tmp 2> /dev/mondo.tmp.vAqR8K/mondo-run-prog-thing.err
--------------------------------start of output-----------------------------
--------------------------------end of output------------------------------
...ran just fine. :-)
Mondo Archive v2.2.6-r1976 --- http://www.mondorescue.org
running i386 binaries
running on i686 architecture
-----------------------------------------------------------
NB: Mondo logs almost everything, so don't panic if you see
some error messages.  Please read them carefully before you
decide to break out in a cold sweat.    Despite (or perhaps
because of) the wealth of messages. some users are inclined
to stop reading this log. If Mondo stopped for some reason,
chances are it's detailed here.  More than likely there's a
message at the very end of this log that will tell you what
is wrong. Please read it!                          -Devteam
-----------------------------------------------------------
Zero...
[Main] mondoarchive.c->welcome_to_mondoarchive#116: One...
	[Main] mondoarchive.c->welcome_to_mondoarchive#117: Two...
		[Main] mondoarchive.c->welcome_to_mondoarchive#118: Three...
			[Main] mondoarchive.c->welcome_to_mondoarchive#119: Four...
	[Main] mondoarchive.c->distro_specific_kludges_at_start_of_mondoarchive#136: Unmounting old ramdisks if necessary
running: umount `mount | grep shm | grep mondo | cut -d' ' -f3` > /dev/mondo.tmp.vAqR8K/mondo-run-prog-thing.tmp 2> /dev/mondo.tmp.vAqR8K/mondo-run-prog-thing.err
--------------------------------start of output-----------------------------
Usage: umount [-hV]
umount -a [-f] [-r] [-n] [-v] [-t vfstypes] [-O opts]
umount [-f] [-r] [-n] [-v] special | node...
--------------------------------end of output------------------------------
...ran with res=512
running: mount | grep cdrom | grep super > /dev/mondo.tmp.vAqR8K/mondo-run-prog-thing.tmp 2> /dev/mondo.tmp.vAqR8K/mondo-run-prog-thing.err
--------------------------------start of output-----------------------------
--------------------------------end of output------------------------------
...ran with res=256
running: mount | grep floppy | grep super > /dev/mondo.tmp.vAqR8K/mondo-run-prog-thing.tmp 2> /dev/mondo.tmp.vAqR8K/mondo-run-prog-thing.err
--------------------------------start of output-----------------------------
--------------------------------end of output------------------------------
...ran with res=256
[Main] libmondo-tools.c->mount_boot_if_necessary#1242: Started sub
			[Main] libmondo-tools.c->mount_boot_if_necessary#1243: About to set g_boot_mountpt[0] to '\0'
			[Main] libmondo-tools.c->mount_boot_if_necessary#1245: Done. Great. Seeting command to something
			[Main] libmondo-tools.c->mount_boot_if_necessary#1248: Cool. Command = 'grep -v ":" /etc/fstab | grep -vE '^#.*$' | grep -E "[ 	]/boot[ 	]" | tr -s ' ' '	' | cut -f1 | head -n1'
			[Main] libmondo-tools.c->mount_boot_if_necessary#1250: tmp = ''
[Main] libmondo-tools.c->mount_boot_if_necessary#1288: Ended sub
[Main] libmondo-tools.c->get_kernel_version#262: g_kernel_version = 2.622000
running: rm -Rf /var/cache/mondo/changed.files* > /dev/mondo.tmp.vAqR8K/mondo-run-prog-thing.tmp 2> /dev/mondo.tmp.vAqR8K/mondo-run-prog-thing.err
--------------------------------start of output-----------------------------
--------------------------------end of output------------------------------
...ran just fine. :-)
Checking sanity of your Linux distribution
running: grep ramdisk /proc/devices > /dev/mondo.tmp.vAqR8K/mondo-run-prog-thing.tmp 2> /dev/mondo.tmp.vAqR8K/mondo-run-prog-thing.err
--------------------------------start of output-----------------------------
--------------------------------end of output------------------------------
...ran with res=256
Ich bin dabei genau nach dem How To vorgegangen (http://www.mondorescue.org/docs/mondorescue-howto.html#BACKUP-CRON)
- Mit dem at-Befehl ein sript erstellen lassen
- dieses script editiert
- anschließend über Webmin als Cron-Job eingerichtet.
Starte ich den Cron-Job manuell über Webmin funktioniert alles.
Nur beim zeitgesteuerten Start nicht.
Nachfolgend poste ich auch mal mein Script welches ich über den at-Befehl erstellt habe und als Cron-Job verwende.
PHP:
#!/bin/sh
# atrun uid=0 gid=0
# mail     root 0
umask 22
DOCUMENT_REALROOT=/usr/libexec/webmin; export DOCUMENT_REALROOT
BASE_REMOTE_USER=; export BASE_REMOTE_USER
MINISERV_CONFIG=/etc/webmin/miniserv.conf; export MINISERV_CONFIG
HTTP_USER_AGENT=Mozilla/5.0\ \(compatible\;\ Konqueror/3.5\;\ Linux\)\ KHTML/3.5.7\ \(like\ Gecko\)\ SUSE; export HTTP_USER_AGENT
HTTP_HOST=localhost:10000; export HTTP_HOST
SERVER_PORT=10000; export SERVER_PORT
LD_LIBRARY_PATH=; export LD_LIBRARY_PATH
HTTP_ACCEPT_CHARSET=utf-8,\ utf-8\;q=0.5,\ \*\;q=0.5; export HTTP_ACCEPT_CHARSET
DOCUMENT_ROOT=/usr/libexec/webmin; export DOCUMENT_ROOT
HTTPS=ON; export HTTPS
SCRIPT_FILENAME=/usr/libexec/webmin/at/create_job.cgi; export SCRIPT_FILENAME
REQUEST_URI=/at/create_job.cgi\?user=root\&day=23\&month=2\&year=2009\&hour=08\&min=00\&dir=%2F\&cmd=mondoarchive+-Oi+-d+%2Fbackup%2Fbkp%2Fmondo+-E+%27%2Fbackup+%2Fsrv+%2Fhome%27+-p+%60hostname%60++; export REQUEST_URI
SCRIPT_NAME=/at/create_job.cgi; export SCRIPT_NAME
REMOTE_HOST=127.0.0.1; export REMOTE_HOST
REMOTE_USER=root; export REMOTE_USER
HTTP_CONNECTION=Keep-Alive; export HTTP_CONNECTION
PATH_INFO=; export PATH_INFO
PATH=/bin:/usr/bin:/sbin:/usr/sbin:/usr/local/bin:/bin:/sbin:/usr/bin:/usr/sbin; export PATH
SERVER_REALROOT=/usr/libexec/webmin; export SERVER_REALROOT
PWD=/; export PWD
SERVER_ADMIN=; export SERVER_ADMIN
SERVER_ROOT=/usr/libexec/webmin; export SERVER_ROOT
WEBMIN_CONFIG=/etc/webmin; export WEBMIN_CONFIG
HTTP_ACCEPT_LANGUAGE=de,\ en; export HTTP_ACCEPT_LANGUAGE
HTTP_REFERER=https://localhost:10000/at/; export HTTP_REFERER
HTTP_ACCEPT=text/html,\ image/jpeg,\ image/png,\ text/\*,\ image/\*,\ \*/\*; export HTTP_ACCEPT
REMOTE_ADDR=127.0.0.1; export REMOTE_ADDR
SHLVL=1; export SHLVL
SERVER_NAME=localhost; export SERVER_NAME
HOME=/root; export HOME
SERVER_SOFTWARE=MiniServ/0.01; export SERVER_SOFTWARE
WEBMIN_VAR=/var/webmin; export WEBMIN_VAR
QUERY_STRING=user=root\&day=23\&month=2\&year=2009\&hour=08\&min=00\&dir=%2F\&cmd=mondoarchive+-Oi+-d+%2Fbackup%2Fbkp%2Fmondo+-E+%27%2Fbackup+%2Fsrv+%2Fhome%27+-p+%60hostname%60++; export QUERY_STRING
GATEWAY_INTERFACE=CGI/1.1; export GATEWAY_INTERFACE
SERVER_PROTOCOL=HTTP/1.0; export SERVER_PROTOCOL
HTTP_ACCEPT_ENCODING=x-gzip,\ x-deflate,\ gzip,\ deflate; export HTTP_ACCEPT_ENCODING
HTTP_COOKIE=\;\ testing=1; export HTTP_COOKIE
REQUEST_METHOD=GET; export REQUEST_METHOD
OLDPWD=/usr/libexec/webmin/at/; export OLDPWD
cd / || {
	 echo 'Execution directory inaccessible' >&2
	 exit 1
}
screen -m -d mondoarchive -Oi -d /backup/bkp/mondo -E '/backup /srv /home' -p `hostname`
2. Problem
Ich lasse von mondo ISO-Images erstellen und diese auf Festplatte schreiben.
Die Images haben dabei CD-Größe. Das ist definiv aber auch die einzige Variante, die bei mir funktioniert. Wenn ich über den -s Parameter eine andere Image-Größe angebe, bricht das Backup mit Fehler ab.
Wenn ich als Speichermedium CD oder DVD angebe, dann wird ebenfalls abgebrochen mit der Fehlermeldung "No Hardwaresupport for mein Mainboard-Typ.
Ich habe aber ansonsten keinerlei Probleme mit meiner Hardware. Kann auch CD's und DVD's brennen.
Vielleicht hat einer eine Idee?.
 

Ähnliche Themen

JBidWatcher: Problem bei loading Auctions in Verbindung mit mySQL

dovecot und postfix Konfiguration Problem

Samba 4 Gast Zugang unter Ubuntu funktioniert nicht

OpenSuse 12.3 / Tiefschlaf funktioniert nicht

X not starting anymore since filesystem was full

Oben