Linux und Flash

mighty_duck

mighty_duck

Jungspund
Moin.
Ich habe unter Linux immer Probleme mit Flash-Inhalten. Ich dachte das wäre vielleicht ein allgemeines Problem, weil Flash eher für Windows entwickelt wird, aber unter Ubuntu habe ich eine Konfiguration gefunden, mit der es fehlerfrei geht, also müsste man das doch irgendwie hinbekommen.

Das Problem:

openSUSE mit Macromedia Flash, Firefox 2 und Opera
- Flash-Filme werden abgespielt, aber danach stürzt der Browser ab (sobald eine neue Seite anfängt zu laden). firefox-bin muss gekillt werden damit ich ff neu starten kann.
Das Problem kann manchmal dadurch umgangen werden, dass man das Video zuende laden lässt.

openSUSE mit swfdec
- einige Videos laufen fehlerfrei, andere verursachen gleich beim Start einen Crash. Beispiele:
geht: http://youtube.com/watch?v=hqNRsOWx5mA
geht nicht: http://youtube.com/watch?v=kIH-FZDSL2s (the program is not responding)

Dann habe ich mal Ubuntu getestet mit der Firefox 3 Beta (Browser ist aber vermutlich unwichtig). Macromedia Flash installiert und: Es geht alles.
Weiter das System eingerichtet, die gstreamer Plugins für mp3 und divx installiert und auf einmal tritt das selbe Problem wie unter openSUSE mit Macromedia Flash auf. Zusätzlich haben die Videos keinen Sound.
gstreamer Plugins wieder entfernt und alles funktioniert perfekt. Zumindest unter Ubuntu ist das Problem also reproduzierbar und hängt wohl irgendwie mit den Codecs zusammen. Da liegt es nahe, dass das bei openSUSe auch so ist. Dort benutze ich libxine1, xvid und fluendo für die Codecs.

Hat jemand eine Idee was ich machen kann?
 
A

Anzeige

Hallo mighty_duck,

schau mal hier: Linux und Flash. Dort wird jeder fündig!
kartoffel200

kartoffel200

AMD Fanboy Since 2003
Haste nen Flash RPM installiert oder den Tarball oder hat sich dein Feuerfurz den Automatisch geholt.
 
mighty_duck

mighty_duck

Jungspund
Ich habe alles entfernt und dann direkt über Firefox Flash geladen und es scheint zu gehen.
Wenn doch Probleme auftreten sollten versuche ich es mit dem Tarball und wenn es dann nicht geht melde ich mich noch mal, aber hoffen wir mal dass das nicht passiert! Danke :)
 
mighty_duck

mighty_duck

Jungspund
Nach kurzer Zeit war der Fehler wieder da... Ich habe die Plugins aus dem Firefox Ordner entfernt und dann die .tar.gz Datei von adobe.com geladen und installiert. Es hat sich aber dadurch nichts geändert.

Keine Ahnung, warum es am Anfang so gut funktioniert hat und jetzt nicht mehr. Habe sonst nichts am System verändert.
 
Zuletzt bearbeitet:

Ähnliche Themen

flash geht nicht unter firefox aber unter konqueror

Firefox -> Flash funktioniert nicht / nicht richtig

Firefox 3 Sound weg (fash)

ffmpeg - bei Videoumwandlung Audio nur als mp2 möglich

Oben