Kompilier Prob

Root

Root

@dmin
Wollte mir eben ReZound Installiern. Genialer Soundeditor. Mein Gentoo hatt natürlich davor probiert alle abhängikeiten zu installiern. Bei der letzten bekomm ich Error. Wenn er mir Fox installiert.

Was genau is das fox ??
Was is das für ein Error ???
Kennt sich da wär bissi aus und kann mir sagen was ihm fehlt oder was ich falsch gemacht habe ??


++ -DHAVE_XSHM -DHAVE_JPEG_H=1 -DHAVE_PNG_H=1 -DHAVE_TIFF_H=1 -DHAVE_ZLIB_H=1 -DHAVE_CUPS_H=1 -Wall -W -Wmissing-prototypes -Woverloaded-virtual -Wformat -DHAVE_OPENGL -DSUN_OGL_NO_VERTEX_MACROS -DHAVE_MESA -I/usr/X11R6/include -o .libs/rex rex.o ../src/.libs/libFOX.so -L/usr/X11R6/lib -lXext -lX11 -lMesaGL -lMesaGLU /usr/lib/libjpeg.so -lpng -ltiff -lz -lm -lcups -lnsl
/usr/lib/gcc-lib/i586-pc-linux-gnu/3.2.2/../../../../i586-pc-linux-gnu/bin/ld: Warning: type of symbol `__nvsym11369' changed from 2 to 1 in /usr/lib/libGLcore.so.1
/usr/lib/gcc-lib/i586-pc-linux-gnu/3.2.2/../../../../i586-pc-linux-gnu/bin/ld: Warning: type of symbol `__nvsym11267' changed from 2 to 1 in /usr/lib/libGLcore.so.1
/usr/lib/gcc-lib/i586-pc-linux-gnu/3.2.2/../../../../i586-pc-linux-gnu/bin/ld: Warning: type of symbol `__nvsym15251' changed from 2 to 1 in /usr/lib/libGLcore.so.1
/usr/lib/gcc-lib/i586-pc-linux-gnu/3.2.2/../../../../i586-pc-linux-gnu/bin/ld: Warning: type of symbol `__nvsym15205' changed from 2 to 1 in /usr/lib/libGLcore.so.1
/usr/lib/gcc-lib/i586-pc-linux-gnu/3.2.2/../../../../i586-pc-linux-gnu/bin/ld: Warning: type of symbol `__nvsym06316' changed from 1 to 2 in /usr/lib/libGLcore.so.1
/usr/lib/gcc-lib/i586-pc-linux-gnu/3.2.2/../../../../i586-pc-linux-gnu/bin/ld: Warning: type of symbol `__nvsym14608' changed from 2 to 1 in /usr/lib/libGLcore.so.1
/usr/lib/gcc-lib/i586-pc-linux-gnu/3.2.2/../../../../i586-pc-linux-gnu/bin/ld: Warning: type of symbol `__nvsym06229' changed from 2 to 1 in /usr/lib/libGLcore.so.1
/usr/lib/libGLcore.so.1: undefined reference to `__nvsym14780'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym06957'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym15158'
/usr/lib/libGLcore.so.1: undefined reference to `__nvsym16889'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym15136'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym14652'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym14619'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym14655'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym14747'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym06960'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym14662'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym15151'
/usr/lib/libGLcore.so.1: undefined reference to `__nvsym15095'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym14651'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym14791'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym15252'
/usr/lib/libGLcore.so.1: undefined reference to `__nvsym14822'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym15138'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym16865'
/usr/X11R6/lib/libMesaGL.so: undefined reference to `__nvsym15166'
collect2: ld returned 1 exit status
make[1]: *** [rex] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/fox-1.0.40/work/fox-1.0.40/tests'
make: *** [all-recursive] Error 1

!!! ERROR: x11-libs/fox-1.0.40 failed.
!!! Function src_compile, Line 37, Exitcode 2
!!! Parallel Make Failed



THX schon mal :(
 
A

Anzeige

Hallo Root,

schau mal hier: Kompilier Prob. Dort wird jeder fündig!
M

merc

Foren As
Also zu der frage was Fox ist sagt emerge mir: "C++ based Toolkit for developing Graphical User Interfaces easily a nd effectively"

Deinen fehler kenne ich zwar so nicht aber bei mir hat es schon öfters geholfen einfach mal den Rechner rebooten und nochmal probieren ohne andere compile vorgänge oder sonstiges nebenbei laufen zu lassen ... vielleicht gehts dann.
 
chb

chb

Steirer
hmm da liegt was bei mesa im argen .. versuch mal neuere version zu compilen / installen .. vielleicht hilfts
 
Root

Root

@dmin
Also ich hab mal nach Mesa gesucht und da meinte er das sei nicht installiert. Also ein emerge Mesa(3.5) durchgeführt, ERROR.
Also im Web die neuste version gesucht, Mesa (5.1 oder so). Installiertt, keine Errors.

Fox neu probiert, wieder selbe Fehler. Alte und neuere Version probiert genau das selbe. :( :( :( :(
 
Root

Root

@dmin
Ok hab den Fehler. Ich versuche schon seit über 2 wochen ohne erfolg meine nvidia Treiber zu installiern. Die aber leider net laufen. Doch beim install von nvidia-glx macht er folgendes opengl-update nvidia. Wenn ich das wieder umstelle auf opengl-update xfree86 klappts jetzt endlich. *freu*
 

Ähnliche Themen

Nginx als Reverse Proxy für Nextcloud und Emby

Zugriff Ubuntu 16.04. auf Freigabe 18.04. LTS nicht möglich

grub-pc Probleme bei upgrade

X startet nichtmehr

OpenJDK8 unter Debian7.11/sparc64/kernel 3.16 kompilieren

Oben