Knoppix -> NVIDIA Treiber

-Shark-

-Shark-

Jungspund
Hi

Da ich noch ein relativer linux newbie bin schlagt mich nicht zu stark wenn ich dumme fragen stelle :) Also mein problem ist:

Nachdem ich es geschafft hatte den Xserver zu beenden wollte ich endlich den NVIDIA treiber installieren! Er startete auch die installlation . Dann kam ein Fehler das er noch einen Kernel benötige und diesen nun downloaden wolle! Ich dachte mir : Ja ok kein problem ! Er fand aber keinen Kernel der zu Knoppix passte ! Also beschloss ich den Kernel selbst downzuloaden vom FTP von NVIDIA. Ich habe mir die tar.gz downgeloadet. Als ich diesen nun installieren wollte sagte er das irgendetwas mit einer GCC nicht stimme!
Ich bin echt verzweifelt danke für eure Hilfe !

Shark
 
A

Andre

Foren Gott
Das mit dem Mismatch kannst du idR beheben, indem du in die ".bashrc" von root folgendes einträgst:
CC=/usr/bin/gcc-3.3; export CC


die gcc version musst du idr noch apassen...also zB 2.95 oder sowas...
du musst dan nur vor dem "bauen" des Kernels auf die bash wechseln ;-)

Gruss Andre
 
-Shark-

-Shark-

Jungspund


die gcc version musst du idr noch apassen...also zB 2.95 oder sowas...
du musst dan nur vor dem "bauen" des Kernels auf die bash wechseln ;-)

Gruss Andre

Das andere habe ich gemacht aber wie passe ich die GCC version an ? Und ich habe 2.95 !

MfG Shark
 
Havoc][

Havoc][

Debian && Gentoo'ler
Original geschrieben von andre
[...] CC=/usr/bin/gcc-2.95; export CC [...]
Das solltest du anpassen...
schau halt nach wie die file bei dir heisst und ändere deine bashrc demnach ab.

Ciao Havoc][
 
-Shark-

-Shark-

Jungspund
ich habe es probiert aber es klappte wieder nicht :( ich kopiere mal die log hierrein villeicht hilft das ....

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Tue Aug 19 15:24:14 2003

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel include path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Kernel include path: '/lib/modules/2.4.20-xfs/build/include'
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f nv.o os-agp.o os-interface.o os-registry.o nv-linux.o nv_compiler.h *
.d NVdriver nvidia.o
-> Building kernel module:
executing: 'cd ./usr/src/nv; make nvidia.o SYSINCLUDE=/lib/modules/2.4.20-xf
s/build/include'...

You appear to be compiling the NVIDIA kernel module with
a compiler different from the one that was used to compile
the running kernel. This may be perfectly fine, but there
are cases where this can lead to unexpected behaviour and
system crashes.

If you know what you are doing and want to override this
check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the
name of the compiler that was used to compile the kernel.

*** Failed cc sanity check. Bailing out! ***
make: *** [gcc-check] Fehler 1
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
 
A

Andre

Foren Gott
schau mal in dein "/usr/bin/" Verzeichnis...da muss das gcc-2.95 liegen...
wen dem so ist, must du in die .bashrc ( von ROOT) nur:
CC=/usr/bin/gcc-2.95; export CC
eintragen....
dann sollte es eigentlich mit einem
bash
make install funktionieren....
?(
 
-Shark-

-Shark-

Jungspund
in root habe ich diese datei garnicht ! Ich habe diese datei 2 mal in folgenden pfaden:

etc/skel
home/knoppix/

Bei beiden habe ich die änderung vorgenommen aber es klappt nicht !
Aber ich habe gerade etwas relativ interesantes entdeckt:

Wenn ich im Kontrollzentrum auf Systemverwaltung gehe dann auf Linux-Kernel...
Nun kommt nur eine ziemlich dicke fehlermeldung ! Wenn mir einer sagt wie man im Linux Screenshots macht zeige ich euch den fehler .. ! Auf jedenfall sagt er das er die Kernel Einrichtung nicht lesen kann ...

MfG Timo
 
A

Andre

Foren Gott
also bei mir im /root
liegt die datei mit folgendem Inhalt:
###########.bashrc################

# ~/.bashrc: executed by bash(1) for non-login shells.

export PS1='\h:\w\$ '
umask 022
CC=/usr/bin/gcc-2.95; export CC
# You may uncomment the following lines if you want `ls' to be colorized:
# export LS_OPTIONS='--color=auto'
# eval `dircolors`
# alias ls='ls $LS_OPTIONS'
# alias ll='ls $LS_OPTIONS -l'
# alias l='ls $LS_OPTIONS -lA'
#
# Some more alias to avoid making mistakes:
# alias rm='rm -i'
# alias cp='cp -i'
# alias mv='mv -i'

########ende##################
speicher das mal unter /root/.bashrc und versuch es nochmal....
bei "flutscht" das ?(


alternativ mal im Knoppixforum schauen...hab da was von einem speziellen installer gelesen...
http://www.linuxtag.org/cgi-bin/yabb/YaBB.pl?board=hardware;action=display;num=1058010885;start=0
 
-Shark-

-Shark-

Jungspund
cool danke ! Der installer hat geholfen ! Alles geht ! Jetzt habe ich noch ein anderes problem *gg* aber da mach ich glaub einen neuen Thread auf ! Aber ich kanns ja schonmal sagen:

MP3s anhören geht sowie dvd schauen und so ! Also sound geht :D Aber sobald ich ins Teamspeak 2 connecte mutet es mir den sound und das mikro ! Auserdem wenn ich UT 2003 spiele habe ich da auch keinen sound ! Ich glaube es hat etwas mit arts zu tun aber nal gucken :D

Danke nochmal für die hilfe !
MfG Timo
 

Ähnliche Themen

nvidia-Treiber: Virtuelle Terminals bleiben schwarz

NVIDIA Treiber und Ubuntu 8.04 = Problem

[HowTo] NVidia und 3D unter SuSE/openSUSE

OpenSUSE 10.3, 3D-Beschleunigung, NVIDIA Geforce 7600 Go, Problem mit Einrichtung

[Debian] NVidia Treiber -> Kernel Version? / Kernel Frage

Sucheingaben

knoppix 7.4 nvidia treiber

Oben