[HowTo] NVidia und 3D unter SuSE/openSUSE

Ritschie

Leap-User
Beiträge
1.218
NVidia und 3D unter SuSE/openSUSE



Da dieses Thema immer wieder ein Problem zu sein scheint, hier mal ein kleines HowTo, das auch für Noobs verständlich sein sollte.

Um 3D-Unterstützung zu haben, benötigt Ihr nicht den quelloffenen und freien nv-Treiber, der per default genutzt wird, sondern den proprietären Treiber von NVidia. Den gibt's hier: http://www.nvidia.de/object/linux_de.html. Sollte der Treiber in Eurem Browser als Text angezeigt werden, einfach mit dem Browser über Datei -> Seite speichern unter ... abspeichern. In dem Fall aber bitte warten, bis der Treiber komplett im Browser hochgeladen ist. Es gibt noch die Möglichkeit, den NVidia-Treiber über YaST-Repositories zu installieren. Auf diese Möglichkeit geht dieses HowTo nicht ein. Auch 1-Click-Intallation wird nicht angesprochen.



Vorbereitende Arbeiten:

Überprüfe in YaST, ob die kernel-sources, make und gcc installiert sind. Wenn nicht, diese nachinstallieren. Anschließend noch ein YaST Online Update durchführen, damit alles in der aktuellen Version vorliegt.

Lege den Treiber irgendwo ab, wo er leicht zu finden ist. Ich würde einfach das /home-Verzeichnis empfehlen (z.B. /home/ritschie).

Zur eigentlichen Installation musst Du Dich aus der grafischen Oberfläche abmelden und alle mit X zusammenhängenden Dienste beenden. Also logst Du Dich aus. Nutzt Du KDE, geht das über "Abmelden" im KDE-Menü. Nun landest Du im Anmeldebildschirm des Display Managers (KDM). Dort wechselst Du über Alt+Strg+Fx in eine andere virtuelle Konsole, oder wählst unten links unter "System" den Text-Konsolen Modus. Nicht erschrecken, jetzt wird's dunkel und ist nicht mehr so bunt :D DOS-ähnlich halt.

Die Treiber-Installation muss als root ausgeführt werden: einfach root eintippen. Anschließend wirst Du nach dem root-Passwort gefragt. Bei dessen Eingabe werden keine Platzhalter angezeigt! Das ist normal! Also unbeirrt das Passwort eingeben und mit Enter bestätigen.



Die Installation​

Nun werden folgende Befehle eingetippt:

Code:
[I]init 3[/I]
beendet X komplett.

Code:
[I]cd /home/ritschie[/I]
damit wechselst Du in den Ordner, in dem sich der Treiber befindet. Du musst natürlich den Pfad verwenden, an dem Du den Treiber vorhin gespeichert hast.

Code:
[I]sh [B]NVIDIA-Linux-x86-169.09-pkg1.run[/B] -q[/I]
sh ist der Befehl. Das fett geschriebene ist der Name des Treibers - hier muss natürlich die Version Deines Treibers eingetragen werden. Das -q ist eine Option, die verhindert, dass der Treiber auf der Homepage von NVidia nach einem vorkompilierten Kernelmodul sucht - dieses schlägt nämlich immer fehl. Les Dir dann ruhig die Abfragen durch. In der Regel kannst die aber einfach abnicken)

Code:
[I]sax2 -r -m 0=nvidia[/I]
0 ist eine Zahl, kein Buchstabe. Nach diesem Befehl musst Du kurz warten, bis sich was tut. SaX2 konfiguriert nun die grafischen Einstellungen und speichert diese nach Bestätigen mit OK in der xorg.conf.

Code:
[I]init 5[/I]
Dienste für X werden wieder gestartet.

Achtung! Alles genau so abtippen. Auch die Leerzeichen und Groß- und Kleinschreibung beachten. Nach jeder Zeile die Eingabetaste drücken.

Wenn Du jetzt startx eintippst, solltest Du wieder in Deiner gewohnten grafischen Oberfläche landen und Du dürftest 3D-Beschleunigung haben.

Die Einstellungen im NVidia-Treiber kannst Du mit dem Befehl nvidia-settings ansehen. Falls Du dort was ändern und direkt in der xorg.conf speichern willst, starte die Settings mit Superuser-Rechten mit dem Befehl kdesu nvidia-settings. Nach Eingabe des root-Passwortes hast Du die Berechtigung, in die xorg.conf zu schreiben. Unter X Server Display Configuration findest Du die Schaltfläche (Save to X Configuration File) dafür.


Nach der Installation​

Der NVidia-Treiber kann mit folgendem Befehl aktualisiert werden:
Code:
nvidia-installer --update

Nach jedem Kernel-Update geht der NVidia-Treiber leider verloren und Du kommst nur noch in die Textkonsole. Um das Problem zu beheben, mit dem Bootparameter init 3 starten, als root anmelden und den Treiber mit folgendem Befehl recompilieren:
Code:
sh NVIDIA-Linux-x86-169.09-pkg1.run -K
Anschließend ein init 5 und ein startx und alles sollte wieder laufen.

Ergänzung dazu von gropiuskalle: die '-K'-Option eignet sich auch dann, wenn mehrere Kernel installiert sind. Man kann also den ersten Kernel (welcher ist egal) ganz regulär mit dem Treiber ausstatten und setzt ab dem zweiten Kernel einfach das '-K' ab (ansonsten funktioniert der Treiber immer nur auf einen Kernel).

Weitere Ergänzung zu den NVidia-Settings von gropiuskalle - die grafische Version der Settings stellt wohl keine Option zur Aktivierung von nv-glx zur Verfügung, im Sinne der Performancesteigerung wäre dies aber zu empfehlen. Folgende Befehle als root absetzen (diese aktivieren Composite-Fähigkeiten, nx-glx und setzen die Farbtiefe auf 24bit):

Code:
nvidia-xconfig --composite
nvidia-xconfig --allow-glx-with-composite
nvidia-xconfig --render-accel
nvidia-xconfig --add-argb-glx-visuals -d 24




So, ich hoffe, ich hab Dich jetzt nicht mit Informationen Erschlagen :D

Leutz, hab ich was vergessen? Oder nen Fehler drin? Ich hoffe nicht. Anregungen bitte per PN oder eMail an mich und nicht hier in diesem Thread. Ich werd sie dann einarbeiten. Das selbe gilt auch für Fragen. Dafür lieber nen extra Thread. Das HowTo sollte so übersichtlich wie möglich bleiben.


An die Admins und Mods: Sollte es dieses HowTo bereits irgendwo geben (hab die Suche benutzt, aber nix gefunden), bitte einfach löschen. Ansonsten wär's nett, man könnte es sticky setzen.

Viel Erfolg.

Gruß,
Ritschie
 
Zuletzt bearbeitet:

sinn3r

Law & Order
Moderator
Beiträge
2.769
Warum nicht in unser Wiki?

Wuerds selber portieren, aber davon hab ich kein Schimmer ;)

Sieht nach guter Arbeit aus.
 

Ähnliche Themen

Nvidia Hybrid-Grafikkarte: 3D Beschleunigung will nicht

XFCE freezes at startup

Nvidia und OpenSuse

Geforce GT 240m - Aspire 5739G - Treiberproblem - 6 faches Bild

OpenSUSE 10.3, 3D-Beschleunigung, NVIDIA Geforce 7600 Go, Problem mit Einrichtung

Oben