GrafikProblem Gnome - XSession verbaut

Ticha

Ticha

Linux Missionar
Hallo Leute

ich habe gerade ein RIESEN Problme.

Gerade habe ich meinen Rechner gestartet und Ubuntu hochgefahren. Kommt eine Meldung von Gnome-display-manager, ich solle menen Bildschirm auswählen, den er irgendwie aus der confoig gelöscht hat.

Daraufhin starttet Gnome mit ausgeschaltetem Compiz und einer auflösung von 800x600 (normal 1024x768)

nachdem ich mich durch die Wiudgets durchgekämpoft habe, die normalerweise im Compiz Widget layer versteckt sein sollten, versuchte ich die Auflösung hoch zuschrauben. Ging nicht.

Daraufhin habe ich neugetstsratt und musste feststellen, dass mein Anmeldefenster erine zu Hohe auflösung hat und deshlab nicht ganz angezeigt wird , wodruch ich nicht einmal eine andere Sitzung wählen kann, sondern mich nur einloggen kann.

Als ich mich einloggte, seh ich nur ncioh alles verzerrt, weil die Ausflösung und die Hertz Zahl zu hoch eingestellt ist. Also ich kann gar nichts der gnome-utils benutzen oder der Ubuntu tools , allgemein nichts Grafisches.

Mir ist aufgefallen, dass er irgendwie die Nvidia Treiber gekillt hat. Diese wollte ich neuinstallieren, was auch nicht so richtiggeklappt hat.

1 .Wie kann ich das alle irgendwie wieder hinbiegen?

2. ich habe noch blackbox und fliuxbox drauf, wo muss ich was einstellen, dass eines der beiden direkt startet anstatt gnome?


bitte um shcnell hilfe...

?(?(

EDIT:

also ich habe es hinbekommn gnome und den Anmelde manger wieder in einer angenehmen auflösung, 800x600 zu öffnen.

Aber er wil die Nvidia Treiber nicht richtig installieren :(

EDIT:

also irgendiwe zeigt er mir auch na, dass kein Proprietäre Software vorhanden ist :-/
wie kann cih die installieren?
 
Zuletzt bearbeitet:
keks

keks

nicht 1337 genug
Hi Ticha,

es scheint so als hätte dir das Ubuntu update einen neuen Kernel installiert :think:.

Nun musst du natürlich auch den Nvidia Treiber (welcher ja als Kernelmodul in den Kernel geladen wird) passend zu deiner Neuen Kernelversion installieren.

Am besten währe es wenn du den alten Nvidia Treiber runterschmeißt, und dir nen neuen von http://www.nvidia.com runterlädst (da gibts auch ne Anleitung wie das geht). Der Installer sollte dir "automatisch" ne neue funktionierende (wenn du glück hast ;) ) xorg.conf schreiben.

Achja vielleicht solltest du davor noch das Nvidia entladen und deinen Xserver runterfahren.
Code:
#xserver
/etc/init.d/gdm stop

#nvidia modul
rmmod nvidia

edit: vielleicht solltest du das ganze (xorg.conf gen.), falls es nicht geklappt hat, manuell anstoßen.
der Nvidia Treiber bring da auch ein Tool mit, glaub das heißt nvidia-xconfig oder so...
 
Zuletzt bearbeitet:
Ticha

Ticha

Linux Missionar
ich habe den ganzen Mittag herumngedoktort und bin zu keinem schlüssigen ergebnis gekomen.

Ich mach jetzt einfach ne Neusinstallation das geht schneller als wenn ich jetzt den fehler ewig lang suche ,.

aber danke :)
 
ew_wolf

ew_wolf

Tripel-As
Auch ich hatte diese Problem!
Ich habe Ubuntu nochmnals installiert. Diesmal erhielt ich schon keinen Hinweis mehr, dass dcer NVIDA-Treiber installiert werden sollte.
Dann habe ich die Updates installieren lassen und auch hier wurde ein neuer Kernel installiert.
Warum mir diesmal (auch nach dem Kernelupadate) kein Hinweis auf den NVIDA-Treiber bekomme ist mir schleierhaft, aber mein Laptop funtz.
Ich vermute, dass beim download der Updates ne Fehler auftrat.

Leider kann ich dir keine andere Lösung vorschlagen, obwohl wir hier nicht von WINDOOF reden:D
 
Zuletzt bearbeitet:
keks

keks

nicht 1337 genug
Dann installier halt sinnlos neu ?( sowas...
Das "Problem" ist in 2 minuten behoben... ;(

ich habe den ganzen Mittag herumngedoktort und bin zu keinem schlüssigen ergebnis gekomen.

Ich mach jetzt einfach ne Neusinstallation das geht schneller als wenn ich jetzt den fehler ewig lang suche ,.

aber danke :)
 

Ähnliche Themen

Auflösungsprobleme mit Medion TFT - Ubuntu 6.06

Verzerrte Anzeige mit zwei Monitoren (TwinView)

Ubunt hängt sich auf nach Ati Treiber installation

Oben