cdrdao - kein Treiber für mich??

miret

im Ghost-Modus
Beiträge
3.031
Habe mal versucht, direkt auf der konsole eine vcd zu kopieren und dabei folgende fehlermeldung erhalten:

miret@linux:~> cdrdao copy --read-raw --source-device 0,0,0 --device 0,1,0 --on-the-fly --speed 12 --buffers 64 --eject
Cdrdao version 1.1.5 - (C) Andreas Mueller <andreas@daneb.de>
SCSI interface library - (C) Joerg Schilling
L-EC encoding library - (C) Heiko Eissfeldt
Paranoia DAE library - (C) Monty

Check http://cdrdao.sourceforge.net/drives.html#dt for current driver tables.

Using libscg version 'schily-0.5'

0,1,0: PHILIPS PCRW1208 Rev: P3.1
ERROR: No driver found for 'PHILIPS PCRW1208', available drivers:
cdd2600
generic-mmc
generic-mmc-raw
plextor
plextor-scan
ricoh-mp6200
sony-cdu920
sony-cdu948
taiyo-yuden
teac-cdr55
toshiba
yamaha-cdr10x
ERROR: Cannot setup device 0,1,0.
miret@linux:~>

Ich habe mir gerade die neue Treiberliste für cdrdao von deren Page runtergeladen und gegen die alte ausgetauscht. Erstens hat's nix geändert und zweitens ist ja auch kein Wunder, denn nur durch die Textdatei ist wohl der Treiber nicht installiert, oder?
Mein Gerät ist übrigens dort jetzt aufgeführt.
Dadurch habe ich natürlich das gleiche Problem mit den Interfaces K3B und xcdroast usw.!

Watt nu??? ?( Kennt sich jemand damit aus???
 

miret

im Ghost-Modus
Beiträge
3.031
Ach ja! Laut Liste von der cdrdao-homepage soll es der Treiber - generic-mmc-raw - sein und der ist ja eigentlich die ganze Zeit schon drauf. Aber trotzdem will es nicht klappen.(siehe oben) Wie bringe ich cdrdao denn dazu, den Treiber zu akzeptieren?
 

gelber_hund

Pseudo-Root
Beiträge
137
hm, ich kann zwar leider nicht helfen. aber ich kann auf jeden fall mal bestätigen dass ich mit CDRDAO auch schon oft probleme hatte (allerdings unter windows). hab auch einen brenner, der laut liste den generic-mmc-raw benötigen soll. hat aber immer mit einem fehler abgebrochen...
 

miret

im Ghost-Modus
Beiträge
3.031
Den Treiber hab ich jetzt mit der Option

--driver generic-mmc-raw

eingebunden, was funzte. dann kam die nächste Fehlermeldung, die ich mit

--force

umgehen konnte.
Trotzdem brach er beim Versuch zu schreiben ab und gab folgendes aus:

miret@linux:~> cdrdao copy --read-raw --source-device 0,0,0 --device 0,1,0 --driver generic-mmc-raw --force --on-the-fly --speed 12 --buffers 64 --eject
Cdrdao version 1.1.5 - (C) Andreas Mueller <andreas@daneb.de>
SCSI interface library - (C) Joerg Schilling
L-EC encoding library - (C) Heiko Eissfeldt
Paranoia DAE library - (C) Monty

Check http://cdrdao.sourceforge.net/drives.html#dt for current driver tables.

Using libscg version 'schily-0.5'

0,1,0: PHILIPS PCRW1208 Rev: P3.1
Using driver: Generic SCSI-3/MMC (raw writing) - Version 2.0 (options 0x0000)

0,0,0: MITSUMI CD-ROM FX4820T!B Rev: F03D
Using driver: Generic SCSI-3/MMC - Version 1.2 (options 0x0020)

Starting on-the-fly CD copy at speed 12...

Track Mode Flags Start Length
------------------------------------------------------------
1 DATA 4 00:00:00( 0) 00:10:00( 750)
2 DATA 4 00:10:00( 750) 72:49:14(327689)
Leadout DATA 4 72:59:14(328439)

Analyzing track 01 (MODE2_RAW): start 00:00:00, length 00:10:00...
Analyzing track 02 (MODE2_RAW): start 00:10:00, length 72:49:14...

Turning BURN-Proof on
Using 16 byte P-Q sub-channel data mode.
Executing power calibration...
?: Input/output error. : scsi sendcmd: retryable error
CDB: 54 01 00 00 00 00 00 00 00 00
status: 0x0 (GOOD STATUS)
cmd finished after 21.141s timeout 20s
ERROR: Power calibration failed.
ERROR: Ignored because of option --force.
Writing lead-in and gap...
?: Input/output error. : scsi sendcmd: no error
CDB: 2A 00 FF FF CF 24 00 00 1B 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: F0 00 05 00 00 00 01 13 00 00 00 00 63 00 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x63 Qual 0x00 (end of user area encountered on this track) Fru 0x0
Sense flags: Blk 1 (valid)
cmd finished after 7.923s timeout 20s
ERROR: Write data failed.
ERROR: Writing failed.
On-the-fly CD copying failed.
miret@linux:~>


Irgendwie versteh ich es nicht!
 

devilz

Pro*phet
Beiträge
12.245
also ich hab dasselbe problem ....

aber mit
"cdrdao copy --source-device 0,2,0 --device 0,5,0 --buffers 64 --driver generic-mmc-raw"
lief es wunederbar durch !

nur mein system hängt gaaanz böse wenn er die source cd ausliest !

ich werde mal schauen ob da der dma modus eingeschaltet ist !!!
 

Ähnliche Themen

Displayport + externer Monitor zeigt bei startx nichts erst bei DVI

Ubuntu X / dbus problem

mkisofs + cdrecord

Textkonsole mit KMS zu klein

Frage zu cdrdao

Oben