Ati-Treiber hat sich im System festgebissen

Emess

Turmspringer
Beiträge
1.045
Hallo erstmal!
Habe mir auf meiner Workstation den Ati-Treiber "ati-driver-installer-9.2-x86.x86_64"
installiert. Hat auch prima geklappt! Bis zum Neustart, da war es dann aus mit KDE und Konsorten. Fehler ati macht probleme. Also hab ich die xorg.conf mit der Sicherheitskopie überschrieben und X läuft wieder mit Standardtreiber.
Wenn ich mir die Treiber-Bezeichnung so anschau, dünkt mich als ob sich die 64 am ende nicht mit meinem 32-Bit-System verträgt.
Das eigentliche Problem ist, wen ich per Apt was installieren will versucht er wohl die reste des Treibers los zu werden und bricht ab. Ich kann nichts mehr instalieren.
Hier die Fehlermeldung:
Code:
debian:/home/mick# apt-get install dvd+rw-tools
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Lese Status-Informationen ein... Fertig
Vorgeschlagene Pakete:
  cdrskin
Die folgenden Pakete werden ENTFERNT:
  fglrx-driver
Die folgenden NEUEN Pakete werden installiert:
  dvd+rw-tools
0 aktualisiert, 1 neu installiert, 1 zu entfernen und 13 nicht aktualisiert.
115 nicht vollständig installiert oder entfernt.
Es müssen noch 0B von 160kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 36,2MB Plattenplatz freigegeben.
Möchten Sie fortfahren [J/n]? j
(Lese Datenbank ... 158078 Dateien und Verzeichnisse sind derzeit installiert.)
Entferne fglrx-driver ...
Keine Umleitung »diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/diversions/libGL.so.1 by fglrx-driver«, keine entfernt
dpkg-divert: Keine Übereinstimmung mit Paket
  beim Entfernen von »diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/diversions/libGL.so.1.2 by fglrx-driver«
  »diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/diversions/libGL.so.1.2 by fglrx-glx« gefunden
dpkg: Fehler beim Bearbeiten von fglrx-driver (--remove):
 Unterprozess post-removal script gab den Fehlerwert 2 zurück
Fehler traten auf beim Bearbeiten von:
 fglrx-driver
E: Sub-process /usr/bin/dpkg returned an error code (1)
debian:/home/mick#
 

Emess

Turmspringer
Beiträge
1.045
Hi,

was ist mit "apt-get remove -f fglrx-driver"?

mfg,
bytepool

Gibt den gleich Fehler aus.

test
Code:
debian:/home/mick# dpkg-reconfigure fglrx-driver
/usr/sbin/dpkg-reconfigure: fglrx-driver ist kaputt oder nicht komplett installiert
debian:/home/mick#
 
Zuletzt bearbeitet:

bytepool

Code Monkey
Beiträge
791
Hi,

dann waere es sicherlich noch hilfreich zu wissen, wie du das Paket denn installiert hast. War das einfach ein .deb Paket? Wenn ja, wuerde ich da vielleicht mal reingucken, was fuer diverts da genau ausgefuehrt wurden.

Ansonsten schau doch mal was
Code:
dpkg-divert --test --rename --remove /usr/lib/libGL.so.1
dpkg-divert --test --rename --remove /usr/lib/libGL.so.1.2
sagen. Das --test sorgt dafuer, dass die Aenderungen noch nicht gemacht werden.

Edit:
Auch "dpkg-divert --list" waere eventuell interessant.

mfg,
bytepool
 
Zuletzt bearbeitet:

kartoffel200

AMD Fanboy Since 2003
Beiträge
938
Das 64 Bit sollte nicht stören denn der geht für beides.
Würde ihn einfach noch mal "drüber" installieren.
Hast du auch die passenden Kernel Header?
 

bytepool

Code Monkey
Beiträge
791
Hi,

Das 64 Bit sollte nicht stören denn der geht für beides.
das wage ich zu bezweifeln, es sei denn ATI hat seine Treiber voellig falsch benannt. 64-Bit Software kann aus technischen Gruenden _niemals_ auf einem 32-Bit System laufen. Wenn der Treiber fuer 64-Bit Systeme ausgewiesen ist, und trotzdem unter 32-Bit Systemen laeuft, ist der Treiber falsch benannt.

mfg,
bytepool
 

Emess

Turmspringer
Beiträge
1.045
Code:
debian:/home/mick# dpkg-divert --test --rename --remove /usr/lib/libGL.so.1
Keine Umleitung »any diversion of /usr/lib/libGL.so.1«, keine entfernt
debian:/home/mick# dpkg-divert --test --rename --remove /usr/lib/libGL.so.1.2
Entferne »diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/diversions/libGL.so.1.2 by fglrx-glx«

Punkt 2 würde ohne Test doch gut aussehen?

Bei dpkg-divert --list gefällt ihm das --remove nicht, und ohne remove passiert garnix
 
G

Gast1

Gast
das wage ich zu bezweifeln,

Stimmt aber.

es sei denn ATI hat seine Treiber voellig falsch benannt.

Haben sie ja nicht:

"ati-driver-installer-9.2-x86.x86_64"

(Genau deshalb ist das auch so ein fetter Klotz, wobei IIRC nicht mal alles doppelt vorhanden ist, sonst würde der Treiber auf 64 Bit keine 32Bit Libs benötigen.

//Edit: Das mit den 32 Bit Libs benötigen hat aber wahrscheinlich andere Gründe, möglicherweise bringt der 64 Bit Treiber auch 32 Bit libs für 32 Bit Anwendungen unter x86_64 mit und dann braucht es eben entsprechende Compat-Pakete.)
 
Zuletzt bearbeitet von einem Moderator:

bytepool

Code Monkey
Beiträge
791
Hi,

Haben sie ja nicht:
"ati-driver-installer-9.2-x86.x86_64"
ok, da habe ich in der Tat nicht drauf geachtet.

Bei dpkg-divert --list gefällt ihm das --remove nicht, und ohne remove passiert garnix
Bei "dpkg-divert --list" steht auch nichts von remove. ;)
Der Befehl, wie man sich eventuell schon denken kann, listet alle diverts auf die auf deinem System eingerichtet sind. Wenn das keine Ausgabe bringt, dann heisst das, dass keinerlei diverts eingerichtet sind.

Ich nehme an es geht um Debian Lenny? In dem Fall ist es nicht ungewoehnlich dass es keine diverts gibt, aber dann scheint bei der Installation von dem Package schon etwas falsch gelaufen zu sein, weswegen die Info nach der Installation nicht unwichtig waere.

Punkt 2 würde ohne Test doch gut aussehen?
Sieht so aus als wuerde das eventuell klappen, ja, aber ich bin noch nicht davon ueberzeugt dass das dein Problem loesen wuerde. Er beschwert sich ja darueber, dass er versucht einen divert zu entfernen, der nicht da ist. Eventuell koenntest du auch das Gegenteil versuchen, den fehlenden divert einfach noch hinzuzufuegen.

Aber statt wild herumzuprobieren wuerde ich doch eher versuchen herauszufinden was eigentlich passiert ist und was haette passieren sollen. Dann kann man das Problem auch gezielt beheben.

mfg,
bytepool
 

Emess

Turmspringer
Beiträge
1.045
apt-get -f install hats gebracht danach update und upgrade. Davon Abgesehen dass jetzt ein neuer Kernel installiert ist und somit mein Wlan erst mal tot ist, kann man diesen Fall als erledigt betrachten. :rolleyes:
 

Ähnliche Themen

Zugriff Ubuntu 16.04. auf Freigabe 18.04. LTS nicht möglich

grub-pc Probleme bei upgrade

Nvidia Hybrid-Grafikkarte: 3D Beschleunigung will nicht

Problem bei apt-get upgrade (Kali 2.0)

Firefox Installation fehlgeschlagen

Oben