UTF-8 und ISO-8859-1 Problem

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von freddymc, 21.03.2005.

  1. #1 freddymc, 21.03.2005
    freddymc

    freddymc Guest

    Hallo!

    Ich besitze SuSE 9.2 und habe Probleme mit den Schriften...
    Wenn ich UTF-8 Unterstützung aktiviere läuft KDE und Konsorten (Konqueror) einwandfrei, d.h. Alle Zeichen werden korrekt dargestellt, außer in GTK Anwendungen (glaub zmindest, dass das so heißt...).
    Wenn ich nun das Ganze auf de_DE@euro (dieses de_DE.ISO-8859-1) umstelle, hab ich die Umlaute in GTK, im Konqueror und in der Konsole werden dann die Umlaute verstümmelt.
    Das ganz große Manko dabei:
    Ark kann keine Dateien, die Umlaute enthalten, aus Archiven entpacken ;(
    *wildumhilferuf*
    Freddy
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Lord Kefir, 21.03.2005
    Lord Kefir

    Lord Kefir König

    Dabei seit:
    10.06.2004
    Beiträge:
    944
    Zustimmungen:
    0
    Wo stellst Du die UTF-8 Unterstützung denn ein?! Unter KDE oder direkt in der Konfiguraiton des X-Servers?

    Mfg, Lord Kefir
     
  4. #3 freddymc, 22.03.2005
    freddymc

    freddymc Guest

    Das mach ich
    1. in yast -> System -> Sprache wählen -> Details
    und
    2. in yast -> System -> Editor für /etc/sysconfig Dateien -> System -> Environment -> Language
    Dort habe ich RC_LANG und RC_LC_LANG auf de_DE@euro gestellt.
     
  5. #4 Lord Kefir, 22.03.2005
    Lord Kefir

    Lord Kefir König

    Dabei seit:
    10.06.2004
    Beiträge:
    944
    Zustimmungen:
    0
    Kann Dir da leider nicht viel weiter helfen, weil ich selbst kein SuSE benutze. Ich habe keine Ahnung, was Yast genau ändert und hatte selbst noch nicht solche Probs.
    Ich denke mir, Du solltest einfach Deinen X-Server entsprechend konfigurieren - die Konfigurationsdatei liegt wahrscheinlich unter /etc/X11/xorg.conf. Unter Layout würde ich dann "de" wählen - dann müsste alles klappen.

    Wie gesagt, alles ohne Gewähr. Bei SuSE gab's auch mal ein Programm, mit dem an den X-Server konfigurieren konnte - komme aber mal gerade nicht drauf, wie das heißt...

    Mfg, Lord Kefir
     
  6. #5 freddymc, 22.03.2005
    freddymc

    freddymc Guest

    meinst du vielleicht sax2?
    werd mal guggen,
    Danke
    Freddy
     
  7. #6 Lord Kefir, 22.03.2005
    Lord Kefir

    Lord Kefir König

    Dabei seit:
    10.06.2004
    Beiträge:
    944
    Zustimmungen:
    0
    Jep, genau das meinte ich ;)

    Mfg, Lord Kefir
     
  8. #7 freddymc, 23.03.2005
    freddymc

    freddymc Guest

    im Sax2 kann ich lediglich das Tastaturlayout umstellen und das ist schon standardmäßig auf deutsch...
    Ich kann auch von USB-Sticks keine Dateien, die Umlaute im Dateinamen tragen, auf die Festplatte kopieren ;(
    zu hülf :hilfe2:
    Freddy
     
  9. #8 Alarich, 08.04.2005
    Alarich

    Alarich Tripel-As

    Dabei seit:
    02.01.2004
    Beiträge:
    163
    Zustimmungen:
    0
    Schau doch mal nach, wie Deine Laufwerke gemountet werden.
    Da muß dann irgendwas stehen von "iocharset=iso8859-1" oder so ähnlich. Bei mir funktionierte die Umstellung auch nicht unter YAST und KDE. Ich habe die Optionen dann in "etc/fstab" direkt in der Datei geändert (Pfad weiß ich grad nicht so genau, sorry).
    Auf jeden Fall hat das geholfen, allen Laufwerken die ISO-Codierung zuweisen.
     
  10. #9 freddymc, 08.04.2005
    freddymc

    freddymc Guest

    Jau, werd ich machen, sobald ich wieder daheim bin!

    THX!

    Freddy
     
  11. #10 MTS, 08.04.2005
    Zuletzt bearbeitet: 08.04.2005
    MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    Hi! Also ich weiss zwar auch nicht genau, was da im System umgestellt ist, aber:

    1. Wenn du deteien mit alten iso Umlauten usw hast gibt es Probleme beim utf. Du musst die dateien dann mit iconv "umkonvertieren". iconv ist ein standardtool der glibc ...
    2. Wenn du dein System komplett auf Unicode umstellen willst, kann es notwendig sein, dass du zuätzlich deine Konsolenschriftart auf eine Unicode kompatible umstellst, zB
    setfont LatArCyrHeb-16
    es gibt ein Skript "unicode_start" dass die Eingabe und Ausgabe von Zeichen auf Unicode umstellt (Ist nicht immer erforderlich).
    3.Wenn du dein System komplett auf Unicode betreiben willst kannst du im Kernel unter Native Language Support das standard charset auf utf8 umstellen, es werden dann alle neuen dateien automatisch in utf erstellt.
    4. Es kann sein dass man nur noch Mist bei den manpages ausgibt, dass liegt daran, dass less die Systemcharsets ignoriert. Du musst zusätzlich die Variable LESSCHARSET setzen, entweder in deinem lesskeyfile oder mit
    export LESSCHARSET="utf-8"

    5. Ich weiss nicht welche Truetype Schriftarten Suse liefert, aber es kann evtl. sein, dass sie noch nicht auf utf umgestellt sind. Hier kannst du entweder nach neuen Suse paketen suchen oder du verwendest zB Fonts aus deiner Windows installation usw.
    Arial Unicode MS enthält so ziemlich alle Zeichen der Unicode 2 Spezifikation glaub ich ...

    ich hoffe das hilft dir ...
     
  12. #11 freddymc, 10.04.2005
    freddymc

    freddymc Guest

    Leider kenne ich mich in der fstab kein bisschen aus :(
    Hier ist mal meine:
    Code:
    /dev/hdb2            /                    reiserfs   acl,user_xattr        1 1
    /dev/hda1            /windows/C           vfat       users,gid=users,umask=0002,iocharset=utf8 0 0
    /dev/hda5            /windows/D           vfat       users,gid=users,umask=0002,iocharset=utf8 0 0
    /dev/hdb1            swap                 swap       pri=42                0 0
    devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
    proc                 /proc                proc       defaults              0 0
    usbfs                /proc/bus/usb        usbfs      noauto                0 0
    sysfs                /sys                 sysfs      noauto                0 0
    /dev/cdrecorder      /media/cdrecorder    subfs      fs=cdfss,unhide,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
    /dev/dvdrecorder     /media/dvdrecorder   subfs      fs=cdfss,unhide,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
    /dev/fd0             /media/floppy        subfs      fs=floppyfss,procuid,nodev,nosuid,sync 0 0
    Vielleicht kann mir jemand sagen wo ich iso8859-1 einstellen kann... :hilfe2:
    Danke schonmal!

    Fred
     
  13. MTS

    MTS Kaiser

    Dabei seit:
    09.11.2002
    Beiträge:
    1.242
    Zustimmungen:
    0
    Ort:
    NRW, Bochum
    anstelle von
    iocharset=utf8
    schreibst du
    iocharset=iso8859-1
    Erstmal bei den ersten beiden Einträgen
    ...
     
  14. #13 freddymc, 10.04.2005
    freddymc

    freddymc Guest

    Danke!!!

    Das hat mir sehr geholfen! :))
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Alarich, 11.04.2005
    Alarich

    Alarich Tripel-As

    Dabei seit:
    02.01.2004
    Beiträge:
    163
    Zustimmungen:
    0
    Selbiges funktioniert auch bei /dev/cdrecorder und /dev/dvdrecorder. Danach hatte ich auch keine Probleme mehr bei unter Windows selbstgebrannten CDs.
    Freut mich, daß der Tip bei Dir auch klappt!

    MfG
    Alarich
     
  17. #15 freddymc, 11.04.2005
    freddymc

    freddymc Guest

    Jo Danke!

    Aber die Nullen hinter dem iso.... bleiben oder?

    Fred
     
Thema:

UTF-8 und ISO-8859-1 Problem

Die Seite wird geladen...

UTF-8 und ISO-8859-1 Problem - Ähnliche Themen

  1. Umlaute (ö,ä,ü) trotz UTF-8 falsch dargestellt auf Red Hat 6.3 Santiago

    Umlaute (ö,ä,ü) trotz UTF-8 falsch dargestellt auf Red Hat 6.3 Santiago: Hallo zusammen:-) Ich lese mit einem PERL-Script auf einem Linux Redhat 6.3 Server Informationen aus einem Exchange-Kalender aus. Dies...
  2. Konsole auf UTF-8

    Konsole auf UTF-8: Hi, ich bin diesem Tutorial hier gefolgt: http://www.gentoo.de/doc/de/utf-8.xml Da 'man' immer noch keine Sonderzeichen angezeigt hat, hab ich...
  3. UTF-8 Fehler

    UTF-8 Fehler: Hallo, da ich immer wenn ich ein SVN Update mache den Fehler "Can't convert string from UTF-8 to antive encoding:" bekomme, dachte ich ich mach...
  4. Dateien in UTF-8 Kodierung konvertieren

    Dateien in UTF-8 Kodierung konvertieren: hallo, ich habe hier jetzt schon viel rum gestöbert, aber noch nichts dazu gefunden... ich habe ein Verzeichnis mit mehreren Dateien (text),...
  5. de_DE.UTF-8

    de_DE.UTF-8: Hallo! Ich wuerde mein OpenBSD 3.9 gerne auf de_DE.UTF-8 stellen. Meine google recherchen dazu waren irgendwie nicht besonders erfolgreich, und...