User @ proftpd

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von Das Kamel, 19.09.2007.

  1. #1 Das Kamel, 19.09.2007
    Das Kamel

    Das Kamel Mitglied

    Dabei seit:
    19.09.2007
    Beiträge:
    44
    Zustimmungen:
    0
    Ort:
    Erfurt
    moin leute
    ich hab in den letzten wochen einen ftp server mit debian und proftpd bei mir zu hause eingerichtet. ist auch alles schön und gut, geht prima mit dem anonymous log in.
    mein problem is jetzt, das ich es net gebacken krieg andere user anzulegen.
    hab schon ewig bei google gesucht, aber nirgens, das gefunden, was ich gesucht hab.
    ich hab schon nen user @ debian angelegt, ich kann mich allerdings net einloggen via ftp
    gibts noch irgend ne list, wo ich den user eintragen muss oder sowas?

    wär cool, wenn mir jemand von euch helfen könnte
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 21.09.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Bei den meisten Distros ist proftpd per Default so eingestellt, daß man sich mit normalen Benutzer-Accounts des Systems anmelden kann. Ansonsten findest du eine Recht gute Dokumentation zu virtuellen Usern in ProFTPd unter http://www.proftpd.de/HowTo-AuthUserFiles.40.0.html und http://www.castaglia.org/proftpd/doc/contrib/ProFTPD-mini-HOWTO-AuthFiles.html
    Um Auth-Files nutzen zu können, mußt du lediglich die Direktive AuthUserFile in der Server-Konfiguration entsprechend setzen.
    Sollte es trotz allem nicht funktionieren, solltest du evtl. mal einen Blick in die Logs werfen oder deren relevante Inhalte sowie deine Konfigurationen hier posten, damit man dir helfen kann.
     
  4. #3 Das Kamel, 21.09.2007
    Das Kamel

    Das Kamel Mitglied

    Dabei seit:
    19.09.2007
    Beiträge:
    44
    Zustimmungen:
    0
    Ort:
    Erfurt
    habs noch mal neu installiert, wegen der orig config. geht aber au net.
    wenn ich versuche mich via ftp einzuloggen, akzeptiert er zwar den usernamen aber das pw net.
    weis jemand was ich falsch mache?
    mit den dokus kann ich net all zu viel anfangen, da sie auf englisch sind.
    hab aber auch schon haufen weise andere how-tow's gelesen, und immer so gemacht, wie dort beschrieben, und es ghet einfach nich.
     
  5. #4 bitmuncher, 21.09.2007
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Ohne Fehlermeldungen aus den Logs und Einblick in deine Konfigurationen kann dir hier niemand helfen, aber das sagte ich ja bereits.
     
  6. JBR

    JBR Fichtenschonung

    Dabei seit:
    18.03.2007
    Beiträge:
    561
    Zustimmungen:
    0
    Ort:
    Nolop
    Ich würde den ftpd-ssl empfehlen. Das ist sicherer allein schon weil dein Passwort dann nicht unverschlüsselt über die Leitung rauscht. Falls du das unsichere ftp trotzdem möchtest heißt das Paket ftpd.
    Vergesse nicht die entsprechende Zeile in der Konfigurationsdatei des inetd auszukommentieren oder falls sie noch nicht vorhanden ist hinzuzufügen und den inetd zu starten.
     
  7. aeson

    aeson Foren As

    Dabei seit:
    25.04.2007
    Beiträge:
    86
    Zustimmungen:
    0
    Überprüfe zuerst mal deine proftpd.conf in /etc/proftpd/proftpd.conf

    Vielleicht sind in deiner Config irgendwelche Optionen gesetzt, die es normalen Usern die man über adduser $username hinzufügt verbieten auf den FTP zuzugreifen. Eventuell hast du eine Option gesetzt die vorher eine andere Datei überprüft ob sich der genannte User einloggen darf. Vielleicht dürfen sich auch nur User einloggen die eine/keine gültige SHELL besitzen.

    Wie "bitmuncher" schon sagt, ohne Logs, Fehlermeldungen oder auszüge aus der proftpd.conf kann dir hier keiner gezielt helfen.

    Ansonsten guck mal auf:
    proftpd.org
    proftpd.de

    Dort findest du eigentlich alle Antworten die Proftpd betreffen!

    gruß aeson
     
  8. #7 Das Kamel, 24.09.2007
    Das Kamel

    Das Kamel Mitglied

    Dabei seit:
    19.09.2007
    Beiträge:
    44
    Zustimmungen:
    0
    Ort:
    Erfurt
    jojo, ich werd sehn, das ich es mal poste
    hab nur ein klitzekleines prob, ich müsst dazu an der server, und der steht draußen in der garage, un da ich atm net laufen kann, wär das ne qual hin und zurück
     
  9. NoXqs

    NoXqs Routinier

    Dabei seit:
    07.05.2007
    Beiträge:
    420
    Zustimmungen:
    0
    Ort:
    Bremen
    Du setzt einen FTP-Server auf, ohne übers Netz auf den Server zugreifen zu können?

    Respekt!!

    Just my 2 cents.
     
  10. #9 Das Kamel, 29.09.2007
    Das Kamel

    Das Kamel Mitglied

    Dabei seit:
    19.09.2007
    Beiträge:
    44
    Zustimmungen:
    0
    Ort:
    Erfurt
    versteh ich net

    egal, back 2 topic
    da ich seit gestern wieder ohne freme hilfe laufen kann hab ich mal die config geholt

    Code:
    ServerType standalone
    DefaultServer on
    Umask 022
    ServerName "192.168.1.108"
    ServerIdent on "Raptor-X"
    ServerAdmin das_kamel@zelt-lan.de
    IdentLookups off
    UseReverseDNS off
    Port 21
    PassivePorts 49152 65534
    #MasqueradeAddress None
    TimesGMT off
    MaxInstances 3
    MaxLoginAttempts 3
    TimeoutLogin 300
    TimeoutNoTransfer 120
    TimeoutIdle 120
    DisplayLogin welcome.msg
    User nobody
    Group nobody
    DirFakeUser off nobody
    DirFakeGroup off nobody
    DefaultTransferMode binary
    AllowForeignAddress on
    AllowRetrieveRestart on
    AllowStoreRestart on
    DeleteAbortedStores off
    TransferRate RETR 30
    TransferRate STOR 40
    TransferRate STOU 40
    TransferRate APPE 40
    SystemLog /ftp/log
    RequireValidShell off
    #gp_random_username_length 6
    #gp_random_password_length 6
    #gp_randomize_case lower
    #gp_useradd_homedir_path /var/ftp
    #gp_html_path /var/www/html/ftp.htm
    #gp_welcome_name welcome.msg
    <IfModule mod_tls.c>
    TLSEngine off
    TLSRequired off
    TLSVerifyClient off
    TLSProtocol TLSv1
    TLSLog /var/log/proftpd_tls.log
    TLSRSACertificateFile /etc/gproftpd/gproftpd.pem
    </IfModule>
    <IfModule mod_ratio.c>
    Ratios off
    SaveRatios off
    RatioFile "/restricted/proftpd_ratios"
    RatioTempFile "/restricted/proftpd_ratios_temp"
    CwdRatioMsg "Please upload first!"
    FileRatioErrMsg "FileRatio limit exceeded, upload something first..."
    ByteRatioErrMsg "ByteRatio limit exceeded, upload something first..."
    LeechRatioMsg "Your ratio is unlimited."
    </IfModule>
    <Limit LOGIN>
      AllowUser backup
      DenyALL
    </Limit>
    
    <Anonymous /ftp/backup>
    User backup
    Group ftpuser
    AnonRequirePassword on
    MaxClients 5 "The server is full, hosting %m users"
    DisplayLogin welcome.msg
    <Limit LOGIN>
    Allow from all
    Deny from all
    </Limit>
    <Limit LIST NLST  STOR STOU  APPE  RETR  RNFR RNTO  MKD XMKD SITE_MKDIR  PWD XPWD  SIZE  STAT  CWD XCWD  CDUP XCUP >
     AllowAll
    </Limit>
    <Limit DELE  RMD XRMD SITE_RMDIR  SITE  SITE_CHMOD  SITE_CHGRP  MTDM >
     DenyAll
    </Limit>
    </Anonymous>
    
    wenn ich verusche zu dem server zu connecten erzählt er mir "login incorrect"
    kann mir jemand sagen was ich falsch mache?
     
  11. #10 aeson, 01.10.2007
    Zuletzt bearbeitet: 01.10.2007
    aeson

    aeson Foren As

    Dabei seit:
    25.04.2007
    Beiträge:
    86
    Zustimmungen:
    0
    Hallo,

    1.
    Durch das setzen dieser Option verbietest du allen Usern außer "backup" den FTP-Zugriff.

    2.
    Der User "backup" muss im System vorhanden sein. Das heißt du musst via adduser einen User in deinem System erstellen und diesem ein Home-Dir geben.

    Ich Empfehle dir folgenden Befehl, wenn du den User "backup" anlegen möchtest:

    Kleine Erklärung was die einzelnen Optionen dieses Befehls bewirken:
    --gecos GECOS --> Keine persönlichen Daten Speichern (Beispiel: Name, Vorname usw.)
    --ingroup ftpuser --> Fügt den neu angelegten User der Gruppe ftpuser hinzu, die du zuvor erstellt hast
    --shell /bin/false --> Der neu angelegte User bekommt keine gültige SHELL
    --home /var/www/backup --> legt das Home-Dir des neu angelegten Users fest (/var/www/ immer für Online-Aktivitäten zu empfehlen)

    3. Ich würde deiner proftpd.conf folgenden Befehl hinzufügen:
    Dieser Befehl verhindert, dass sich FTP-User auf dem ganzen System bewegen können und sperrt jeden FTP-User in sein Home-Dir ein. Bei dem User "backup" wäre das in unserem Fall /var/www/backup/

    4.
    Was soll das? Erstens hast du <Limit Login> schon an einer anderen stelle deiner config konfiguriert und zweitens macht diese Option ohnehin kein Sinn, weil du erst allen Usern den FTP-Zugriff erlaubst und eine Option weiter verbietest du wieder allen Usern den FTP-Zugriff.


    Behebe erstmal die Fehler und melde dich dann nochmal, falls es immer noch nicht klappen sollte. Und lies dir das Manual auf proftpd.org oder halt auf proftpd.de, wenn du kein Englisch können solltest durch. Wobei linux ohne Englisch generell ein weniger schwer werden dürfte :D

    Achja und noch was...

    Was NoXqs damit glaube ich sagen möchte ist... wieso man einen FTP-Server anlegen sollte ohne jeglichen Zugriff lokal oder extern auf diesen zu haben. Weil wenn lokaler oder externer Zugriff möglich ist, brauchst du den Server ja nicht aus der Garage zu holen um die config zu kopieren... Denk mal drüber nach ;)

    gruß aeson
     
  12. #11 Das Kamel, 26.01.2008
    Das Kamel

    Das Kamel Mitglied

    Dabei seit:
    19.09.2007
    Beiträge:
    44
    Zustimmungen:
    0
    Ort:
    Erfurt
    moin leutz
    hat zwar ewig gedauert, hat ziemlichen stress mit der schule, aber heut hab ich das mal alles gemacht was ihr mir so vorgeschlagen habt.

    als erstes hab ich openssh installiert ^^
    voll kuhl von meinem zimmer aus rechner in der garage zu steuern.

    dann hab ich den alten user gelöscht, und noch mal neu mit der gruppe un alles angelegt.
    hat alle prima geklappt, log in funzt jetzt auch.
    das einzige problem was ich jetzt noch hab ist, mit dem
    Code:
    DefaultRoot ~
    funzt net.
    wenn ich des in die config mit reinschreibe bekomm ich immer
    Code:
    Starting ftp server: proftpd - Fatal: unknown configuration directive 'DeafaultRoot' on line 63 of '/etc/proftpd/proftpd.conf'
    
    als fehlermeldung, kann damit aber nich wirklich was anfangen

    vielleicht hat ja noch einer von euch ne idee. ansonsten funzt alles soweit mit dem user etc.
    wenn ich jetzt noch mehrere logins erlauben will schreib ich die einfach bei
    Code:
    <Limit LOGIN>
      AllowUser backup
      DenyALL
    </Limit>
    mit rein?
     
  13. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    ich glaube du musst noch eine gruppe angeben, bei mir z.B. sieht das so aus:

    DefaultRoot ~ ftpuser

    kann auch sein, das das mit einzelenen usern funktioniert

    selbiges zu 2 du kannst auch einfach eine gruppe hinzufügen

    z.B.

    AllowGroup ftpuser
     
  14. #13 JBR, 26.01.2008
    Zuletzt bearbeitet: 26.01.2008
    JBR

    JBR Fichtenschonung

    Dabei seit:
    18.03.2007
    Beiträge:
    561
    Zustimmungen:
    0
    Ort:
    Nolop
    Ich denke hier liegt der Hund begraben:
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Das Kamel, 26.01.2008
    Das Kamel

    Das Kamel Mitglied

    Dabei seit:
    19.09.2007
    Beiträge:
    44
    Zustimmungen:
    0
    Ort:
    Erfurt
    @ doc
    AllowGroup is kuhl ^^

    @ JBR
    und was sagt mir das?
    ich weis nur das es geht, wenn ichs rausmache
     
  17. Gast1

    Gast1 Guest

    Mir zumindest sagt es, daß es bei Dir mit dem Lesen von Fehlermeldungen nicht allzu weit her ist.

    Kein Wunder.

    Code:
    Starting ftp server: proftpd - Fatal: unknown configuration directive 
    
    'De[B][COLOR="Red"]a[/COLOR][/B]faultRoot' on line 63 of '/etc/proftpd/proftpd.conf'
     
Thema:

User @ proftpd

Die Seite wird geladen...

User @ proftpd - Ähnliche Themen

  1. ProFTPd Frage Bezüglich 'Superuser'

    ProFTPd Frage Bezüglich 'Superuser': Hallo, für die Arbeit habe ich mal nen neuen FTP aufgesetzt mit ProFTPd, hat alles soweit auch super geklappt. Nur eine Sache fehlt jetzt noch...
  2. Proftpd User Authentifikation

    Proftpd User Authentifikation: wo kann ich im proftpd.conf den user, die in etc/passwd gespeichert sind aktivieren? Hab viel gegoogelt, finde einfach nix.... HILFE! mfg
  3. User sollen Dateien speichern und ändern, aber nicht neu anlegen dürfen

    User sollen Dateien speichern und ändern, aber nicht neu anlegen dürfen: Hallo liebe Helfer, welche Einstellungen muss ich in der smb.conf bzw. unter Linux vornehmen, damit User vorhandene Dateien öffnen und speichern...
  4. Solaris Login mit Active Directory User

    Solaris Login mit Active Directory User: Hallo zusammen, Ich arbeite daran unsere Solaris Systeme ans AD anzubinden. Teilweise ist mir das schon gelungen, teilweise stehe ich aber auch...
  5. LUG: Wolust - Wormser Linux User Stammtisch

    LUG: Wolust - Wormser Linux User Stammtisch: Wir sind die Nachfolger der Wolug. Linux und Open Source ist unser Thema. Wir mögen Server, Softwaretests, CMS, eingebettete Systeme, Arduino und...