ssh Anmeldung nur vom lokalen Server

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von Ruebenmaster, 18.01.2005.

  1. #1 Ruebenmaster, 18.01.2005
    Ruebenmaster

    Ruebenmaster Edna lebt! mit OpenSuSE

    Dabei seit:
    09.03.2003
    Beiträge:
    35
    Zustimmungen:
    0
    Ort:
    Kraichgau, klar!
    Hallo Leute,
    eigentlich bin ich ja nicht auf den Kopf gefallen... Aber der SuSE 9.2, den ich heute aufgesetzt hab, raubt mir in Sachen ssh den letzten Nerv. Ich möchte gerne von einem Client aus, per putty, auf dem Server zugreifen. Er meldet, dass ich den Benutzernamen eingeben soll und danach das Passwort. Es folgt die Fehlermeldung:

    Access denied

    Ich habe mich an der Konsole des Servers angemeldet und dann ssh <IPAdresse des Servers> eingegeben. Die gleiche Prozedur läuft ab, aber ich bekomme "Have a lot of fun".

    Ich kann mich also vom localhost aus anmelden.

    Ich bin dann zur /etc/ssh/ssh_config und sshd_config gegangen um entfernte Rechner freizugeben.

    Die Firewall Funktion von SuSE 9.2 ist abgeschaltet!

    Es gelingt mir immer noch nicht, mich von einem entfernten System aus anzumelden. Was muss ich in welcher Konfigurationsdatei angeben, damit ich Zugriff erhalte. Oder ist es ein Benutzerproblem? Fehlen dem Benutzer die Rechte zur Anmeldung? "root" darf sich auch nicht anmelden...

    Gruss
    DER Ruebenmaster
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. tr0nix

    tr0nix der-mit-dem-tux-tanzt

    Dabei seit:
    11.07.2003
    Beiträge:
    1.585
    Zustimmungen:
    0
    Ort:
    Schweiz, Opfikon/Glattbrugg
    Login als root? -> /etc/ssh/sshd_config allow_root_login (oder sowas)
    Login lokal moeglich? -> ssh localhost
    Kommt Passworteingabeaufforderung wenn du remote versuchst einzuloggen? Dann ist ssh-daemon sicher aktiv und erreichbar.

    Letzten endes:
    auf Susi sshd stoppen und manuell mit sshd -DDD (-D ist glaubs Debug Schalter) starten und auf der Konsole schauen was nicht i.O. ist

    Gruess
    Joel
     
  4. #3 Ruebenmaster, 19.01.2005
    Ruebenmaster

    Ruebenmaster Edna lebt! mit OpenSuSE

    Dabei seit:
    09.03.2003
    Beiträge:
    35
    Zustimmungen:
    0
    Ort:
    Kraichgau, klar!
    Hallo tr0nix,
    ich werde mal nachschauen, was in die sshd_config eingetragen werden muss.

    Wenn ich von einem externen Rechner zugreife, dann bekomme ich den "login:"
    Ich gebe den Benutzernamen ein (nicht root) und dann wird nach dem Passwort gefragt. Erst danach kommt: Access denied.

    Ich habe mich lokal angemeldet und dann ein ssh 172.16.78.239 abgesetzt. Es folgt die gleiche Prozedur wie oben nur dass die Anmeldung erfolgreich verläuft. Ein ssh localhost habe ich noch nicht getestet, werde dies aber gleich mal ausprobieren.

    Gruss
    DER Ruebenmaster
     
  5. #4 Ruebenmaster, 19.01.2005
    Ruebenmaster

    Ruebenmaster Edna lebt! mit OpenSuSE

    Dabei seit:
    09.03.2003
    Beiträge:
    35
    Zustimmungen:
    0
    Ort:
    Kraichgau, klar!
    Hallo tr0nix,
    ich habe die Lösung gefunden. Es muss in der Datei /etc/ssh/sshd_config folgende zwei Einträge geändert werden.

    PermitRootLogin yes

    und für die normalen Benutzer:

    PasswordAuthentication yes

    Und schon kann ich mich mit beiden Benutzern anmelden.

    Vielen Dank für Deine Tipps.


    Viele Grüsse vom Kraichgaurand
    DER Ruebenmaster
     
  6. #5 bananenman, 19.01.2005
    bananenman

    bananenman Routinier

    Dabei seit:
    07.03.2004
    Beiträge:
    410
    Zustimmungen:
    0
    den root-login würde ich gleich wieder abschalten - jeder der als root auf der maschine was zu machen hat, kann sich mit seinem user anmelden und anschließend durch su - root werden (1. gibt es weltweit wahrscheinlich nur einen anderen account der ähnlich oft mit brute-force attacken angegriffen wird (administrator), 2. wird in den log's dokumentiert wer wann root war und so schlau war mkreiserfs über die ungesicherte datenpartition laufen zu lassen ;) ). noch sinnvoller ist es gleich sämtlichen zugang per password zu verbieten und den wenigen usern die wirklich zugriff brauchen einen entsprechenden key-file zu verpassen.

    mfg

    bananenman
     
  7. #6 Ruebenmaster, 23.01.2005
    Ruebenmaster

    Ruebenmaster Edna lebt! mit OpenSuSE

    Dabei seit:
    09.03.2003
    Beiträge:
    35
    Zustimmungen:
    0
    Ort:
    Kraichgau, klar!
    root über ssh

    Hallo Bananenmann,
    Du hast aus Sicherheitsgründen schon Recht. Kein Root sollte sich anmelden können. Mir ginge es in erster Linie nur darum, ssh überhaupt zum Laufen zu bringen.
    Währen mein MAC OS X gleich Zutritt hatte, hatte ich mit Putty vom Windows System Probleme. Scheinbar übermittelt der putty zu Beginn das Passwort in Reinform, kann das sein?

    Zudem kam mir beim SuSE System spanisch vor, dass es ausser der ssh_config und der sshd_config noch eine eigene ssh Konfigurationsdatei gibt.Leider ist aus den mitgelieferten Handbüchern und online Hilfen nichts über diese Dateien, deren Unterschiede oder Einsatzbereiche beschrieben.

    Gruss vom Kraichgaurand
    Ruebenmaster
     
  8. #7 odcheck, 02.02.2005
    odcheck

    odcheck Jungspund

    Dabei seit:
    24.02.2004
    Beiträge:
    15
    Zustimmungen:
    0
    von wegen seltsam... ssh und Sicherheit

    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    @ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!

    wenn Ihr diese Meldung bei einem Verbindungsversuch via ssh jemals bekommen habt dann wisst Ihr wahrscheinlich was es damit auf sich hat.
    - kann muß aber nicht eine "man-in-the-middle attack" Angriff sein
    was bei mir zu der derzeitigen Netzwerkkonfiguration auszuschließen ist.

    Wie dem auch sei. Lösung kann angeblich an dieser Stelle sein wenn man immer nur von einem Client aus seinen "server" o.ä. via ssh erreichen möchte das eintragen eines "known hosts" in der Datei /root/.ssh/known_hosts beheben. Hört sich ja ganz toll an nur zu dumm das ich diese besagte Datei nicht finde... (als root über die bash !??)
    ich finde sie nicht.
    Benutzte Suse 9.2 Prof.
    Hat einer eine Ahnung warum ich die Datei nicht finde. Wahrscheinlich lacht jetzt jeder der genau weiß was gemeint ist nur ich kann da leider nicht darüber lachen.. obwohl :-) Ich hoffe hier einfach auf einen Rat. ja ja rtfm Bin dabei! Aber parallel Info's sammeln kann ja nicht schaden.

    gruß
    odchek
     
  9. #8 wasseradler, 13.02.2005
    wasseradler

    wasseradler Grünschnabel

    Dabei seit:
    13.02.2005
    Beiträge:
    9
    Zustimmungen:
    0
    Tach!

    Habe ein ehnliches Problem. Bei mir kann ich mich trotz ssh 2 per Putty/Windows nicht anmelden. Ich kann mich aber von einem Debian-Rechner per ssh anmelden.
    D.h. doch das eine Anpassung der ssh_config wenig sinnvoll ist - oder ?

    Gruß
     
  10. #9 Ruebenmaster, 14.02.2005
    Ruebenmaster

    Ruebenmaster Edna lebt! mit OpenSuSE

    Dabei seit:
    09.03.2003
    Beiträge:
    35
    Zustimmungen:
    0
    Ort:
    Kraichgau, klar!
    putty und ssh version 2

    hallo wasseradler,
    ich kenne mich mit dem Putty nicht gut aus. ich denke aber, dass der Putty wohl die erste Anmeldungen auf der Version 1 basieren, sozusagen ohne Verschlüsselung. Dies ist aber eine Vermutung meiner Seite, die ich heute wohl mit dem SLES der Version 8 wieder erleben darf. ich werde dann mal genauer schaun... ;o) Schliesslich kann man da ja nur auf Version 2 schalten und dann schauen, ob ausser meinem debian Liebling auch noch der Putty dran darf!

    Viele Grüsse vom Kraichgaurand
    DER Ruebenmaster
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. #10 bananenman, 14.02.2005
    bananenman

    bananenman Routinier

    Dabei seit:
    07.03.2004
    Beiträge:
    410
    Zustimmungen:
    0
    nein, putty implementiert die ssh-version 2 vollständig - auf wunsch sogar ausschließlich (im menue unter ssh-options einstellbar).

    wenn ihr diese meldung bekommt
    dann wurde der key des servers geändert. sofern ihr wisst das das so ist, die maschine einfach aus der /.known_host-datei löschen. beim nächsten verbindungsversuch bekommt ihr dann eine neuerliche abfrage, ob ihr den key akzeptiert. wenn ihr nichts von der umstellung der keys wisst, solltet ihr unbedingt nachfragen und den key erst dann akzeptieren wenn ihr euch sicher seit, dass der server der richtige ist! (wie oben schon erwähnt droht eine man-in-the-middle-attack).

    wer heute noch mit dem sles 8.x unterwegs ist, sollte ssh updaten - da hat sich einiges getan. außerdem ist es sinnvoll immer die neueste putty-version zu verwenden (0.56)

    mfg

    bananenman
     
  13. #11 wasseradler, 14.02.2005
    wasseradler

    wasseradler Grünschnabel

    Dabei seit:
    13.02.2005
    Beiträge:
    9
    Zustimmungen:
    0
    Das war der Kinken

    Danke!

    Hatte eigentlich ein relativ aktuelles putty-Release (0.51). War aber nicht genug. Mit 0.56 geht's. Bei der Version kann man nämlich '2 only' unter SSH einstellen. Schon gehts.

    Gruß
     
Thema:

ssh Anmeldung nur vom lokalen Server

Die Seite wird geladen...

ssh Anmeldung nur vom lokalen Server - Ähnliche Themen

  1. Anmeldung auf Samba4 Server

    Anmeldung auf Samba4 Server: Ein debian 8 server mit samba4 als pdc und file server installiert. Alle Konfigurationen sind gut gelaufen und samba4 hat bis jetzt einwandfrei...
  2. Anmeldung für LUG-Camp 2016 läuft

    Anmeldung für LUG-Camp 2016 läuft: Vom Donnerstag, den 5. Mai, bis zum Sonntag, den 8. Mai 2016, findet im badischen Bruchsal das mittlerweile 17. Treffen der Linux User Groups aus...
  3. Alias nach Ab- und Neuanmeldung futsch

    Alias nach Ab- und Neuanmeldung futsch: Ich habe in der .profile einen "alias" hinterlegt (alias='ordnera/ordnerb/ordnerc'). Wenn ich ab- und wieder anmelde, ist der "alias"...
  4. Anmeldung für Software Freedom Day 2014 gestartet

    Anmeldung für Software Freedom Day 2014 gestartet: Am Samstag, dem 20. September 2014, feiern Unterstützer freier Software in aller Welt wie in jedem Jahr den Software Freedom Day. Die...
  5. Anmeldung für Document Freedom Day 2014 gestartet

    Anmeldung für Document Freedom Day 2014 gestartet: Die Registrierungsphase für den Document Freedom Day 2014 hat begonnen. Der Document Freedom Day (DFD) findet immer am letzten Mittwoch im März...