Samba-Kennung auf XP-Clients

Dieses Thema im Forum "Samba" wurde erstellt von ehorn, 18.09.2007.

  1. ehorn

    ehorn Jungspund

    Dabei seit:
    18.09.2007
    Beiträge:
    17
    Zustimmungen:
    0
    Hallo zusammen,

    ich bin, was Samba anbetrifft, eher ein Laie, kämpfe mich derzeit aber durch die Konfiguration eines Linux-Servers mit Samba, da ich den in unserer Schulverwaltung installiert habe. Nun ergibt sich ein rätselhaftes Phänomen: Auf sämtlichen Rechnern (Windows XP, 2k, 98) werden Shares - als Netzwerklaufwerke verbunden - so angezeigt, wie ich es kenne. Wenn ich das Share "test" auf Server "server" mit Laufwerk G: verbinde, steht im Windows Explorer

    test auf "server" (G:)

    wie es auch sein sollte. Nun habe ich drei neue Laptops mit neuesten XP-Versionen bekommen, auf denen die Netzlaufwerke so in etwa folgenderweise aussehen (die Zahlen sind Phantasie-Zahlen, ich habe die Versionsnummer derzeit nicht im Kopf):

    test auf "SAMBA-3.20.01.23.45-CODE10(server)" (G:)

    An sich ist das nicht schlimm, nur wird dadurch der Dateibaum im Explorer etwas unübersichtlich - und gerade unsere Sekretärinnen bekommen etwas Probleme, da sie sich immer über Laufwerksbuchstaben orientieren, die aufgrund der String-Länge verschwinden.

    Kennt jemand das Phänomen? Gibt es eine Möglichkeit, die Aufnahme des SAMBA-Strings in die Server-Kennung zu unterdrücken? Meiner Ansicht nach müsste der Fehler bei der Konfiguration der drei neuen XP-Clients liegen, da mehrere andere XP-Clients die gewünschte "normale" Anzeige haben.

    Danke für jede Hilfe im Voraus

    Eric.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. NoXqs

    NoXqs Routinier

    Dabei seit:
    07.05.2007
    Beiträge:
    420
    Zustimmungen:
    0
    Ort:
    Bremen
    Hast du in der [global]-Section den Schalter "netbios name" explizit gesetzt oder ist es der default-wert?
     
  4. ehorn

    ehorn Jungspund

    Dabei seit:
    18.09.2007
    Beiträge:
    17
    Zustimmungen:
    0
    "netbios name" ist explizit auf die Server-Bezeichnung gesetzt (also nach meinem obigen Beispiel "netbios name = server"). Was mich eben wundert: Auf allen anderen Clients außer den drei neuen funktioniert es einwandfrei, nur die drei neuen zeigen den "Huddel" mit der langen Kennung an.
     
  5. #4 ehorn, 19.09.2007
    Zuletzt bearbeitet: 19.09.2007
    ehorn

    ehorn Jungspund

    Dabei seit:
    18.09.2007
    Beiträge:
    17
    Zustimmungen:
    0
    Ich habe eben festgestellt, dass es in der [global]-Section den Wert "server string" gibt, mit dem man eben den Server-String verändern kann. Ich werde morgen mal ausprobieren, ob ich damit zumindest den langen Eintrag rauskegeln kann, sodass die Anzeige etwas übersichtlicher wird. Das ändern zwar noch nichts an der grundsätzlichen Frage, wieso bei einigen XP-Clients der lange Server-String angezeigt wird und bei anderen nur der Host-Name, aber zumindest wäre das mal ein erstes "work around". Werde das Ergebnis dann hier posten.
     
  6. #5 ehorn, 20.09.2007
    Zuletzt bearbeitet: 20.09.2007
    ehorn

    ehorn Jungspund

    Dabei seit:
    18.09.2007
    Beiträge:
    17
    Zustimmungen:
    0
    Kurz zum Zwischenstand: Auch das Setzen des Wertes "server string" in der [global]-Section hat keine Veränderung gebracht. Auf den drei besagten XP-Clients wird weiterhin die komplette Serverkennung "SAMBA-3.xxxxx" ausgegeben.
     
  7. ehorn

    ehorn Jungspund

    Dabei seit:
    18.09.2007
    Beiträge:
    17
    Zustimmungen:
    0
    Eine kleine Korrektur: Es ist doch der Wert "server string", der das beeinflusst. Nur dass Windows XP den Wert nicht mehr zu aktualisieren scheint, wenn es einmal den Wert ausgelesen hat. Ich werde demnächst mal schauen, ob der Wert in der Registry hinterlegt wird (wegen Herbstferien komme ich im Moment nicht an die Rechner ran) und dort geändert werden kann. Das Verhalten selbst - soviel habe ich inzwischen eingrenzen können - scheint mit der Aktualisierung auf IE 7 zu tun zu haben. Solange ich bei IE 6 bleibe, wird die alte Freigabedarstellung genutzt (also nur: "test auf 'hostname' (X:)"), sobald IE 7 installiert ist wird die Form "test auf 'server string (hostname)' (X:)" verwendet. Mal sehen, ob das noch weiter in den Griff zu bekommen ist.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Samba-Kennung auf XP-Clients

Die Seite wird geladen...

Samba-Kennung auf XP-Clients - Ähnliche Themen

  1. Linux-Router (SuSE 10.2) für XP-Clients

    Linux-Router (SuSE 10.2) für XP-Clients: Guten Morgen Unix-Community, ich bin dabei mit armseligen Anfängerkenntnissen (aber viel Geduld) einen Router unter 10.2 aufzusetzen. File-...
  2. Profile der XP-Clients auf Server kopieren

    Profile der XP-Clients auf Server kopieren: Hi, ich bin gerade dabei einen Samba-Server (Fedora 5) als PDC einzurichten. Jetzt geht es darum, die Profile der (XP-Client-)User eben von den...
  3. Sicherung der XP-Clients

    Sicherung der XP-Clients: Hallo Leute, wieder einmal wende ich mich an euch. Diesmal versuche ich eine Datensicherung der XP-Clients hinzubekommen, dass im Falle eines...