proFTPd Fehler in Verbindung mit mySQL

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von Beo, 17.02.2007.

  1. #1 Beo, 17.02.2007
    Zuletzt bearbeitet: 17.02.2007
    Beo

    Beo Grünschnabel

    Dabei seit:
    17.02.2007
    Beiträge:
    2
    Zustimmungen:
    0
    Hi,

    ich versuche jetzt schon seit geraumer Zeit proFTPd mit proFTPd_Admin Backend auf meinem Debian Sarge - Server zu installieren. Als Fehlermeldung erhalte ich im mysql log von proftpd leider immer nur:

    Code:
    unrecoverable backend error
    error:'1045'
    message: 'Benutzer 'proftpd_admin'@'localhost' hat keine Zugriffsberechtigung verwendetes Passwort (Nein)'
    Ich wäre echt dankbar, wenn mir jemand helfen könnte und mir vielleicht sogar erläutern könnte, wo ich meinen Fehler gemacht habe. Obwohl ich jetzt schon seit ein paar Tagen am suchen bin, will er mir einfach nicht auffallen. Und ich persönlich weiß mir einfach nicht mehr weiter zu helfen.

    Für den Fall, dass ich in meiner proftpd.conf einen Fehler gemacht haben sollte, füge ich die Codeseite mal bei:

    Code:
    #
    # Grundsätzliche Userinformationen zum FTP-Server
    #
    ServerName "BeoSDebianFTP"
    ServerType standalone
    ServerAdmin admin@ftp.de
    
    #
    # Konfiguration für LogIn 
    #
    ServerIdent on "BeoSDebian FTP ready"
    DeferWelcome on
    DefaultServer on
    MultilineRFC2228 on
    ShowSymlinks off
    
    TimeoutNoTransfer 600
    TimeoutStalled 600
    TimeoutIdle 1200
    
    #
    # 'welcome.msg beim LogIn, 'connect.msg' bei Verbindungsaufbau,
    # '.message.msg' bei erstem Verzeichniswechsel anzeigen
    #
    DisplayLogin .welcome.msg
    DisplayConnect .connect.msg
    DisplayFirstChdir .message.msg
    
    #PathDenyFilter "\\.ftp)|\\.ht)[a-z]+$"
    DenyFilter \*.*/
    
    #
    # Bei Nutzung von NIS oder LDAP zum Empfang von Passwörtern nachfolgendes auskommentieren
    #
    #PersistentPasswd off
    
    #
    # FTP-Portauswahl (Standard-FTP-Port lautet 21)
    #
    Port 21
    
    #
    # Maximal Werte setzen (Schutz vor DoS - Attacken, nur für standalone-Betrieb)
    #
    MaxClientsPerHost 2 "Nicht mehr als %m Verbindungen erlaubt!"
    MaxClients 8 "Leider sind schon %m Clients verbunden!"
    MaxLoginAttempts 3
    MaxInstances 30
    
    #
    # User und Group setzen, unter dem der FTP-Server grundsätzlich arbeitet
    #
    User nobody
    Group nogroup
    
    #
    # Im Normalfall sollten Dateien überschreibbar sein
    #
    <Directory />
    # Umask 022 ist ein guter Standard-Umask, um zu verhindern, dass Verzeichnisse und
    # Dateien allgemein schreibbar werden
    Umask 022 022
    
    AllowOverwrite on
    </Directory>
     
    #
    # FXP Unterstuetzung
    #
    AllowForeignAddress on
    
    #
    # Restart erlauben
    #
    AllowStoreRestart on
    AllowRetrieveRestart on
     
    #
    # Nutzer in bestimmte Verzeichnisse "einsperren"
    #
    DefaultRoot /var/www
     
    #
    # Root-LogIn verbieten und gültige Shell verlangen (in /etc/shells)
    #
    <Global>
    RootLogin off
    RequireValidShell on
    </Global>
    
    #
    # Speed erhoehen
    #
    UseReverseDNS off
    IdentLookups off
    
    ScoreboardFile /var/log/scoreboard
     
    # 
    # Logging Formate
    #
    LogFormat default "%h %l %u %t \"%r\" %s %b"
    LogFormat auth "%v [%P] %h %t \"%r\" %s"
    LogFormat write "%h %l %u %t \"%r\" %s %b"
    
    #
    # Logging Optionen
    #
    TransferLog /var/log/proftpd.xferlog
     
    # Datei- / Verzeichniszugriff
    ExtendedLog /var/log/proftpd.access_log WRITE,READ write
     
    # alle logins
    ExtendedLog /var/log/proftpd.auth_log AUTH auth
     
    # für paranoide (vorsicht, erzeugt grosse Logfiles)
    ExtendedLog /var/log/proftpd.paranoid_log ALL default
    
    # mySQL-Log
    SQLLogFile /var/log/proftpd.mysql
    
    # Debugging-Log (Intensität 1 - 6)
    #debugLevel 6
    #ServerLog /var/log/proftpd.debug_log
    
    #
    # Bar use of SITE CHMOD by default
    #
    #<Limit SITE_CHMOD>
    #  DenyAll
    #</Limit>
    
    #
    # Grundlegende Konfiguration fuer anonymen LogIn, keine Upload-Verzeichnisse
    # Wenn Anonyme Nutzer nicht gewünscht sind, diesen kompletten Abschnitt (<Anonymous>)
    # loeschen
    #
    #<Anonymous ~ftp>
    #  User ftp
    #  Group ftp
    
    # FTP-Clients sollen sowohl per "anonymous" als auch "ftp" einloggen koennen
    # UserAlias anonymous ftp
    
    # Maximale Menge gleichzeitiger "Anonymous"-Logins begrenzen
    # MaxClients 10
    
    # WRITE-Option überall im geschuetzten Bereich von <Anonymous> begrenzen
    #<Limit WRITE>
    #  DenyAll
    #</Limit>
    #</Anonymous>
    
    
    # mySQL - Zugang
    # ==============
    #
    # Zugangskontrolle
    #
    AuthOrder mod_sql.c
    SQLAuthTypes Backend
    SQLConnectInfo proftpd@localhost proftpd proftpd_admin
    SQLUserInfo usertable userid passwd uid gid homedir shell
    SQLGroupInfo grouptable groupname gid members
    SQLUserWhereClause "disabled=0 and (NOW()<=expiration or expiration =-1 or expiration=0)"
    
    # SQL Kommandos
    # Log the user logging in
    SQLLog PASS counter
    SQLNamedQuery counter UPDATE "lastlogin=now(), count=count+1 WHERE userid='%u'" usertable
    
    # logout log
    SQLLog EXIT time_logout
    SQLNamedQuery time_logout UPDATE "lastlogout=now() WHERE userid='%u'" usertable
    
    # display last login time when PASS command is given
    SQLNamedQuery login_time SELECT "lastlogin from usertable where userid='%u'"
    SQLShowInfo PASS "230" "Last login was: %{login_time}"
    
    # xfer Log in mysql
    SQLLog RETR,STOR transfer1
    SQLNamedQuery  transfer1 INSERT "'%u', '%f', '%b', '%h', '%a', '%m', '%T', now(), 'c', NULL" xfer_stat
    SQLLOG ERR_RETR,ERR_STOR transfer2
    SQLNamedQuery  transfer2 INSERT "'%u', '%f', '%b', '%h', '%a', '%m', '%T', now(), 'i', NULL" xfer_stat
    
    
    AllowStoreRestart 		on
    AllowRetrieveRestart		on
    RequireValidShell               off
    PathDenyFilter                  "\\.ftp)|\\.ht)[a-z]+$"
    DefaultRoot 			~
    DenyFilter 			\*.*/
    
    
    <Directory /ftp/*>
    	AllowOverwrite		off
     	HideNoAccess		off
    	<Limit READ>
    		AllowAll
            </Limit>
    
    	<Limit WRITE>
    		DenyGroup	!admins
     	</Limit>
    </Directory>
    
    <Directory /ftp/incoming/*>
    	AllowOverwrite		on
    	HideNoAccess		on
    
    	<Limit READ>
          		DenyGroup	!admins
        	</Limit>
    
        	<Limit STOR MKD>
          		AllowAll
        	</Limit>
    </Directory>
    
    mySQL sollte eigentlich vollkommen in Ordnung sein, denn phpMyAdmin macht mir überhaupt keine Sorgen und läuft völlig einwandfrei.
    php5 dürfte ich ebenfalls einwandrei installiert haben, da ja die php-Config-Seite einwandfrei arbeitet und eingegebene Daten auch entsprechend in der Datenbank ablegt.
    Der Fehler muss also meines Erachtens in der Verbindung zwischen proFTPd und mySQL liegen, zumindestens weiß ich es leider nicht besser.

    Auf den FTP-Server finde ich leider keinen Zugriff und wäre daher für jede Hilfestellung (und sei es nur die Überprüfung meiner proftpd.conf auf Fehler) echt dankbar.

    P.S.
    Vielleicht sollte ich noch erwähnen, dass ich noch Linux-Newb bin :hilfe2:
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Beo

    Beo Grünschnabel

    Dabei seit:
    17.02.2007
    Beiträge:
    2
    Zustimmungen:
    0
    Kann denn keiner helfen? Und sei es nur die Überprüfung meiner proftpd.conf auf Richtigkeit. :hilfe2:
     
  4. rygar

    rygar Routinier
    Moderator

    Dabei seit:
    15.07.2002
    Beiträge:
    332
    Zustimmungen:
    0
    Ort:
    Kaarst
    Hmmm...

    Mit ProFTP mach ich eigentlich nix... aber die Fehlermeldung ist ja schon recht deutlich :

    Code:
    unrecoverable backend error
    error:'1045'
    message: 'Benutzer 'proftpd_admin'@'localhost' hat keine Zugriffsberechtigung verwendetes Passwort (Nein)'
    
    Bedeutet also Du hast einen MySQL-User proftpd_admin. Der scheint aber in der ProFTP Config kein Passwort eingetragen zu haben.

    So wie es ausschaut funtzt darum die Verbindung zum SQL Server nicht.

    Such doch mal in deiner Config nach proftp_admin und schau wie man da das Passwort mit angeben kann.

    Viel Glueck!
     
Thema:

proFTPd Fehler in Verbindung mit mySQL

Die Seite wird geladen...

proFTPd Fehler in Verbindung mit mySQL - Ähnliche Themen

  1. ProFTPd - Kein Login möglich! Wo ist der Fehler?

    ProFTPd - Kein Login möglich! Wo ist der Fehler?: Hallo Leute, heute habe ich zum ersten mal versucht einen FTP-Server aufzusetzen - jedoch kann ich mich absolut nicht auf meinen FTP einloggen....
  2. Ich bekomme proFTPd nicht gestartet, bekomme immer eine Fehlermeldung

    Ich bekomme proFTPd nicht gestartet, bekomme immer eine Fehlermeldung: Hallo zusammen, ich hab da mal ne Frage. Jedesmal wenn ich proFTPd ( Fedora Core 3 )starten will, kommt folgende Warnmeldung Konnte...
  3. proftpd Verwaltung

    proftpd Verwaltung: Mahlzeit, ich finde leider keine Lösung ich hoffe Ihr habt eine Idee. Ich habe ca. 30 proftpd Server. Bis jetzt läuft die Authentifizierung...
  4. Proftpd/TLS Probleme

    Proftpd/TLS Probleme: Tach Leute, bitte bedenkt, das ich Anfänger bin und gerade ein wenig Linux Erfahrung sammeln mag. Ich habe mir proftpd auf dem Server...
  5. proftpd tls Zertifikat einbinden

    proftpd tls Zertifikat einbinden: Hallo zusammen, da meine ftp Proxy proiblem macht (CentOS 5.5) habe ich einen neuen aufgesetzt (CentOS 6.2 64 bit). Problem: proftpd läuft....