probleme mit den 2.6 er kerneln

Dieses Thema im Forum "Linux OS" wurde erstellt von sono, 07.03.2004.

  1. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    Habe kleinere Probleme mit den 2.6 er Kerneln.
    Egal welchen Kernel ich verwenden möchte wenn ich mit den
    dingern booten möchte bekomme ich jedes mal die Meldung
    " Kernel panic unable to mount rootfs "

    hm das ist komisch da ich definitiv ne ext3 partition habe.
    und ext3 hab ich definitiv mit eincompiliert.
    sowie ext2 , xfs usw daran sollte es nicht liegen

    unter den 2.4 ern läuft alles ohne Probleme.
    hab Debian 3.0 stable , aber ich hab modconf und die module-init-tools upgedatet. von daher sollte es daran nicht liegen.

    irgendwie weiß ich jetzt nicht so richtig weiter .
    googel findet auch nichts , bzw nur sachen die nicht direkt mein problem betreffen.
    kommt das jemand bekannt vor ?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. thorus

    thorus GNU-Freiheitskämpfer

    Dabei seit:
    03.11.2002
    Beiträge:
    757
    Zustimmungen:
    0
    Ort:
    Passau, Niederbayern
    Du brauchst auch die Treiber für deine Festplatte.
    Also IDE bzw. SCSI mit den richtigen Chipsatz/Controller-Treibern fest in dern Kernel einbinden.
     
  4. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    hm das könnte noch ne idee sein.
    sollte ich mal testen.

    merci
     
  5. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    so ich mal mit lspci überprüft was alles so in meiner kiste steckt.

    hab unter device dann auch alles überprüft was mit ide zu tun hatte , und ich hab devinitiv beide IDE Controller angegeben.

    einmal den auf dem board und dann noch nen pci raid controller .

    was haben die den verdammtnochmal anderts gemacht im vergleich zum 2.4er kernel ? die laufen nämlich auf anhieb. mittlerweile hab ich den 2.6.2 er auf nem 2ten computer ausprobiert.
    auf dem läuft debian 3.0 unstable , also soweit sollte es keine probleme mit dem kernel gaben. trotzdem bekomme ich noch die meldung von wegen kernel panic unable to mount root fs ! juhu.

    ich weiß echt ned was der computer von mir will . komm mir langsam etwas blöd vor. ?(
     
  6. Gronau

    Gronau Doppel-As

    Dabei seit:
    28.02.2004
    Beiträge:
    113
    Zustimmungen:
    0
    vielleicht hilft es wenn du testweise mal die config von deiner jetzigen kernel benutzt.
     
  7. thorus

    thorus GNU-Freiheitskämpfer

    Dabei seit:
    03.11.2002
    Beiträge:
    757
    Zustimmungen:
    0
    Ort:
    Passau, Niederbayern
    Ist das rootfs auf raid?
     
  8. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    ne des ned , weiß dass es damit probleme geben würde.

    hab ne ganz normale ext3 auf hda4 ( ist aber die 2te partition direkt nach der boot partition) ist eine primäre partition ,

    weiß ned so genau was das soll. die platten werden ja auch erkannt , bekomme sie beim booten aufgezählt.

    dann kommtd vfs kernel panic blablabla , er könne das filesysetm nicht mounten .
    ???????????????????????????????????????????????????????????????

    ich weiß was es bedeutet ich weiß nur ned was das soll !
    hab sogar nochmal mit cfdisk nachgeschaut was ich habe, weil ich mir langsam dumm vorkomme.
     
  9. #8 damager, 08.03.2004
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    ist ext3 und die ide-controller-treiber fest im kernel oder als modul?
     
  10. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    fest mit eincompiliert . denke mal das würde anderst probleme geben.

    hab den kernel jetzt zum xten mal aufgesetzt , jetzt bekomme ich noch zusätzlich die meldungen das keine platten über 16 heads unterstüzt werden würde .
    die meldung ist neu , aber voher gings auch schon ned , von daher .

    wenn ich die platten aufgelistet bekomme dann ist doch auf jeden fall der richtige
    idecontroller drin , bzw der kernel kan mit dem ding umgehen ?
    wäre auf jeden fall logisch , also müsste es am filesystem hängen , was jetzt zum xten mal ext3 (ich weiß ich wiederhol mich) auf ner primary , und ned auf nem raid ist . auch auf hda4 unter 1024 zylindern , und sich vom 2.4er kernel ohne probleme mounten und nutzen lässt.

    das sind so die einzigen sachen die ich als fehler kennen würde , aber auschliesen kann. was gibts denn noch für einstellungen im kernel die für die ansteuerung der platten wichtig sind ? ich hab den automounter drin denke mal ned das er was damit zu tun hat zumal ich es schon mit , oder ohne versucht habe , funktioniert hat beides ned.

    komischerweiße hab ich das problem auf 2 verschiedenen computern , was mich recht sicher macht das das problem an mir liegt , bzw meiner unkenntnis über das richige konfigurieren des 2.6 er kernels .

    kann ich irgendie ein configfile von nem 2.4er kernel für den 2.6er nehmen ?
    so ind er art make oldconfig ? lann mich dunkel dran erinnern sowas mal in der ct gelesen zu haben , finde die stelle aber nimmer
     
  11. #10 erathosthenes, 08.03.2004
    erathosthenes

    erathosthenes my love

    Dabei seit:
    25.11.2002
    Beiträge:
    129
    Zustimmungen:
    0
    Ich hab zu dem thema auch schon mal bissel rumgespielt, und hab den selben fehler :rolleyes:. Lag's am ext3? Ne, weil, soweit ich noch den nerv hatte, liegt der fall so: Der 2.6.3er braucht auch um starten zu können ein initrd image. Warum? Das hab ich noch nicht raus. Und mit dem alten meines 2.4. gehts ja nicht =), also erstmal "man mkinitrd". Was mich aber auf nach 3 versuchen immer noch nicht zum ziel gebracht hatte, und den rechner den ganzen tag rauf und runter booten, ist schock schwere not zeitverschwendung, hab scheinbar irgendwas übersehen.
    Vielleicht so als Anstoß, an welcher stelle man weiter schauen sollte.
     
  12. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    Ort:
    D -> BW -> Karlsruhe
    Ne, ne. Ich hatte die gleichen Probs. Soweit ich mich entsinne lags daran, dass ich den Support für MSDOS-Partitions nicht drinne hatte. Er konnte beim booten quasi die Partitionstabelle nicht lesen und dann kam die Meldung " Kernel panic unable to mount rootfs". Mit dem initrd hab ich nix gemacht und nach ändern der Option gings bei mir auch.
     
  13. #12 damager, 09.03.2004
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    hmmm ... du könntest recht haben Cybermac.
    das war bei mir unteranderem der einzige unterschied zwischen der kernel-config von 2.4.25 (der funtzt) und 2.6.3 (der nicht funtzt).

    hab's jetzt mal ergänzt und schon mal das "backen" gestartet ... bin mal gespannt :]
     
  14. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    jo dummerweise hab ich alle möglichen filesysteme eingebunden , zumindest die windoof ( man hat halt altlasten als umsteiger )

    hab auf hda1 ne boot partition , aber die ganzen windoofdinger sind fest im kernel drin. daran sollte es ned liegen

    momentan arbeite ich halt mit dem 2.4.25er , muss ja auch mal was arbeiten und ned nur kernel backen.

    werde aber später nochmal versuchen das ding zum laufen bekommen . muss wohl irgendwo am filesystem liegen oder in den treiber , oder was weiß ich wo .

    werd mal das so durchtesten was ihr gepostet habt , hoffe die lösung für mich ist dabei sach euch dann was der kernel desmal will lol :D
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 damager, 10.03.2004
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    also bei mir lag es auch definitv an den MSDOS-Partitions-Support im kernel so wie Cybermarc beschrieben.
    habe geändert und jetzt kann auch boot ... aber dafür andere probleme :D ...aber hat mit den problem hier nichts zu tun.
     
  17. sono

    sono Sack Flöhe Hüter

    Dabei seit:
    31.01.2004
    Beiträge:
    1.299
    Zustimmungen:
    0
    Ort:
    http://webfrap.de
    nur mal so um mich zu beruhigen
    kann das sein das es generell gerne probleme mit den 2.6 er gibt , vor allem unter debian ?

    nur das ich mich nicht so einsam fühle ;(
     
Thema:

probleme mit den 2.6 er kerneln

Die Seite wird geladen...

probleme mit den 2.6 er kerneln - Ähnliche Themen

  1. grub-pc Probleme bei upgrade

    grub-pc Probleme bei upgrade: Hallo, ich habe beim dist-upgrade folgendes Problem: ---------- Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt. Trigger für...
  2. Probleme mit YUM

    Probleme mit YUM: Hallo, ich habe CentOs 7 als Dualboot mit Windows 7 auf einen Dell Latitude E5510 installiert. Dies hat soweit auch alles geklappt. Leider habe...
  3. Forscher analysieren Durchsatzprobleme im Linux-Scheduler

    Forscher analysieren Durchsatzprobleme im Linux-Scheduler: Eine Gruppe von Forschern hat Fälle identifiziert, in denen der Scheduler im Linux-Kernel falsche Entscheidungen trifft und die CPUs nicht so gut...
  4. München: LiMux als Sündenbock für IT-Probleme?

    München: LiMux als Sündenbock für IT-Probleme?: Im Münchner Stadtrat soll später in diesem Jahr erneut über den Einsatz von Linux in der Stadtverwaltung diskutiert werden. Die Grünen vermuten,...
  5. BSI-Audit findet keine akuten Probleme in OpenSSL

    BSI-Audit findet keine akuten Probleme in OpenSSL: Das Bundesamt für Sicherheit in der Informationstechnik hat OpenSSL auf seine Sicherheit untersuchen lassen. Die Analyse zeigt vor allem, dass die...