Problem mit Perl und Apache

Dieses Thema im Forum "RedHat,Fedora & CentOS" wurde erstellt von Jaridian, 04.10.2003.

  1. #1 Jaridian, 04.10.2003
    Jaridian

    Jaridian Jungspund

    Dabei seit:
    04.10.2003
    Beiträge:
    12
    Zustimmungen:
    0
    Bin so langsam aber sicher am verzweifeln. ?(
    Redhat 8.0
    perl: 5.80
    PHP: 5.0.0b1
    Kernel: 2.4.18-14
    Apache 2.047

    Mein Apache läuft.
    PHP-Scripte funktionieren ohne Probleme.
    Mein Perl läuft.
    Aber es ist mir nicht möglich, ein Perl-Script mit dem Apache zum Laufen zu bringen.
    Jedesmal wenn das Skript starten soll / bzw.startet, (Aufruf
    über Website) dann:
    You don't have permission to access /scripts/script.pl on this server.


    Rechte sind gesetzt auf: 755/777

    in der http.conf:
    DocumentRoot "/srv/http/htdocs"

    ScriptAlias /cgi-bin/ "/srv/http/htdocs/scripts/"

    <Directory "/srv/http/htdocs/scripts">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
    </Directory>

    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl

    die error_log sagt folgendes:
    Options ExecCGI is off in this directory: /srv/http/htdocs/scripts/script.pl

    das script:
    #!/usr/bin/perl
    print "Content-type: text/html\r\n\r\n";
    print "Hello, World.";


    Was mache ich falsch ? ?(
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Jaridian, 05.10.2003
    Jaridian

    Jaridian Jungspund

    Dabei seit:
    04.10.2003
    Beiträge:
    12
    Zustimmungen:
    0
    bin jetzt soweit:

    DocumentRoot "/srv/http/htdocs"

    ScriptAlias /cgi-bin/ "/srv/http/htdocs/cgi-bin/"

    <Directory "/srv/http/htdocs/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
    </Directory>

    <Location /cgi-bin>
    AllowOverride None
    Options +ExecCGI -Includes
    SetHandler cgi-script
    </Location>

    jetzt die fehlermeldung in der logerror:
    "Premature end of script headers"
     
  4. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Oh, das gleiche hatte ich mit nem SuSE Root Server mit Perl Scripts !
    Das Problem sollte aber dann am Script liegen ...
     
  5. #4 Jaridian, 05.10.2003
    Jaridian

    Jaridian Jungspund

    Dabei seit:
    04.10.2003
    Beiträge:
    12
    Zustimmungen:
    0
    glaube ich weniger, da es ja bei egal welchem script auftritt.
    habe u.a. auch versucht:
    #!/usr/local/bin/perl
    oder:
    #!/bin/sh
     
  6. cremi

    cremi Dude

    Dabei seit:
    15.02.2004
    Beiträge:
    329
    Zustimmungen:
    0
    Ort:
    AUT/Ktn
    habs selbe problem

    hast du eine lösung gefunden?
     
Thema:

Problem mit Perl und Apache

Die Seite wird geladen...

Problem mit Perl und Apache - Ähnliche Themen

  1. Zeichensatzprobleme - Perlskript mit cygwin unter Windows

    Zeichensatzprobleme - Perlskript mit cygwin unter Windows: Hallo, ich arbeite mit cygwin unter Windows XP und führe damit ein Perlskript aus. Das Skript liest Werte (Strings) aus einer Textdatei und...
  2. [Perl] Namespace Probleme

    [Perl] Namespace Probleme: Hallo zusammen, irgendwie scheitere ich gerade daran, meine sehr lange Hauptdatei in viele Module (*.pm) mit einem Steuerprogramm (.pl) zu...
  3. Perl: Problem mit "-d" Operator auf FAT

    Perl: Problem mit "-d" Operator auf FAT: Hallo! Ich bin grad etwas sehr verdutzt und verstehs auch ned ganz. Bin grade dabei ein Perl Skript zu schreiben, welches mir von einem...
  4. Problem: PHP + PERL + /bin/bash

    Problem: PHP + PERL + /bin/bash: Hallo, ich bin dabei ein kleinen Adminpanel zu schreiben. Der Pannel ist mit PHP programmiert und hat genügend Rechte um über system(); ein...
  5. Apache2 probleme mit PHP und Perl!!!!

    Apache2 probleme mit PHP und Perl!!!!: Erstmal Hallo Zusammen gruß an alle!!!! Habe folgendes Problem und zwar, sobald ich im Browser (sei es Firefox, oder Opera usw.) die adresse:...