Problem mit Bind und interner Adress/Namensauflösung

Dieses Thema im Forum "FreeBSD" wurde erstellt von h8000, 01.04.2008.

  1. h8000

    h8000 Grünschnabel

    Dabei seit:
    31.03.2008
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo,

    hier läuft bind8 auf FreeBSD 5.2.1, benutzt habe ich folgendes HOWTO: http://www.tuxweb.net/howto/dns/bsd/bind-89-bsd4x.html
    In den ersten Zeilen steht das es veraltet ist, habe aber in anderen Quellen die gleichen Informationen gefunden. Nun zu meinem Problem

    Beim Start meldet named keine Fehler.
    Die Auflösung externer Adressen funktioniert, in beide Richtungen.
    Die Auflösung der Internen Adressen endet so:

    Nslookup sagt: " Non-existent host/domain".
    Dnswalk sagt:

    Checking blah.blah.
    BAD: SOA record not found for blah.blah.
    BAD: blah.blah. has NO authoritative nameservers!
    BAD: All zone transfer attempts of blah.blah. failed!
    0 failures, 0 warnings, 3 errors.

    Die Troubleshooting Guides die ich gelesen habe, beziehen sich größtenteils auf fehler die auftreten wenn extere Namen nicht aufgelöst werden können.

    Server läuft nicht oder Host/Adresse nicht in der Liste sollten als Fehler ausgeschlossen sein.

    Anbei sind die Konfigurationsdateien, wäre echt klasse wenn Ihr mir helfen könnt, oder wisst wo ich nachlesen kann um das Problem zu lösen.

    Danke im Voraus


    /etc/resolv.conf

    domain blah.blah
    search blah.blah
    nameserver 127.0.0.1

    /etc/namedb/named.conf

    options {
    directory "/etc/namedb";
    allow-query { 192.168.100/24; 127.0.0.1; };
    listen-on { 192.168.100.2; 127.0.0.1; };
    version "unavailable";
    };

    zone "." {
    type hint;
    file "named.root";
    };

    zone "0.0.127.IN-ADDR.ARPA" {
    type master;
    file "localhost.rev";
    };

    zone "blah.blah" {
    type master;
    file "db.blah.blah.forw";
    allow-transfer { none; };
    };

    zone "100.168.192.in-addr.arpa" {
    type master;
    file "db.100.168.192";
    allow-transfer { none; };
    };

    /etc/namedb/db.blah.blah.forw

    ; forward lookup
    ;

    $TTL 3600

    @ IN SOA server.blah.blah. root.server.blah.blah. (
    1 ; Serial
    3600 ; Refresh
    900 ; Retry
    3600000 ; Expire
    3600 ) ; Minimum
    @ IN NS server.blah.blah.

    ; Machines
    localhost IN A 127.0.0.1
    router IN A 192.168.100.1
    server IN A 192.168.100.2
    drucker IN A 192.168.100.3

    /etc/namedb/db.100.168.192

    ;reverse lookup
    ;

    $TTL 3600

    @ IN SOA server.blah.blah. root.server.blah.blah. (
    2 ; Serial
    3600 ; Refresh
    900 ; Retry
    3600000 ; Expire
    3600 ) ; Minimum
    IN NS server.blah.blah.

    ; Machines
    1 IN PTR router.blah.blah.
    2 IN PTR server.blah.blah.
    3 IN PTR drucker.blah.blah.

    /etc/namedb/localhost.rev

    ; From: @(#)localhost.rev 5.1 (Berkeley) 6/30/90
    ; $FreeBSD: src/etc/namedb/PROTO.localhost.rev,v 1.6 2000/01/10 15:31:40 peter Exp $
    ;
    ; This file is automatically edited by the `make-localhost' script in
    ; the /etc/namedb directory.
    ;

    $TTL 3600

    @ IN SOA server.blah.blah. root.server.blah.blah. (
    3 ; Serial
    3600 ; Refresh
    900 ; Retry
    3600000 ; Expire
    3600 ) ; Minimum
    IN NS server.blah.blah.
    1 IN PTR localhost.server.blah.blah.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Herr Nilsson, 01.04.2008
    Herr Nilsson

    Herr Nilsson Eroberer

    Dabei seit:
    21.03.2008
    Beiträge:
    62
    Zustimmungen:
    0
    Ort:
    Dortmund
    Schon mal im FreeBSD-Handbook nachgeschaut? Die Doku ist wirklich gut! Im Kapitel 27.6 wird DNS ausführlich besprochen.
     
  4. h8000

    h8000 Grünschnabel

    Dabei seit:
    31.03.2008
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo,

    wie Ihr bestimmt schon gemerkt habt ist das mein erster Kontakt mit Bind.

    Das Kapitel über DNS im FreeBSD Handbuch habe ich schon gelesen.

    In der Konfiguration kann ich keinen Fehler erkennen. Ich weiss aber ehrlich gesagt auch nicht wonach ich suchen soll/muss. Wenn ich den Netzwerktraffic mit Wireshark beobachte kann ich sehen das DNS Anfragen die lokale Adressen oder Namen enthalten das lokale Netz verlassen und an externe Server geschickt werden, aber warum? :hilfe2: Der Domainname ist übrigens wirklich blah.blah. Wollte einen Namen bei dem sicher ist das er nicht mit "echten" Domainnamen kollidiert. Ist der Fehler da zu suchen? ?(
     
  5. #4 diirch, 28.04.2008
    Zuletzt bearbeitet: 28.04.2008
    diirch

    diirch Mit Glied

    Dabei seit:
    17.06.2006
    Beiträge:
    121
    Zustimmungen:
    0
    Ort:
    Hamburg
    Hallo

    Meine Bind-config:

    /etc/namedb/named.conf:

    Code:
    options {
            directory "/etc/namedb";
            pid-file "/var/run/named/pid";
    
            listen-on port 53 { 192.168.23.1; 127.0.0.1; };
    
    
            forwarders {
                    213.155.150.205;
                    63.208.196.90;
                    213.191.74.18;
                    213.191.92.87;
            };
    
            dump-file "s/named_dump.db";
    };
    
    zone "." {
            type hint;
            file "named.root";
    };
    
    zone "0.0.127.IN-ADDR.ARPA" {
            type master;
            file "localhost.rev";
    };
    
    zone "1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA" {
            type master;
            file "localhost-v6.rev";
    };
    
    zone "brain-calibration.com" {
            type master;
            file "master/ipv4/brain-calibration.com.";
    };
    
    zone "23.168.192.in-addr.arpa" {
            type master;
            file "master/ipv4/23.168.192.IN-ADDR.ARPA.";
    };
    
    zone "brain-calibration6.com" {
            type master;
            file "master/ipv6/brain-calibration6.com.";
    };
    
    zone "0.0.0.0.2.4.2.4.3.2.3.2.0.c.e.f.IP6.ARPA." {
            type master;
            file "master/ipv6/0.0.0.0.2.4.2.4.3.2.3.2.0.c.e.f.IP6.ARPA.";
    };
    

    forwärts:

    /etc/namedb/master/ipv4/brain-calibration.com.

    Code:
    $TTL    76800
    @               IN      SOA     brain-calibration.com. root.brain-calibration.com. (
                                    1840448266
                                    21600
                                    7200
                                    864000
                                    76800 )
                    IN      NS      dns.brain-calibration.com.
    ;
    ; SERVERS
    ;
    napalm                  A       192.168.23.10
                            HINFO   Athlon3200 BSD
    dns                     A       192.168.23.1
                            HINFO   Athlon3200 BSD
    smb                     A       192.168.23.2
                            HINFO   Athlon3200 BSD
    4d                      A       192.168.23.230
                            HINFO   Athlon64X2 BSD
    amok                    A       192.168.23.235
                            HINFO   Athlon64X2 BSD
    dildozer                A       192.168.23.236
                            HINFO   Athlon2400 BSD
    ;
    ; STATIONS
    ;
    dhcp1                   A       192.168.23.101
    dhcp2                   A       192.168.23.102
    dhcp3                   A       192.168.23.103
    dhcp4                   A       192.168.23.104
    dhcp5                   A       192.168.23.105
    dhcp6                   A       192.168.23.106
    dhcp7                   A       192.168.23.107
    dhcp8                   A       192.168.23.108
    dhcp9                   A       192.168.23.109
    dhcp10                  A       192.168.23.110
    dhcp11                  A       192.168.23.111
    dhcp12                  A       192.168.23.112
    dhcp13                  A       192.168.23.113
    dhcp14                  A       192.168.23.114
    


    rückwarts:

    /etc/namedb/master/ipv4/23.168.192.IN-ADDR.ARPA.

    Code:
    $TTL    76800
    @                       IN      SOA     brain-calibration.com. root.brain-calibration.com. (
                                    1867717842
                                    21600
                                    7200
                                    864000
                                    76800 )
                            IN      NS      dns.brain-calibration.com.
    ;
    ; SERVERS
    ;
    10                      PTR     napalm.brain-calibration.com.
    1                       PTR     dns.brain-calibration.com.
    2                       PTR     smb.brain-calibration.com.
    230                     PTR     4d.brain-calibration.com.
    235                     PTR     amok.brain-calibration.com.
    236                     PTR     dildozer.brain-calibration.com.
    ;
    ; Stations
    ;
    101                     PTR     dhcp1.brain-calibration.com.
    102                     PTR     dhcp2.brain-calibration.com.
    103                     PTR     dhcp3.brain-calibration.com.
    104                     PTR     dhcp4.brain-calibration.com.
    105                     PTR     dhcp5.brain-calibration.com.
    106                     PTR     dhcp6.brain-calibration.com.
    107                     PTR     dhcp7.brain-calibration.com.
    108                     PTR     dhcp8.brain-calibration.com.
    109                     PTR     dhcp9.brain-calibration.com.
    110                     PTR     dhcp10.brain-calibration.com.
    111                     PTR     dhcp11.brain-calibration.com.
    112                     PTR     dhcp12.brain-calibration.com.
    113                     PTR     dhcp13.brain-calibration.com.
    114                     PTR     dhcp14.brain-calibration.com.
    
    Läuft definitiv :D

    Gruss Diirch
     
  6. #5 Herr Nilsson, 28.04.2008
    Zuletzt bearbeitet: 28.04.2008
    Herr Nilsson

    Herr Nilsson Eroberer

    Dabei seit:
    21.03.2008
    Beiträge:
    62
    Zustimmungen:
    0
    Ort:
    Dortmund
    1. In Deiner "resolv.conf" solltest Du den "search"-Eintrags für die Domäne weglassen, weil wegen des "domain"-Eintrag schon ein fehlender Domain-Suffix anhängt würde.
    2. Verändere in Deiner "db.blah.blah.forw"-Datei den Eintrag "@ IN NS server.blah.blah." zu "IN NS server.blah.blah."; laß zudem den "localhost IN A 127.0.0.1" hier weg, da er nicht zur Domäne gehört. Ich empfehle Dir, diesen Eintrag in der "/etc/hosts"-Datei vorzunehmen:
      Code:
      127.0.0.1      localhost.blah.blah localhost
      
    3. Es kann vorteilhaft sein, wenn auf Deinem Server in der "/etc/hosts"-Datei folgender Eintrag steht:
      Code:
      192.168.100.2      server.blah.blah server
      192.168.100.2      server.blah.blah.
      

    Gib zudem mal bitte die Ausgabe folgender Befehle an:
    Code:
    # ps -ax | grep named
    # nslookup server
    # nslookup server.blah.blah
    # nslookup 192.168.100.2
    # dig @localhost server.blah.blah
    # dig server.blah.blah
    
     
  7. h8000

    h8000 Grünschnabel

    Dabei seit:
    31.03.2008
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo,

    die Änderungen in der resolv.conf und in /etc/hosts habe ich vorgenommen.
    Die Ausgaben von:

    ps -ax | grep named
    nslookup server
    nslookup server.blah.blah
    nslookup 192.168.100.2
    dig @localhost server.blah.blah
    dig server.blah.blah

    sind leider die gleichen wie vorher:

    server# ps -ax | grep named
    28013 ?? Is 0:03.61 /usr/sbin/named
    39960 p0 R+ 0:00.00 grep named



    server# nslookup server
    Server: localhost.server.blah.blah
    Address: 127.0.0.1

    *** localhost.server.blah.blah can't find server: Non-existent host/domain


    server# nslookup server.blah.blah
    Server: localhost.server.blah.blah
    Address: 127.0.0.1

    *** localhost.server.blah.blah can't find server.blah.blah: Non-existent host/domain


    server# nslookup 192.168.100.2
    Server: localhost.server.blah.blah
    Address: 127.0.0.1

    *** localhost.server.blah.blah can't find 192.168.100.2: Non-existent host/domain


    server# dig @localhost server.blah.blah

    ; <<>> DiG 8.3 <<>> @localhost server.blah.blah
    ; (2 servers found)
    ;; res options: init recurs defnam dnsrch
    ;; got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 49077
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    ;; QUERY SECTION:
    ;; server.blah.blah, type = A, class = IN

    ;; AUTHORITY SECTION:
    . 1h34m IN SOA a.root-servers.net. nstld.verisign-grs.com. (
    2008050200 ; serial
    30M ; refresh
    15M ; retry
    1W ; expiry
    1D ) ; minimum


    ;; Total query time: 2 msec
    ;; FROM: server to SERVER: 127.0.0.1
    ;; WHEN: Fri May 2 15:44:30 2008
    ;; MSG SIZE sent: 28 rcvd: 103



    server# dig server.blah.blah

    ; <<>> DiG 8.3 <<>> server.blah.blah
    ;; res options: init recurs defnam dnsrch
    ;; got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 44259
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    ;; QUERY SECTION:
    ;; server.blah.blah, type = A, class = IN

    ;; AUTHORITY SECTION:
    . 1h33m23s IN SOA a.root-servers.net. nstld.verisign-grs.com. (
    2008050200 ; serial
    30M ; refresh
    15M ; retry
    1W ; expiry
    1D ) ; minimum


    ;; Total query time: 1 msec
    ;; FROM: server to SERVER: 127.0.0.1
    ;; WHEN: Fri May 2 15:45:07 2008
    ;; MSG SIZE sent: 28 rcvd: 103



    Noch eine Frage: sind die Einträge in den Konfigurationsdateien "case sensitive"? Also wird "nslookup Server" so interpretiert wie "nslookup server"?
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 Herr Nilsson, 03.05.2008
    Herr Nilsson

    Herr Nilsson Eroberer

    Dabei seit:
    21.03.2008
    Beiträge:
    62
    Zustimmungen:
    0
    Ort:
    Dortmund
    Normalerweise müßte die Antwort auf 'nslookup server' so aussehen:
    Code:
    $ nslookup server
    Server:         127.0.0.1
    Address:        127.0.0.1#53
    
    Name:   server.blah.blah
    Address: 192.168.100.2
    
    Dein Eintrag lautet "localhost.server.blah.blah"; ein DNS-"Prefix" ist schon etwas seltsames...

    Schau mal hier:
    Code:
    /etc/namedb/localhost.rev
     
     ; From: @(#)localhost.rev 5.1 (Berkeley) 6/30/90
     ; $FreeBSD: src/etc/namedb/PROTO.localhost.rev,v 1.6 2000/01/10 15:31:40 peter Exp $
     ;
     ; This file is automatically edited by the `make-localhost' script in
     ; the /etc/namedb directory.
     ;
     
     $TTL 3600
     
     @ IN SOA server.blah.blah. root.server.blah.blah. (
     3 ; Serial
     3600 ; Refresh
     900 ; Retry
     3600000 ; Expire
     3600 ) ; Minimum
     IN NS server.blah.blah.
    [COLOR="RED"] 1 IN PTR localhost.server.blah.blah.[/COLOR]
    
    Das habe ich wohl übersehen: es muß
    Code:
    1       IN      PTR     localhost.blah.blah.
    
    heißen.

    Seltsam hierbei ist, daß diese Datei normalerweise durch den Aufruf des im Handbuch unter "27.6.6.1 Using make-localhost" erwähnten Scripts erzeugt worden sein sollte - und dieses Script nimmt sich als Vorlage die Daten der Systemkonfiguration.

    Entweder Du hast diesen falschen Eintrag selber gemacht oder etwas stimmt mit der Konfiguration Deines Rechners nicht. Falls Du letzteres vermutest, richte am besten noch mal mit sysinstall Deine Netzwerkkarte/Netwerk ein: Configure, Networking, Interfaces. Es könnten die Einträge "Host" und "Domain" betroffen sein.
     
  10. h8000

    h8000 Grünschnabel

    Dabei seit:
    31.03.2008
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo,

    ES FUNKTIONIERT! :D

    Erstmal ein riesen DANKE für eure Unterstützung! :):):)

    Leider weiss ich immer noch nicht 100%ig was das Problem verursacht hat. ?(

    Gemacht habe ich folgendes:

    Freebsd 5.2.1 auf einem andern Rechner installiert, die Konfiguration 1zu1 übernommen.
    Siehe da, es funktioniert!? ?(

    Auf dem Rechner auf dem es nicht funktioniert hat, alle Konfigurationen gelöscht und
    make-localhost ausgeführt. Die neuen Dateien habe ich aus der "localhost.rev" erstellt.

    Der Unterschied besteht darin das ich alle Dateien "von Hand" direkt auf dem Rechner erstellt habe.
    Die "alten" habe ich mit dem Editor unter Windows erstellt und den Inhalt dann in ein "putty" Fenster eingefügt.
    Könnte dieser Vorgang die Probleme verursacht haben?
     
Thema:

Problem mit Bind und interner Adress/Namensauflösung

Die Seite wird geladen...

Problem mit Bind und interner Adress/Namensauflösung - Ähnliche Themen

  1. JBidWatcher: Problem bei loading Auctions in Verbindung mit mySQL

    JBidWatcher: Problem bei loading Auctions in Verbindung mit mySQL: Moin Moin, ich habe das Problem bei JBidWatcher, dass ich das Programm in Verbindung mit einer mySQL-Datenbank nutzen möchte... Leider hängt...
  2. Problem mit MPD Konfiguration, kann lokal nicht verbinden

    Problem mit MPD Konfiguration, kann lokal nicht verbinden: Hi Leute, ich habe hier ein Linux-Board mit Touchscreen+Sound. Das Linux darauf ist eine Art "Eigenbau-Debian", das Debian-armel mit eigenen...
  3. Probleme mit Workstation-Domäneneinbindung

    Probleme mit Workstation-Domäneneinbindung: Hallo zusammen, ich habe einen samba-PDC mit ldap-Authentifizierung eingerichtet. Ich kann auch auf die freigegebenen Laufwerke im...
  4. VPN Verbindungsprobleme

    VPN Verbindungsprobleme: Hallo Leute, ich habe ein grosses problem mit vpn. Ich kann mich nicht mit meinem server verbinden. Siehe /var/log/messages client:...
  5. Samba Problem bei Verbindung zu Share

    Samba Problem bei Verbindung zu Share: Hallo zusammen. Ich möchte mit Samba einen einfachen Sahre auf meinem Solaris 10 Server einrichten. Leider erscheint immer wieder das Windows...