PHP4 unter SuSE 10.x

Dieses Thema im Forum "Web- & File-Services" wurde erstellt von flori000, 18.02.2007.

  1. #1 flori000, 18.02.2007
    flori000

    flori000 Grünschnabel

    Dabei seit:
    18.02.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Hallöchen,

    ich bin normal Ubuntu-User und wollt mir das neue SuSE 10.3Alpha1 anschauen. Hat sich ja wirklich viel getan seit 8.0 ;)

    Nun aber zu meiner Frage... Apache, mysql etc. ist bereits eingerichtet... Nur kommt SuSE leider mit PHP5 daher... und ich programmiere ausschließlich in PHP4... Gibts da ne Möglichkeit das bequem nachzuinstallieren durch nen Repro oder so?

    Danke und Gruß

    flori000
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. ftx

    ftx Foren As

    Dabei seit:
    12.07.2006
    Beiträge:
    77
    Zustimmungen:
    0
    mal ne frage ... warum programmierst du in php4 und nicht 5 ? ist nur so interessenshalber, da ich vor kurzem mit php angefangen habe :D ich meine bei 5 ist doch die OOP mit dazugekommen, was ja eigentlich nicht schlecht ist :)
     
  4. .mike.

    .mike. Doppel-As

    Dabei seit:
    27.08.2006
    Beiträge:
    207
    Zustimmungen:
    0
  5. #4 flori000, 18.02.2007
    flori000

    flori000 Grünschnabel

    Dabei seit:
    18.02.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Weil PHP5 mir zuviele Änderungen hat und ich praktisch umschulen müsste... das sehe ich gerade daran da keine Seite mehr (lokal) wirklich 100% läuft. Und OOP brauch ich nicht wirklich für das was ich mache...

    Daher... muss PHP4 her... sonst wechsel ich halt wieder zu Debian ;) Da hats php4 :D
     
  6. dmaphy

    dmaphy Routinier

    Dabei seit:
    16.04.2004
    Beiträge:
    482
    Zustimmungen:
    0
    Ort:
    Hamburg
    PHP5 verarbeitet doch aber problemlos Scripte, die für PHP4 geschrieben sind. Ich verstehe das Problem nicht. O.o
     
  7. karru

    karru OSX'ler

    Dabei seit:
    02.05.2006
    Beiträge:
    338
    Zustimmungen:
    0
    Das stimmt nicht. Es gibt einiges an Software, welches nur unter PHP4 und nicht unter PHP5 läuft. Es gibt auch Einzellfälle wo man sogar zwischen PHP4.3 und PHP4.4 unterscheiden muss.
    Als Beispiel das ECMS eZ Publish. :brav:

    Wegen PHP4, vielleicht gibt's auf den Repos vom Guru noch brauchbare Pakete.
    http://linux01.gwdg.de/~pbleser/

    karru
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 Mµ*e^13.5_?¿, 18.02.2007
    Mµ*e^13.5_?¿

    Mµ*e^13.5_?¿ Routinier

    Dabei seit:
    21.02.2006
    Beiträge:
    453
    Zustimmungen:
    0
    Ja, es gibt ein paar Sachen, die sich geändert haben.
    Aber dass man komplett umlernen müsste, wenn die Scripte auch auf php5 laufen sollen, halte ich für eine heftige Übertreibung.

    Achja, OOP gibt es (wenn auch ziemlich einfach) auch unter php4.
     
  10. #8 flori000, 18.02.2007
    flori000

    flori000 Grünschnabel

    Dabei seit:
    18.02.2007
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo,

    danke für die Antworten...
    Die Guru Seite beinhaltet leider kein PHP4...
    Ich werd jetzt SuSE löschen und wieder zu Debian wechseln. Gibt halt doch nichts bessres ;)

    Danke an alle...

    Gruß

    flori000
     
Thema:

PHP4 unter SuSE 10.x

Die Seite wird geladen...

PHP4 unter SuSE 10.x - Ähnliche Themen

  1. Apache2 mit PHP4 und PHP5 (Debian Etch)

    Apache2 mit PHP4 und PHP5 (Debian Etch): Hallo, ich suche nun schon seit einiger Zeit im Internet eine gute Anleitung wie ich unter Debian Etch mit Apache2 mit der PHP-Version 4 und 5...
  2. libphp4.so fehlt

    libphp4.so fehlt: hallo zusammen, nach ewig langem rumprobieren und stundenlangen quaelerein mit fehlenden abhaengigkeiten habe ich es endlich wieder geschafft,...
  3. Debian Etch und Apache2 + Php4 oder 5

    Debian Etch und Apache2 + Php4 oder 5: Hallo Leutz, hab ein Problem und zwar habe ich mir vor tagen Debian Etch installiert mit Apache2 php4 php5 und modul apache2-mod-php5 nun lief...
  4. Apache2 PHP4 mysql Fedora @ RS6000

    Apache2 PHP4 mysql Fedora @ RS6000: Eigendlich kenne ich mich mit Fedora garnicht aus, aber wie es der Zufall will kann ich auf meinem RS6000 kein Debian Installieren und musste...
  5. [Suse 9.3]Update von PHP4 auf PHP5

    [Suse 9.3]Update von PHP4 auf PHP5: Hi, ich habe bei Server4You einen VServer mit Suse Linux 9.3 gemietet, nun würde ich gerne die mittlerweile schon recht alte PHP4 Version durch...