Per Samba auf Netzwerk-Fetsplatte zugreifen

Dieses Thema im Forum "Samba" wurde erstellt von UllaUffz, 02.03.2008.

  1. #1 UllaUffz, 02.03.2008
    Zuletzt bearbeitet: 06.03.2008
    UllaUffz

    UllaUffz Eroberer

    Dabei seit:
    25.01.2006
    Beiträge:
    57
    Zustimmungen:
    0
    Per Samba auf Netzwerk-Festplatte zugreifen

    Hi,
    ich suche jetzt schon eine geraume Weile habe aber noch nichts gefunden, was mir weiterhilft.

    Problem: Ich weill eine Festplatte im Netzwerk beim Systemstart von SuSE 10.3 mounten lassen.

    Bis heute Mittag galt:
    Platte läuft, kann sie von einem anderen Rechner (SuSE 10.2) aus nutzen. Bei beiden Rechnern sind die gleichen samba-Pakete installiert.
    Ich habe Samba-Unterstuetzung im Kernel aktiviert (Kann ich überprüfen, ob das geklappt hat?).

    Über smb://192.160.0.3/Daten kann ich auf die Platte zugreifen (Konqueror).
    Die Mountpunkte habe ich in der fstab eingetragen wie bei dem anderen Rechner auch.
    "//192.168.0.3/Daten /mnt/smb/Daten smbfs auto,username=name,password=pass,uid=1000,gid=100 0 0"
    Geht aber nicht :-(. "Service skipped" kommt als Meldung auf Konsole 1.

    Ich habe auch einen Mountpunkt in die /etc/samba/sambafstab eingetragen. Fehlermeldung:
    "//192.168.0.3/Daten on /mnt/smb/Daten type smbfs .Starting Avahi daemon
    mount: wrong fs type, bad option, bad superblock on //192.168.0.3/Daten,
    missing codepage or helper Programm, or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so"
    dmesg:
    "smbfs: mount_data version 1919251317 is not supported"
    Laut Internet heisst das, dass smbfs nicht installiert ist. "lsmod" listet smbfs aber und mein Runleveleditor sagt, smbfs wird in den Runleveln 3 und 5 gestartet.

    Habe auch versucht mit cifs statt smbfs zu mounten (in der fstab den Eintrag geaendert) .
    dmesg bring da folgenden Fehler:
    "CIFS VFS: Error connecting to IPv4 socket Aborting operation
    CIFS VFS: cifs_mount failed w/return code = -101"
    Aber auch da finde ich nichts an Hilfe :-(.

    Bin irgendwie ratlos, denn der Zugriff findet ja statt und mit den gleichen Eintraegen laeuft es auf dem anderen Rechner.

    Mitlerweile geht gar nichts mehr :->.
    Ich habe auf dem Rechner mit Suse 10.2 ein Update der Samba-Pakete gemacht. Seitdem tritt dort das gleiche Problem auf.
    Muss also was mit der Samba-Version zu tun haben scheint es.
    Ich habe auch versucht die Platte als CIFS in die smbfstab einzutragen:
    //192.168.0.3/Daten /mnt/smb/Daten smbfs gid=100,uid=1000,username=name,password=pass
    Dann mountet er die Platte beim booten. Nur leider trotz der Übergabe der Parameter gehören alle Dateien root. Schade eigentlich. Wenn ich da die Rechtevergabe in den Griff bekommen wuerde, waere das eine Alternative... Aber auch hier keien Idee obwohl ich schon ne Zeit lange gesucht habe :-(.
    Wenn ich statt cifs smbfs eintrage sagt er wieder "wrong fs type".
    Aber auch auf dem Rechner läuft (laut lsmod) smbfs.

    Welche(n) Fehler mache ich?

    Wäre nett, wenn mir wer helfen koennte. Gerne auch rtfm (Welches?)

    Gruß
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Mµ*e^13.5_?¿, 02.03.2008
    Mµ*e^13.5_?¿

    Mµ*e^13.5_?¿ Routinier

    Dabei seit:
    21.02.2006
    Beiträge:
    453
    Zustimmungen:
    0
    Nur um ganz sicherzugehen: Der Befehl mount.smbfs ist vorhanden?
     
  4. #3 UllaUffz, 02.03.2008
    Zuletzt bearbeitet: 02.03.2008
    UllaUffz

    UllaUffz Eroberer

    Dabei seit:
    25.01.2006
    Beiträge:
    57
    Zustimmungen:
    0
    Der Befehl mount.smbfs ist nicht vorhanden.
    Ich suche gerade danach, wo ich den herbekomme, habe aber noch nichts passendes gefunden. Hört sich so an, als obdas was mit der Samba-Unterstuützung im Kernel zu tun hat... bin ich da auf der richtigen Spur?
    Oder müsste das in einem Paket drin sein, das ich nicht habe?
    mount.cifs ist da. Aber da gehen ja die Rechte nicht zu setzen...
    Ich suche mal weiter, freue mich aber auch über Hilfe.
     
  5. #4 Mµ*e^13.5_?¿, 02.03.2008
    Mµ*e^13.5_?¿

    Mµ*e^13.5_?¿ Routinier

    Dabei seit:
    21.02.2006
    Beiträge:
    453
    Zustimmungen:
    0
  6. #5 supersucker, 02.03.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    smbfs wird IMHO schon seit längerer Zeit nicht mehr offiziell unterstützt.

    Ich mounte meine SMB-share mit cifs anstelle von smbfs.

    Probier einfach mal statt:

    Code:
    //192.168.0.3/Daten /mnt/smb/Daten [COLOR="Red"][B]smbfs[/B][/COLOR] auto,username=name,password=pass,uid=1000,gid=100 0 0
    Code:
    //192.168.0.3/Daten /mnt/smb/Daten [COLOR="Red"][B]cifs[/B][/COLOR] auto,username=name,password=pass,uid=1000,gid=100 0 0
    Damit sollte es klappen.
     
  7. #6 UllaUffz, 02.03.2008
    Zuletzt bearbeitet: 02.03.2008
    UllaUffz

    UllaUffz Eroberer

    Dabei seit:
    25.01.2006
    Beiträge:
    57
    Zustimmungen:
    0
    samba-client ist installiert, auf beiden Rechnern.
    Die Datei ist allerdings nicht im Paket enthalten (laut Yast).
    im Verzeichnis /sbin befindet sich nur die Datei rcsmbfs.
    Habe jetzt mal das jengelh-Paket samba-client installiert, in dem die Datei mount.smbfs drin ist (Datei st da), aber es funktioniert trotzdem nicht.

    Ja, Samba ist nicht mehr offiziell im Kernel. Das hab ich da auch extra reingebacken, denn mt CIFS kann ich keine Rechte vergeben :-(. Egal welche Parameter ich uebergebe alle Daten gehören root.

    OT: Verzweiflung macht sich breit... das ging doch gestern noch... :-(
     
  8. #7 supersucker, 02.03.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Hä?

    Das stimmt so definitiv nicht.

    Ich verwende cifs sowohl privat als auch beruflich, und natürlich kannst du damit auch Rechte vergeben.

    Wenn das bei dir nicht klappt, machst du etwas falsch, aber das wäre jetzt ein anderes Problem....
     
  9. #8 Mµ*e^13.5_?¿, 02.03.2008
    Mµ*e^13.5_?¿

    Mµ*e^13.5_?¿ Routinier

    Dabei seit:
    21.02.2006
    Beiträge:
    453
    Zustimmungen:
    0
    Was mir grade aufgefallen ist, ist das mount.smbfs bei mir (und auch in dem Paket samba-client) nur ein Shell-Script ist, das ein paar Optionen umändert und dann mount.cifs aufruft. Das war also kein sehr guter Tip :(
    Das ganze scheint sehr merkwürdig zu sein, bei mir funktioniert das mit der option uid=.. einwandfrei.
     
  10. #9 UllaUffz, 02.03.2008
    Zuletzt bearbeitet: 03.03.2008
    UllaUffz

    UllaUffz Eroberer

    Dabei seit:
    25.01.2006
    Beiträge:
    57
    Zustimmungen:
    0
    Ich weiss, dass es gehen muss per cifs Rechte zu vergeben.
    Aber ich übergebe Parameter und er nimmt sie nicht an:
    //192.168.0.3/Daten /mnt/smb/Daten cifs auto,username=name,password=pass,uid=1000,gid=100 0 0
    Auch wenn ich diese Optionen in der smbfstab (ohne die beiden Nulen hinten) übergebe ist das Ergebnis das Gleiche: Alle Dateien gehören root.
    Wenn ich dabei etwas falsches eingebe wäre ich auch hier um Hilfe dankbar. Neuer Thread hierzu.

    Edit:
    Wie im neuen Beitrag beschrieben habe ich versucht mit cifs zu mounten und ein Problem damit den Besitzer zuzuweisen.
    Paralles dazu noch ein Versuch mit Samba:
    Wenn ich die Platte per Hand mounte stimmt alles (Benutzer, Gruppe, Rechte):
    mount -t smbfs -o username=name,password=pass,uid=1000,gid=100 //192.168.0.3/Daten /mnt/smb/Daten
    Selbiges (an die Dateien angepasster Eintrag) in /etc/fstab oder /etc/samba/smbfstab führt zu nichts. Nach dem Reboot ist die Platte nicht eingehängt. Eine Fehlermeldung finde ich nicht (Wo koennte ich da noch suchen ausser in dmesg?).
    Was mich stutzig macht: Wechsle ich im Konqueror in das Verzeichnis /mnt/smb/Daten, ist es zwar leer, aber die Festplatte faengt zu laufen an...
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. #10 UllaUffz, 04.03.2008
    Zuletzt bearbeitet: 06.03.2008
    UllaUffz

    UllaUffz Eroberer

    Dabei seit:
    25.01.2006
    Beiträge:
    57
    Zustimmungen:
    0
    Nach vielen Stunden lesen und probieren:

    Notebook (Suse 10.3):
    Der Befehl
    Code:
    mount -t cifs -o uid=achim,gid=users,username=name,password=pass //192.168.0.3/Daten /mnt/smb/Daten/
    mountet die Platte wie gewünscht.
    Der Eintrag
    Code:
    //192.168.0.3/Daten /mnt/smb/Daten cifs uid=achim,gid=users,username=name,password=pass
    in der /etc/samba/smbfstab
    führt dazu, dass die Platte nicht gemountet wird, aber:
    führe ich danach
    Code:
    rcsmbfs start
    durch, mountet er die Platte genau so wie sie sein soll.
    Code:
    chkconfig -l smbfs
    sagt mir aber, dass der Dienst in den Runleveln 3 und 5 gestartet wird.
    Was kann ich denn tun, damit das auch wirlich passiert?

    Habe jetzt was gelesen das koennte daran liegen, das die Netzwerkverbindung erst später (im Userspace) aufgebaut wird und deshalb noch kein Netz da ist, wenn Samba gemountet wird.
    Weiss jemand was man da machen kann?

    Festnetzrechner (Suse 10.2):
    Gleiche Vorgehensweise wie oben beschrieben führt zum "alten" Ergebnis: Alle Daten gehören root.

    Ich hab keine Probleme damit den Festnetzrechner auf 10.3 umzustellen, wenn ich die Loesung fuer das rcsmbfs-Problem finde...
    Bitte erneut um Mithilfe.
    Danke
     
  13. #11 UllaUffz, 06.03.2008
    UllaUffz

    UllaUffz Eroberer

    Dabei seit:
    25.01.2006
    Beiträge:
    57
    Zustimmungen:
    0
    Es gibt was neues...

    Teilerfolg:

    Auf meinem Festnetzrechner läuft jetzt Suse 10.3 und da das Netzwerk dort mit ifup gestartet wird (also traditionell) startet rcsmbfs erst nach dem Netzwerk und alles ist wunderbar :-).

    Teilmisserfolg:

    Auf dem Notebook startet die Wlan-Karte nicht wenn ich "traditionell (ifup) seinstelle... warum auch immer. Da geht garnichts. Also muss ich da wohl mal mit den scripten rumspielen um rcsmbfs ausführen zu lassen, nachdem das Netz oben ist...
     
Thema:

Per Samba auf Netzwerk-Fetsplatte zugreifen

Die Seite wird geladen...

Per Samba auf Netzwerk-Fetsplatte zugreifen - Ähnliche Themen

  1. Samba4 AD DC

    Samba4 AD DC: Hey Forum, das ist mein erster Post ich hoffe ich bin in der Richtigen section [IMG] Ich habe mit OpenSuSe 42.1 probiert einen Samba4 AD DC...
  2. Samba Active Directory SUBDOMAIN

    Samba Active Directory SUBDOMAIN: Hi, ich habe eine Samba Domäne ESC.LAN mit Samba 4.5 aufgebaut. Jetzt würde ich gern einen neuen Domänen AD im Tree MUNICH.ESC.LAN also eine...
  3. Wiederherstellen von überschriebenen Dokumenten auf debian samba

    Wiederherstellen von überschriebenen Dokumenten auf debian samba: Ich habe ein Problem. Vor Kurzem hat der Trojaner cryptologer einen Schaden eingerichtet. Glücklicherweise gab es eine Sicherung auf...
  4. SAMBA für Windows10 Domäne einrichten

    SAMBA für Windows10 Domäne einrichten: Hallo, ich habe letztes Wochenende verzweifelt versucht, Samba auf meinem Server einzurichten, daher versuche ich aktuell meinen Fehler zu...
  5. Problem mit Win-Zugriff auf SAMBA

    Problem mit Win-Zugriff auf SAMBA: Hallo rundherum, vielleicht hat jemand eine Idee... Habe jetzt schon 1 1/2 Tage damit verbraten und den Fehler nicht gefunden. Problem:...