Paket defekt

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von MacLux, 27.06.2007.

  1. MacLux

    MacLux Eroberer

    Dabei seit:
    19.06.2006
    Beiträge:
    50
    Zustimmungen:
    0
    Hallo,

    habe versucht, auf einer recht "nackten" Debian Sarge Installation einen funktionierenden GCC zu installieren. Bei dem, der mit auf der Distributions-CD mit drauf war und denn ich per synaptic installiert habe, bekam ich immer gesagt, er könnte keine Executables erzeugen. In einem anderen Forum hab ich gelesen, dass noch der g++ hinzuinstalliert werden müsste. Der war aber leider nicht in der korrekten Version für den gcc4.1 auf der CD.

    Also hab ich per "dpkg- i g++4.1xxx.deb" das Paket installiert. Der wollte dann aber eine bestimmte Version der libc6xxxdev haben. Die hab ich ihm auch nachgereicht. per "dpkg -i ..." Entweder hab ich jetzt irgendwo das falsche Paket erwischt (ich hab nie eins der force-Flags benutzt!), aber jedenfalls hab ich im Synaptic jetzt ein "defektes Paket" stehen: libstdc++6.4.1-dev (kann sein, dass ich versehentlich das statt libc6 installiert hab).

    Problem ist, ich bekomm's nicht mehr weg. "dpkg -r" zählt mir tonnenweise Applikationen auf, die davon abhängig sind, obwohl ich denke, es gerade erst drauf gepackt zu haben (und explizit überschrieben hab ich ja nix). Wie krieg ich das wieder gefixt? Kann mir jemand helfen?

    Gruss,
    Mac
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 27.06.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Vergiss das mit der CD und trag die entsprechenden Quellen in die /etc/apt/sources.list ein.

    Dann

    Code:
    apt-get clean
    apt-get update
    apt-get install -f
    apt-get upgrade
    apt-get dist-upgrade
    apt-get install build-essential
    
     
  4. MacLux

    MacLux Eroberer

    Dabei seit:
    19.06.2006
    Beiträge:
    50
    Zustimmungen:
    0

    Ok, hat erstmal funktioniert. Die defekten Abhängigkeiten sind weg. Danke!
    Jetzt kann ich mich wieder dem eigentlichen Problem zuwenden.
    Müsste ich nicht mit "apt-get install gcc-4.1" alle benötigten Pakete für den gcc-4.1 bekommen?

    Gruss,
    Mac
     
  5. #4 Goodspeed, 27.06.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Die hast Du eigentlich schon über das Paket "build-essential" ...
     
  6. #5 supersucker, 27.06.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Was sagt denn

    Code:
    gcc --version
    ?
     
  7. MacLux

    MacLux Eroberer

    Dabei seit:
    19.06.2006
    Beiträge:
    50
    Zustimmungen:
    0
    4.1 ...

    Aber das Configure des ersten Compile, den ich starten wollte, sagt: "compiler cannot create executables". Da fehlt doch was...

    Mac
     
  8. #7 supersucker, 27.06.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Code:
    apt-get install cpp
    Damit sollte das Problem erledigt sein.
     
  9. MacLux

    MacLux Eroberer

    Dabei seit:
    19.06.2006
    Beiträge:
    50
    Zustimmungen:
    0

    Sagt:

    "cpp ist schon die neueste Version."

    Gruss,
    Mac
     
  10. hengs

    hengs Tripel-As

    Dabei seit:
    21.02.2005
    Beiträge:
    217
    Zustimmungen:
    0
    Ort:
    Salzburg
    Probier mal folgendes

    Code:
    apt-get install make bin86
     
  11. MacLux

    MacLux Eroberer

    Dabei seit:
    19.06.2006
    Beiträge:
    50
    Zustimmungen:
    0
    Und die Fortsetzung:

    make und bin86 haben sich problemlos installieren lassen. Nur bei build-essential krieg ich noch:

    build-essential: Hängt ab: libc6-dev soll aber nicht installiert werden oder
    libc-dev
    Hängt ab: g++ (>= 3:3.3) soll aber nicht installiert werden

    Mach ich "apt-get install libc6-dev", krieg ich:

    Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
    libc6-dev: Hängt ab: libc6 (= 2.3.2.ds1-22) aber 2.3.6.ds1-13 soll installiert werden.

    Wenn ich ihm dann genau diese Version unterjuble:
    "apt-get install libc6=2.3.2.ds1-22"

    Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
    libxt-java: Hängt ab: kaffe oder
    java1-runtime oder
    java2-runtime


    Wat'n dat für'n Müll? Was hat denn jetzt java damit zu tun. Ich bin verwirrt.... Wie krieg ich diese dämlichen Ring-Abhängigkeiten weg?
    Wenn ich übrigens an der installierten libc6=2.3.6 rühre, listet er mir tausende Applikationen auf, die er jetzt gern de-installieren möchte, inkl. Gnome und anderen "unwichtigen" Sachen... :erschlag: ?(

    Hat jemand noch 'nen Tipp?

    Gruss,
    Mac
     
  12. #11 Goodspeed, 09.07.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Irgendwie sieht das nach riesengroßer Grütze aus ...

    Poste mal Deine sources.list ... denn entsprechend Deiner geposteten Versionen haste irgendeinene Sarge-Etch-irgendwas-Mix ...

    k.A. wo Du die Pakete her hast, die Du manuell per dpkg installieren willst, aber offensichtlich passen sie nicht zu dem Release, was Du nutzt ...
     
  13. #12 Wolfgang, 09.07.2007
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Wenn du mit Debian Sarge arbeitest, ist die libc6 nicht kompatibel mit gcc4.x!
    Sarge hat default gcc 3.xx mit entsprechender libc6.
    Du musst das vermutlich aus dem Backports holen. Weiß aber gerade nicht, ob es die dort gibt.

    Gruß Wolfgang
     
  14. MacLux

    MacLux Eroberer

    Dabei seit:
    19.06.2006
    Beiträge:
    50
    Zustimmungen:
    0
    Der Rechner wurde von unserem Händler per NetInstall betüdelt.
    Mit Etch lagst Du goldrichtig, wie ich gerade sehe

    deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main

    Paket-Update hat er nach eigenen Angaben von 'nem Uni-Server in Braunschweig gemacht. Den Eintrag hab ich aber nicht mehr drin stehen.

    Wir haben hier firmenintern einen eigenen Paketserver, den ich in die sources.list eingetragen habe.

    deb http://xxx.com/linux/debian stable main

    Genaue Adresse nützt Euch eh nix, da Intranet. Ich würde auch wieder einen anderen, externen Mirror nehmen, wenn ich beim Apt irgendwo 'nen Proxy eintragen könnte. Mit der Methode "export http_proxy=..." konnte er dann den externen Namen nicht auflösen.

    Krieg ich mit der Etch-Geschichte also keinen GCC4.1.2 zum Laufen? Wäre doof - genau den brauch ich. So langsam verliere ich die Übersicht. Ich komme hier vom Hundertsten in's Tausendste und stehe immer noch am Anfang beim Aufbau der Büchse. Mist! :hilfe:

    Gruss,
    Mac
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Goodspeed, 09.07.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Ein paar Sachen zur Klärung:
    Apt und Proxy:
    http://channel.debian.de/faq/ch-dpkgundco.html

    Sarge = oldstable (kein GCC 4.1)
    Etch = stable (GCC 4.1 default)

    Ich weiß ja nicht, was ihr auf eurem internen Server für Pakete hostet, aber nach Etch sieht das nicht aus.

    Mein Vorschlag:
    1. mit obigem Hinweis apt zum Laufen zu bringen
    2. Beispiele für sources.list Einträge: http://wiki.unixboard.de/index.php/Repositories_fuer_Debian_und_Derivate
    3. per dist-upgrade das System gerade ziehen
    4. Projekt "GCC 4.1" nochmal von vorn beginnen ..
     
  17. MacLux

    MacLux Eroberer

    Dabei seit:
    19.06.2006
    Beiträge:
    50
    Zustimmungen:
    0
    Yep, das war's. Auf dem Ding waren wohl nicht die passenden Pakete. Hab's mit einem externen Debian-Mirror hinbekommen. Danke!

    Gruss,
    Mac
     
Thema:

Paket defekt

Die Seite wird geladen...

Paket defekt - Ähnliche Themen

  1. Welche Paketquellen sind empfohlen? -CentOS 7.2.15.11

    Welche Paketquellen sind empfohlen? -CentOS 7.2.15.11: Hallo liebes Forum. Es scheint mir wie eine plumpe Anfängerfrage, jedoch habe ich zu dem Thema nichts sinnvolles gefunden. Ich habe CentOS...
  2. Netzwerkaufbau mit simulierten Paketen unter Linux

    Netzwerkaufbau mit simulierten Paketen unter Linux: Hallo, ich habe folgendes Problem. Da ich noch sehr unerfahren in Sachen Linux bzw. Netzwerkaufbau bin, wollte ich fragen, ob Ihr mir vllt etwas...
  3. Canonical schließt Lücke im Snap Paketformat

    Canonical schließt Lücke im Snap Paketformat: Snaps sind das neue Paketformat, das neben herkömmlichen DEB-Paketen in Ubuntu koexistieren kann. Jetzt wurde eine Sicherheitslücke geschlossen,...
  4. Snap als neues Paketformat in Ubuntu 16.04 LTS »Xenial Xerus«

    Snap als neues Paketformat in Ubuntu 16.04 LTS »Xenial Xerus«: Wenn Canonical in wenigen Tagen Ubuntu 16.04 veröffentlicht, wird mit Snap ein neues Paketformat an Bord sein, das mit dem herkömmlichen...
  5. Artikel: Pacman – Der Paketmanager von Arch Linux

    Artikel: Pacman – Der Paketmanager von Arch Linux: Einer der großen Vorzüge der Linux-Distribution Arch Linux ist ihr Paketmanager »Pacman« und seine Buildtools. Trotz der sehr umfangreichen und...