Optisches Lufwerk kein DMA

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Kulfadir, 10.04.2005.

  1. #1 Kulfadir, 10.04.2005
    Kulfadir

    Kulfadir Der tollste Typ hier.

    Dabei seit:
    27.10.2004
    Beiträge:
    329
    Zustimmungen:
    0
    Ort:
    Dortmund
    Ich hab das Problem das ich DMA nicht ktivieren kann.
    weder mit:
    Code:
    hdparm -d1 /dev/hdc
    noch mit dem direkten Eintrag in die hdparm.conf.

    Habe dann mal meinen Rechner unter Knoppix gebootet da funktionierts.
    Wenn ihr noch weitere Infos braucht sagt bescheid.

    Welche möglichkeit habe ich jetzt noch DMA zum laufen zu bekommen?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Welche Meldung bekommst du denn ?

    Vielleicht fehlt im Kernel der Support für deinen Controller ... ?
     
  4. #3 Kulfadir, 10.04.2005
    Kulfadir

    Kulfadir Der tollste Typ hier.

    Dabei seit:
    27.10.2004
    Beiträge:
    329
    Zustimmungen:
    0
    Ort:
    Dortmund
    Operation not permited

    (hoffe das hab ich richtig geschrieben)

    Mein Chipsatz ist der KT880
    Southbridge ist VT8273

    Wenn der Support fehlt, welches >Kernelmodul brauch ich dafür?
     
  5. #4 Goodspeed, 10.04.2005
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Gegenfrage: Welchen Kernel nutzt Du?
     
  6. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    VIA Chipsatz Support :)
     
  7. #6 Kulfadir, 10.04.2005
    Kulfadir

    Kulfadir Der tollste Typ hier.

    Dabei seit:
    27.10.2004
    Beiträge:
    329
    Zustimmungen:
    0
    Ort:
    Dortmund
    Ich nutze den Kernel 2.6.11

    lspci hat die Ausgabe:
    Code:
    0000:00:00.0 Host bridge: VIA Technologies, Inc.: Unknown device 0269 (rev 80)
    0000:00:00.1 Host bridge: VIA Technologies, Inc.: Unknown device 1269
    0000:00:00.2 Host bridge: VIA Technologies, Inc.: Unknown device 2269
    0000:00:00.3 Host bridge: VIA Technologies, Inc.: Unknown device 3269
    0000:00:00.4 Host bridge: VIA Technologies, Inc.: Unknown device 4269
    0000:00:00.7 Host bridge: VIA Technologies, Inc.: Unknown device 7269
    0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
    0000:00:09.0 Ethernet controller: Marvell Technology Group Ltd. Yukon Gigabit Ethernet 10/100/1000Base-T Adapter (rev 13)
    0000:00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
    0000:00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
    0000:00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
    0000:00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
    0000:00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
    0000:00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
    0000:00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
    0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [K8T800 South]0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
    0000:01:00.0 VGA compatible controller: nVidia Corporation NV28 [GeForce4 Ti 4200 AGP 8x] (rev a1)
    Ich schätze ja mal das es darum geht:
    Code:
    0000:00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
    Der Eintrag sieht genauso aus wie unter Knoppix und unter knoppix funktioniert DMA.

    Code:
    CONFIG_BLK_DEV_IDEDMA_PCI = y
    ist auch gesetzt.

    Trotzdem kommt bei:
    Code:
    hdparm -d1 /dev/hdc
    die Ausgabe:
    Code:
    /dev/hdc:
     setting using_dma to 1 (on)
     HDIO_SET_DMA failed: Operation not permitted
     using_dma    =  0 (off)
     
  8. #7 Kulfadir, 08.05.2005
    Kulfadir

    Kulfadir Der tollste Typ hier.

    Dabei seit:
    27.10.2004
    Beiträge:
    329
    Zustimmungen:
    0
    Ort:
    Dortmund
    so das Problem mit dem DMA ist gelöst. Hab in die initrd via_sata und viacxxx hinzugefügt. Nun habe ich aber ein neus Problem:
    Vom Laufwerk werden nun alle DVDs als leer angeezeigt. CDS betrifft dies nicht. Wenn ich aber per Handmounte gibt es keine Probleme.

    Woran könnte das liegen?
     
  9. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Eventl. hast du kein UDF-Dateisystem im Kernel vergessen ....

    EDIT : Oh wenns von Hand geht, poste mal deine /etc/fstab
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 Goodspeed, 08.05.2005
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Ich versteht nur Bahnhof ... zumindest, was den ersten Teil angeht.
    Kannst Du mal etwas genauer erklären, was Du wie machst?
     
  12. #10 Kulfadir, 08.05.2005
    Kulfadir

    Kulfadir Der tollste Typ hier.

    Dabei seit:
    27.10.2004
    Beiträge:
    329
    Zustimmungen:
    0
    Ort:
    Dortmund
    Kann ich machen also um DMA zu bekommen habe ich folgendes gemacht:
    /etc/modules
    Code:
    .....
    via82cxxx
    .....
    
    /etc/mkinitrd/modules
    Code:
    sata_via
    via82cxxx
    
    /etc/mkinitrd/mkinitrd.conf
    Code:
    MODULES=dep
    und dann
    Code:
    mkinitrd -o /boot/initrd.img..... "kernelversion"
    Danach lief DMA


    So nun habe ich :
    -hotplug
    -udev
    -pmount
    -hal

    installiert damit mein usb-stick automatisch gemeountet wird.

    Jetzt wird aber jede DVD die automatisch gemeountet wird nur als leere DVD angezeigt. Bei CDs zeigt er mir den inhalt an.
    Wenn ich per mount-Befehl von Hand mounte kann ich aber auf den Inhalt der DVD zugreifen. Bevor ich DMA aktiviert hatte ist dieses Problem nicht aufgetretten.

    Wenn ich nun hal deinstalliere wird mir die DVD zweimal angezeigt einmal als leere DVD einmal wird der richtige Inhalt angezeigt (unter gnome).

    Hoffe das hier erklärt etwas genauer mein Problem!
     
Thema:

Optisches Lufwerk kein DMA

Die Seite wird geladen...

Optisches Lufwerk kein DMA - Ähnliche Themen

  1. Ubuntu ohne optisches Laufwerk und USB Ubuntu installieren

    Ubuntu ohne optisches Laufwerk und USB Ubuntu installieren: Hi, ich bin gerade dabei für meinen Großvater das alte Notebook meiner Freundin vorzubereiten. Ich wollte das vorhandene Windows XP entfernen...
  2. optisches Laufwerk langsamer laufen lassen?

    optisches Laufwerk langsamer laufen lassen?: Hallo, leider wird mein optisches Laufwerk im Betrieb oftmals recht laut. Unter Windows gibts doch dafür die CD-Bremse, die eine max...
  3. Optisches Problem in Fensterliste

    Optisches Problem in Fensterliste: Guten Tag, Ich habe hier ein kleines Problemchen mit meinem brandneuen Gnome 2.4-Desktop. (hatte vorher eher leichtes wie XFCE oder FluxBOX)...
  4. Froum für Optisches?

    Froum für Optisches?: wie wärs mit ´nem Forum für optisches sprich Wallpapers oder icons bootsplashes etc. was so dazugehört ich denke bilder sollten nicht im...