nvidia-kernel mit 2.6.7'er Kernel

Dieses Thema im Forum "Gentoo" wurde erstellt von Havoc][, 28.06.2004.

  1. #1 Havoc][, 28.06.2004
    Havoc][

    Havoc][ Debian && Gentoo'ler

    Dabei seit:
    27.07.2003
    Beiträge:
    898
    Zustimmungen:
    0
    Ort:
    GER/BaWü/Karlsruhe (bzw. GER/NRW/Siegen)
    Hi Leute,

    gerade haben Blueflower und ich im chan das Problem gehabt, das wir zwar unseren neuen 2.6er Kernel am laufen haben, aber unsere doofe NVIDIA Grafikkarte nicht funktioniert.

    Beim laden des Moduls per: "modprobe nvidia" bekamen wir folgenden fehler:
    FATAL: Error inserting nvidia (/lib/modules/2.6.7-love2/video/nvidia.ko): Invalid module format

    Folgendes haben dann Blueflower und ich, danke Hinne und Flightbase, herrausbekommen:

    Zuersteinmal muss im kernel die option 4K-Stack abgeschaltet sein.
    Ob Ihr diese Option aktiviert habt könnt ihr über
    Code:
    alpha:~# [b]cat /usr/src/linux/.config | grep "CONFIG_4KSTACKS"[/b]
    # CONFIG_4KSTACKS is not set
    alpha:~#
    
    herrausfinden.
    Ist die Ausgabe bei euch die selbe wie die meine, ist alles in Ordnung. Sollte da aber sowas wie "CONFIG_4KSTACKS=Y" stehen, solltet ihr den Kernel dahingehende bearbeiten und diese Option ausschalten. (Übrigens zu finden unter "Kernel Hacking")

    Nachdem ihr den Kernel wie "üblich" über "make && make modules_install" gebacken habt, ihn installiert und den Neustart hinter euch gebracht habt, müsst ihr nur noch die neuen nvidia kernel driver "emergen".

    Über ein:
    Code:
    alpha:~# ACCEPT_KEYWORDS="~x86" emerge -p nvidia-kernel
    
    Solltet ihr euch versichern das es sich um die versions nummer (höher?) 1.0.5336-r4 handelt (sie darf nicht tiefer sein - evtl sowas wie 1.0.4496-r3).

    Danach, den oben genannten Befehl, noch einmal ohne "-p" und schon könnt ihr nach dem emerg-prozess den neuen Driver über "modprbe nvidia" laden.

    Ich hoffe ich konnte einigen weiterhelfen. Mir dient es zumindest einmal als Gedächntis stütze. Vielen dank nochmal an Hinne, Devilz und Flightbase.

    Havoc][ out...
     
  2. Anzeige

    Schau dir mal diesen Ratgeber an. Viele Antworten inkl. passender Shell-Befehle!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. DaMutz

    DaMutz Doppel-As

    Dabei seit:
    18.10.2003
    Beiträge:
    149
    Zustimmungen:
    0
    Ort:
    Giebenach / Schweiz
    ich hatte das gleiche problem mit dem nvidia-kernel, das mit dem aktuellem ebuild habe ich dann selber herausgefunden. Jetzt funktioniert zum Glück alles wieder.
     
  4. #3 spychodelics, 02.07.2004
    spychodelics

    spychodelics Grünschnabel

    Dabei seit:
    01.07.2004
    Beiträge:
    2
    Zustimmungen:
    0
    Hatte das gleiche Problem , nun steh ich vor dem Problem
    das ich keine 3d Beschleunigung habe.

    Nvidia Modul ist geladen , Logo wird beim Start gezeigt , GLX wird in der config geladen , aber in glxgears komm ich nicht ueber 650 fps
     
  5. Phate

    Phate Frickler/Kellerkommunist

    Dabei seit:
    08.02.2004
    Beiträge:
    261
    Zustimmungen:
    0
    Ort:
    Rheinland
    @spychodelics:

    nvidia-glx auch neu emerged nach der Kernelkompilierung bzw. überhaupt je installiert?
     
Thema:

nvidia-kernel mit 2.6.7'er Kernel

Die Seite wird geladen...

nvidia-kernel mit 2.6.7'er Kernel - Ähnliche Themen

  1. nvidia-kernel-173.14.09

    nvidia-kernel-173.14.09: Nachdem ich wie hier beschrieben den Befehl apt-get install nvidia-glx nvidia-glx-dev xserver-xorgausführe (hab ja leider Debian lenny),...