Nach Kernelupdate Sound leise

Dieses Thema im Forum "Arch Linux" wurde erstellt von Mitzekotze, 12.07.2007.

  1. #1 Mitzekotze, 12.07.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Servus zusammen,

    nach dem Update des Kernels auf Version 2.6.21 ist bei mir auf einmal der Ton sehr leise. Um ein wenig zu hören muss ich den Lautstärkenregler ganz aufdrehen. Im Alsamixer hab ich den Ton auch schon bis zum Anschlag aufgedreht, aber es hat sich nichts verbessert.

    Weiß einer von euch eine Lösung für das Problem?
    Woher nimmt das Programm "alsamixer" eigentlich seine Daten bzw. kann man diese Auch manuell verändern?
     
  2. Anzeige

    Schau dir mal diesen Ratgeber an. Viele Antworten inkl. passender Shell-Befehle!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Was hast du denn aufgedreht? Nur Master? Meist kann auch PCM zimelich leise sein, wo dann auch Master nix mehr reisst.
     
  4. MrBoe

    MrBoe Routinier

    Dabei seit:
    13.06.2006
    Beiträge:
    399
    Zustimmungen:
    0
    Ort:
    braunschweig/nds/de/world
    Mich würde auch mal interessieren, ob man die alsamixer Daten irgendwo fest einstellen kann. Bei meiner Soundkarte stellt sich immer der optische Ausgang ab wenn kdm gestartet wird. Das nervt.
    Gestern hab ichs ausprobiert, kann gar nicht nachvollziehen warum das so ist:
    Mit dem alsamixer optisch eingeschaltet.
    Dann hab ich den XServer neu gestartet und die Einstellung war wieder weg.

    Wieso passiert das?
     
  5. Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Code:
    alsactl store
    müsste das eigentlich tun.
     
  6. MrBoe

    MrBoe Routinier

    Dabei seit:
    13.06.2006
    Beiträge:
    399
    Zustimmungen:
    0
    Ort:
    braunschweig/nds/de/world
    Cool, danke! Das probier ich nachher mal aus.
     
  7. #6 Mitzekotze, 12.07.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    PCM ist voll aufgedreht. Aber was meinst du mit Master? Im Alsamixer kann man bloß Master aktiviert, die Lautstärke kann man dort aber nicht regeln. Mein Sound System scheint jetzt aber auch völlig Amok zu laufen, den mittlerweile hab ich gar kein Sound. Kann es sein das nach dem Kernelupdate plötzlich irgendwelche Sound Module fehlen, bzw. nicht mehr richtig zugeordnet werden können?
     
  8. MrBoe

    MrBoe Routinier

    Dabei seit:
    13.06.2006
    Beiträge:
    399
    Zustimmungen:
    0
    Ort:
    braunschweig/nds/de/world
    Natürlich kann das sein! Vielleicht hat sich aber auch was an alsa geändert, das ist ja auch im Kernel. Was hast du denn für eine Karte?

    Vielleicht musst du auch nur noch einmal "alsaconf" aufrufen....
     
  9. Zico

    Zico Lebende Foren Legende

    Dabei seit:
    16.04.2004
    Beiträge:
    1.559
    Zustimmungen:
    0
    Wenn du die alte KErnel config richtig geclont hast sollte das eigentlich kein Problem sein.
    Ich mach das immer per
    Code:
    cd /usr/src/linux
    zcat /proc/config.gz > .config
    make oldconfig
    
     
  10. #9 Mitzekotze, 12.07.2007
    Zuletzt bearbeitet: 13.07.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Ich hab die alte Kernel Config nicht kopiert *schäm* und im /usr/src finde ich auch nur den Ordner des aktuellen Kernels.
    Durch den Aufruf von "alsaconfig" hat sich auch nicht mehr viel geändert, aber es war immerhin ein Versuch wert.
    Mittlerweile funktioniert mein Sound übrigens wieder, wenn auch so leise wie zuvor.
    Ist es vielleicht möglich die Lautstärke irgendwo manuell zu ändern, also nicht über ein Programm wie Alsamixer?

    btw ich habe eine Intel Corporation 82801G (ICH7 Family) High Definition Audio Soundkarte.
     
  11. #10 Mitzekotze, 13.07.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Mhhh ich sollte vielleicht noch erwähnen das ich das Update per pacman gemacht habe.
     
  12. #11 Mitzekotze, 14.07.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Ich habe jetzt das System nochmal komplett neu aufgesetzt mit dem selben Ergebnis. Anscheinend hab ich einen Bug gefunden oder lässt sich das ganze noch anders erklären?
     
  13. defcon

    defcon Kaiser
    Moderator

    Dabei seit:
    22.08.2005
    Beiträge:
    1.482
    Zustimmungen:
    1
    Ort:
    Bruchsal
    Tu doch mal just4fun den Kernel 2.6.22 aus testing installieren.
    BTW.. welche WM nutzt du? Was für ne Soundcard?
     
  14. #13 Mitzekotze, 16.07.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Habs mal ausprobiert das Ergebnis war leider das selbe. Anscheinend hängt der Fehler mit dem letzten Alsapatch zusammen. Nun ja da hilft wohl nichts weiter als abwarten und Tee trinken. Ich werde aber vorsichtshalber nochmal andere Distris mit dem aktuellen Kernel testen, um ganz sicher zu sein.

    Mein WM war Fluxbox und ich hab eine "Intel Corporation 82801G (ICH7 Family) High Definition Audio" Soundkarte. Eigentlich wundert es mich dass der Sound mit dieser Karte nicht geht. Immerhin ist sie ja von Intel und diese werden bekanntermaßen ja immer gut unterstützt.
     
  15. #14 Mitzekotze, 22.07.2007
    Mitzekotze

    Mitzekotze little man

    Dabei seit:
    01.12.2006
    Beiträge:
    750
    Zustimmungen:
    0
    Das Problem hat sich erledigt. Der Fehler lag am Einbinden eines falschen Moduls. Genaueres findet man hier: *klick*
     
Thema:

Nach Kernelupdate Sound leise

Die Seite wird geladen...

Nach Kernelupdate Sound leise - Ähnliche Themen

  1. Wlanproblem nach Kernelupdate

    Wlanproblem nach Kernelupdate: Nach Kernelupdate 2.6.26-1-686 ist das wlan weg. Also wollte ich wie immer nach folgender Anleitung mein Wlan neu instalieren (RT2500) Hier nun...
  2. WG511T funktioniert nach Kernelupdate nicht mehr

    WG511T funktioniert nach Kernelupdate nicht mehr: Hallo, meine WG511T PCMCIA Karte funktioniert nach einem Kernelupdate unter SuSe 10.3 nicht mehr. Woran kann das liegen? Lg Duester Kernel ist...
  3. Eine Multimediataste funktioniert nach Kernelupdate nicht mehr

    Eine Multimediataste funktioniert nach Kernelupdate nicht mehr: Hallo zusammen, ich habe auf meinem Laptop (Fujitsu-Siemens Amilo M7400) Debian Lenny installiert. Nun habe ich in der letzten Woche auf den...
  4. Nach Kernelupdate, Grub zerschossen

    Nach Kernelupdate, Grub zerschossen: Jedes mal wenn Debian einen Kernel- oder Kernelheaderupdate anbietet und ich diesen ausführe zerschießt es mir den Grub. Will heißen in der...
  5. GRUB zeigt mir nach Kernelupdate + Systemreparatur kein WinXP mehr :(

    GRUB zeigt mir nach Kernelupdate + Systemreparatur kein WinXP mehr :(: Hey! Hab fleißig hier aufm Forum gesucht, aber nichts, was mein Problem direkt beschreibt :( Also ich (openSuSE 10.2) habe auf...