lokales mailen funktioniert nicht

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von tzzaetaynzz, 07.02.2006.

  1. #1 tzzaetaynzz, 07.02.2006
    tzzaetaynzz

    tzzaetaynzz Tripel-As

    Dabei seit:
    31.01.2004
    Beiträge:
    153
    Zustimmungen:
    0
    hallo an alle,

    lokal zu mailen bekomme ich nicht hin.
    leider verstehe ich meine eigene konfiguration nicht mehr. :think:

    was ich versuche, gerne moechte ich wieder von root alle mails an admin senden.

    Code:
    [root@emma ~]# cat /etc/postfix/aliases
    # Person who should get root's mail.  This alias
    # must exist.
    # CHANGE THIS LINE to an account of a HUMAN
    root:		admin
    
    Code:
    postalias hash:/etc/postfix/aliases
    Code:
    [admin@emma ~]$ mail root
    Subject: test
    dies' ist der test
    .
    Cc: 
    
    Weder bei root noch bei admin kommen mails an.
    auch in der mailq und postqueue ist nichts zu sehen.

    nur das maillog scheint eine hilfe zu sein.
    Code:
    [root@emma ~]# tail -n 50 /var/log/maillog | less
    Feb  7 15:56:13 emma postfix/cleanup[7614]: BF96744138: message-id=<20060207145613.BF96744138@emma>
    Feb  7 15:56:13 emma postfix/qmgr[7486]: BF96744138: from=<>, size=2150, nrcpt=1 (queue active)
    Feb  7 15:56:13 emma postfix/qmgr[7486]: 9CB4444136: removed
    Feb  7 15:56:13 emma postfix/smtp[7494]: BF96744138: to=<admin@emma.emma>, relay=none, delay=0, status=bounced ([emma.emma]: Name or service not known)
    
    postfix und /etc/hosts ist aber der name emma bekannt
    Code:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1	emma localhost 
    192.168.178.1	fritzbox
    Code:
    [root@emma ~]# postconf -n
    alias_database = hash:/etc/postfix/aliases
    alias_maps = hash:/etc/postfix/aliases
    command_directory = /usr/sbin
    config_directory = /etc/postfix
    daemon_directory = /usr/libexec/postfix
    debug_peer_level = 2
    html_directory = no
    inet_interfaces = localhost
    mail_owner = postfix
    mail_spool_directory = /var/spool/mail
    mailq_path = /usr/bin/mailq.postfix
    manpage_directory = /usr/share/man
    mydestination = $myhostname, localhost.$mydomain, $mydomain
    myhostname = emma
    mynetworks = 127.0.0.0/8
    myorigin = $myhostname
    newaliases_path = /usr/bin/newaliases.postfix
    queue_directory = /var/spool/postfix
    readme_directory = /usr/share/doc/postfix-2.1.5/README_FILES
    relay_domains = $mydestination
    sample_directory = /usr/share/doc/postfix-2.1.5/samples
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    smtp_sasl_security_options = noplaintext, noanonymous
    unknown_local_recipient_reject_code = 450
    und nun bin ich mit meinem latein am ende.
    habt ihr eine idee?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Dies bedeutet, dass Du an einen Rechner namens emma mit dem Domainnamen emma schreibst. Ich konnte aus keiner Deiner Konfigurationsdateien entnehmen, dass Dein Rechner den Domainnamen emma hat. Schreibe entweder an admin@emma oder aendere Deinen localhost Eintrag in /etc/hosts:
    127.0.0.1 emma.emma localhost, emma

    Ich weiss nicht, ob man postfix auch noch so etwas wie $mydomainname bekanntgeben muss.
     
  4. #3 tzzaetaynzz, 07.02.2006
    tzzaetaynzz

    tzzaetaynzz Tripel-As

    Dabei seit:
    31.01.2004
    Beiträge:
    153
    Zustimmungen:
    0
    danke fuer den tip!
    in der tat, ich habe die /etc/hosts so geaendert, wie du es oben geschrieben hast, und auf anhieb konnte ich emails von root nach admin versenden.

    Code:
    [root@emma ~]$ mail admin
    Subject: test mit geaenderter /etc/hosts
    dies' ist der test2
    .
    Cc: 
    sogar die ersten systemmails ueber crond kommen rein!

    da ich aber keine domain emma besitze, habe ich die /etc/hosts und die /etc/postfix/main.cf wie folgt angepasst.

    Code:
    [root@emma ~]# cat /etc/hosts
    127.0.0.1	localhost, emma
    Code:
    # INTERNET HOST AND DOMAIN NAMES
    # 
    # The myhostname parameter specifies the internet hostname of this
    # mail system. The default is to use the fully-qualified domain name
    # from gethostname(). $myhostname is used as a default value for many
    # other configuration parameters.
    #
    myhostname = emma.localhost
    macht das mehr sinn?
    und, was bedeutet das komma in der /etc/hosts (habe ich noch nie gesehen)?
     
  5. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Das Komma in der hosts-Datei ist ein Fehler meinerseits, tatsaechlich sind die Felder durch Leerzeichen/tabs getrennt.

    Wenn Du nur einen hostnamen aber keinen Domaenennamen hast, gibt doch einfach
    myhostname = emma
    ein, oder funktioniert das nicht? Soweit ich weiss, trennt der erste Punkt (von links) host von Domaene, von daher haettest Du bei Deiner Version die Domaene localhost, was nicht ist, was Du willst. Es sei denn, Du traegst ein Deine /etc/hosts ein:
    127.0.0.1 emma.localhost emma localhost
    Aber ich weiss nicht, ob das nicht Verwirrung stiften kann.
     
  6. #5 tzzaetaynzz, 07.02.2006
    tzzaetaynzz

    tzzaetaynzz Tripel-As

    Dabei seit:
    31.01.2004
    Beiträge:
    153
    Zustimmungen:
    0
    @rikola

    wenn ich in der /etc/fstab stehen habe
    Code:
    127.0.0.1	localhost emma
    und in der /etc/postfix/main.cf
    Code:
    myhostname = emma
    dann geht wieder nichts
    Code:
    Feb  7 22:17:30 emma postfix/smtp[12595]: 8971344136: to=<admin@emma.emma>, orig_to=<admin>, relay=none, delay=1, status=bounced ([emma.emma]: Name or service not known)
    aber so funktioniert es:
    Code:
    [root@emma ~]# cat /etc/hosts
    127.0.0.1	localhost emma.localhost emma
    Code:
    [root@emma ~]# grep myhostname /etc/postfix/main.cf
    myhostname = emma.localhost
    Code:
    [root@emma ~]# tail -n 50 /var/log/maillog | less
    [..]
    Feb  7 22:22:12 emma spamd[4718]: connection from localhost [127.0.0.1] at port 43426 
    Feb  7 22:22:12 emma spamd[4718]: checking message <20060207212139.9B22F44136@emma.localhost> for admin:500. 
    Feb  7 22:22:12 emma spamd[4718]: clean message (-2.4/5.0) for admin:500 in 0.2 seconds, 440 bytes. 
    Feb  7 22:22:12 emma spamd[4718]: result: . -2 - ALL_TRUSTED,AWL,BLANK_LINES_80_90 scantime=0.2,size=440,mid=<20060207212139.9B22F44136@emma.localhost>,autolearn=ham 
    ich werde bei der letzten konfiguration bleiben.
    an dich nochmals, vielen dank.
     
Thema:

lokales mailen funktioniert nicht

Die Seite wird geladen...

lokales mailen funktioniert nicht - Ähnliche Themen

  1. Debian 7.6 kein lokales Netz

    Debian 7.6 kein lokales Netz: [solved] Debian 7.6 kein lokales Netz Hallo zusammen! Schon lange kein solches Problem gehabt. Ich bekommen einfach keinen Zugriff auf das...
  2. Lokales Netzwerk einrichten... Anleitung ohne 3 Kapitel bla blub?

    Lokales Netzwerk einrichten... Anleitung ohne 3 Kapitel bla blub?: Also iwie Verzweifle ich gerade, das Windows Netzwerk wird angezeigt aber einhängen geht nicht. ich habs schon mit den iptables und der smb.conf...
  3. Lokales Monitoring

    Lokales Monitoring: Ich suche für meinen Homeserver ein lokales Monitoring mit Mail Notification. Sprich ich will an sich nur Temp, Last, Raid und evtl. den ein oder...
  4. lokales Netzwerk: wie nadeloehr finden?

    lokales Netzwerk: wie nadeloehr finden?: Hallo, wir haben ein kleines lokales Linux-Netzwerk mit NFS und NIS-Authentifizierung. Zur Zeit starten v.a. KDE-Programme nicht mehr von...
  5. Bind DNS für lokales Netz einrichten

    Bind DNS für lokales Netz einrichten: Hallo, möchte einen Bind9 Server einrichten um die Namen der Clientcomputer im Netzwerk aufzulösen. Nun is meine Frage in der Zonefile muss man...