Linux bootet nicht mehr/grub verunstaltet

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von valenterry, 22.11.2006.

  1. #1 valenterry, 22.11.2006
    valenterry

    valenterry Mitglied

    Dabei seit:
    04.10.2006
    Beiträge:
    29
    Zustimmungen:
    0
    Hallo.

    Erstmal zum System: Eine Festplatte, drei Partitionen (eine für Windows, eine für Linux, eine swap)
    Ich nutze Kubuntu 6.06.
    Nachdem ich Windows neu installiert habe, hat es mir meinen MBR überschrieben. (Das war mir klar)
    Also hab ich alle HIER aufgeführten Anleitungen ausprobiert um meinen grub-loader wiederherzustellen.
    Nachdem ich die erste ausprobiert hatte (grub neu installiert) und rebootete war es geschehen.
    grub startete zwar wie gewöhnlich, aber ich konnte kein Betriebssystem mehr auswählen.
    Also auch noch die restlichen Anleitungen ausprobiert, aber da gab es nur Fehlermeldungen.
    Wenn ich alles genau wie in der letzten Anleitung mache, bekomme ich beim Befehl "grub-install --root-directory=/mnt /dev/hda" folgendes:
    Code:
    root@ubuntu:/boot/grub# grub-install --root-directory=/mnt /dev/hda
    /dev/hda4: Not found or not a block device.
    root@ubuntu:/boot/grub#
    
    Wenn ich versuche grub zu updaten, bekomme ich Folgendes:
    Code:
    root@ubuntu:/# update-grub
    Searching for GRUB installation directory ... found: /boot/grub
    Testing for an existing GRUB menu.list file ... found: /boot/grub/menu.lst
    Searching for splash image ... none found, skipping ...
    Updating /boot/grub/menu.lst ... done
    
    Und Folgendes bekomme ich durch "fdisk -l"
    Code:
    root@ubuntu:/# fdisk -l
    
    Disk /dev/hda: 80.0 GB, 80026361856 bytes
    255 heads, 63 sectors/track, 9729 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/hda1               1        6699    53809686    7  HPFS/NTFS
    /dev/hda2            6700        6808      875542+  82  Linux swap / Solaris
    /dev/hda3   *        6809        9729    23462932+  83  Linux
    
    Als letztes noch die "menu.lst"
    Code:
    # menu.lst - See: grub(8), info grub, update-grub(8)
    #            grub-install(8), grub-floppy(8),
    #            grub-md5-crypt, /usr/share/doc/grub
    #            and /usr/share/doc/grub-doc/.
    
    ## default num
    # Set the default entry to the entry number NUM. Numbering starts from 0, and
    # the entry number 0 is the default if the command is not used.
    #
    # You can specify 'saved' instead of a number. In this case, the default entry
    # is the entry saved with the command 'savedefault'.
    # WARNING: If you are using dmraid do not change this entry to 'saved' or your
    # array will desync and will not let you boot your system.
    default		0
    
    ## timeout sec
    # Set a timeout, in SEC seconds, before automatically booting the default entry
    # (normally the first entry defined).
    timeout		3
    
    ## hiddenmenu
    # Hides the menu by default (press ESC to see the menu)
    hiddenmenu
    
    # Pretty colours
    #color cyan/blue white/blue
    
    ## password ['--md5'] passwd
    # If used in the first section of a menu file, disable all interactive editing
    # control (menu entry editor and command-line)  and entries protected by the
    # command 'lock'
    # e.g. password topsecret
    #      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
    # password topsecret
    
    #
    # examples
    #
    # title		Windows 95/98/NT/2000
    # root		(hd0,0)
    # makeactive
    # chainloader	+1
    #
    # title		Linux
    # root		(hd0,1)
    # kernel	/vmlinuz root=/dev/hda2 ro
    #
    
    #
    # Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST
    
    ### BEGIN AUTOMAGIC KERNELS LIST
    ## lines between the AUTOMAGIC KERNELS LIST markers will be modified
    ## by the debian update-grub script except for the default options below
    
    ## DO NOT UNCOMMENT THEM, Just edit them to your needs
    
    ## ## Start Default Options ##
    ## default kernel options
    ## default kernel options for automagic boot options
    ## If you want special options for specific kernels use kopt_x_y_z
    ## where x.y.z is kernel version. Minor versions can be omitted.
    ## e.g. kopt=root=/dev/hda1 ro
    ##      kopt_2_6_8=root=/dev/hdc1 ro
    ##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
    # kopt=root=/dev/hda4 ro
    
    ## default grub root device
    ## e.g. groot=(hd0,0)
    # groot=(hd0,1)
    
    ## should update-grub create alternative automagic boot options
    ## e.g. alternative=true
    ##      alternative=false
    # alternative=true
    
    ## should update-grub lock alternative automagic boot options
    ## e.g. lockalternative=true
    ##      lockalternative=false
    # lockalternative=false
    
    ## additional options to use with the default boot option, but not with the
    ## alternatives
    ## e.g. defoptions=vga=791 resume=/dev/hda5
    # defoptions=quiet splash
    
    ## altoption boot targets option
    ## multiple altoptions lines are allowed
    ## e.g. altoptions=(extra menu suffix) extra boot options
    ##      altoptions=(recovery mode) single
    # altoptions=(recovery mode) single
    
    ## controls how many kernels should be put into the menu.lst
    ## only counts the first occurence of a kernel, not the
    ## alternative kernel options
    ## e.g. howmany=all
    ##      howmany=7
    # howmany=all
    
    ## should update-grub create memtest86 boot option
    ## e.g. memtest86=true
    ##      memtest86=false
    # memtest86=true
    
    ## should update-grub adjust the value of the default booted system
    ## can be true or false
    # updatedefaultentry=false
    
    ## ## End Default Options ##
    
    ### END DEBIAN AUTOMAGIC KERNELS LIST
    

    Ich hoffe das war erstmal richtig so.
    :hilfe2:

    Bitte helft mir. So ein Entzug ist nicht schön. ;(
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. brahma

    brahma Netzpirat

    Dabei seit:
    06.12.2005
    Beiträge:
    709
    Zustimmungen:
    0
    Ort:
    Münsterland

    Hast du vorher mit
    Code:
    mount /dev/hda3 /mnt
    deine Linux-Partition eingebunden?
     
  4. hwj

    hwj Doppel-As

    Dabei seit:
    23.06.2006
    Beiträge:
    131
    Zustimmungen:
    0
    Ort:
    Bei Buxtehude
    Reicht es nicht, in menu.lst die Zeile

    # kopt=root=/dev/hda4 ro

    in

    # kopt=root=/dev/hda3 ro

    zu ändern ?

    Heiko
     
  5. #4 Goodspeed, 23.11.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Also nach Deinem verlinkten HowTo hast Du es scheinbar _nicht_ gemacht, denn da steht was anderes, als Du hier getippt hast.

    Dessweiteren solltest Du die menu.lst überarbeiten. Wie hwj schon schreib, ist das root-Device falsch und auch der Eintrag bei groot stimmt mit sicherheit nicht (was hätte GRUB auch n Deiner SWAP-Partition zu suchen ...)

    Wenn Du das korrigiert hast und Dich entsprechend dem HowTo in der chroot befindes, sollte auch grub-install und update-grub Deinen Kernel-Eintrag wieder herzaubern.
    Den Eintrag für Windows musste eventuell selber eintragen ... aber dafür gibt es hier im Forum ja genug Beispiele, wie das auszusehen hat.
     
  6. #5 valenterry, 23.11.2006
    valenterry

    valenterry Mitglied

    Dabei seit:
    04.10.2006
    Beiträge:
    29
    Zustimmungen:
    0
    Mahlzeit,
    ich mach nochmal alles in Reihenfolge.
    Zuerst die "menu.lst" ändern. Sie sieht nun so aus:
    Code:
    # menu.lst - See: grub(8), info grub, update-grub(8)
    #            grub-install(8), grub-floppy(8),
    #            grub-md5-crypt, /usr/share/doc/grub
    #            and /usr/share/doc/grub-doc/.
    
    ## default num
    # Set the default entry to the entry number NUM. Numbering starts from 0, and
    # the entry number 0 is the default if the command is not used.
    #
    # You can specify 'saved' instead of a number. In this case, the default entry
    # is the entry saved with the command 'savedefault'.
    # WARNING: If you are using dmraid do not change this entry to 'saved' or your
    # array will desync and will not let you boot your system.
    default		0
    
    ## timeout sec
    # Set a timeout, in SEC seconds, before automatically booting the default entry
    # (normally the first entry defined).
    timeout		3
    
    ## hiddenmenu
    # Hides the menu by default (press ESC to see the menu)
    hiddenmenu
    
    # Pretty colours
    #color cyan/blue white/blue
    
    ## password ['--md5'] passwd
    # If used in the first section of a menu file, disable all interactive editing
    # control (menu entry editor and command-line)  and entries protected by the
    # command 'lock'
    # e.g. password topsecret
    #      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
    # password topsecret
    
    #
    # examples
    #
    # title		Windows 95/98/NT/2000
    # root		(hd0,0)
    # makeactive
    # chainloader	+1
    #
    # title		Linux
    # root		(hd0,1)                             
    # kernel	/vmlinuz root=/dev/hda2 ro
    #
    
    #
    # Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST
    
    ### BEGIN AUTOMAGIC KERNELS LIST
    ## lines between the AUTOMAGIC KERNELS LIST markers will be modified
    ## by the debian update-grub script except for the default options below
    
    ## DO NOT UNCOMMENT THEM, Just edit them to your needs
    
    ## ## Start Default Options ##
    ## default kernel options
    ## default kernel options for automagic boot options
    ## If you want special options for specific kernels use kopt_x_y_z
    ## where x.y.z is kernel version. Minor versions can be omitted.
    ## e.g. kopt=root=/dev/hda1 ro
    ##      kopt_2_6_8=root=/dev/hdc1 ro
    ##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
    # kopt=root=/dev/hda3 ro
    
    ## default grub root device
    ## e.g. groot=(hd0,0)
    # groot=(hd0,2)
    
    ## should update-grub create alternative automagic boot options
    ## e.g. alternative=true
    ##      alternative=false
    # alternative=true
    
    ## should update-grub lock alternative automagic boot options
    ## e.g. lockalternative=true
    ##      lockalternative=false
    # lockalternative=false
    
    ## additional options to use with the default boot option, but not with the
    ## alternatives
    ## e.g. defoptions=vga=791 resume=/dev/hda5
    # defoptions=quiet splash
    
    ## altoption boot targets option
    ## multiple altoptions lines are allowed
    ## e.g. altoptions=(extra menu suffix) extra boot options
    ##      altoptions=(recovery mode) single
    # altoptions=(recovery mode) single
    
    ## controls how many kernels should be put into the menu.lst
    ## only counts the first occurence of a kernel, not the
    ## alternative kernel options
    ## e.g. howmany=all
    ##      howmany=7
    # howmany=all
    
    ## should update-grub create memtest86 boot option
    ## e.g. memtest86=true
    ##      memtest86=false
    # memtest86=true
    
    ## should update-grub adjust the value of the default booted system
    ## can be true or false
    # updatedefaultentry=false
    
    ## ## End Default Options ##
    
    ### END DEBIAN AUTOMAGIC KERNELS LIST
    
    Dann folgendes in die Shell eingeben:
    Code:
    To run a command as administrator (user "root"), use "sudo <command>".
    See "man sudo_root" for details.
    
    ubuntu@ubuntu:~$ sudo mkdir /mnt/ubuntu
    ubuntu@ubuntu:~$ sudo mount /dev/hda3 /mnt/ubuntu
    ubuntu@ubuntu:~$ sudo mount -o bind /dev /mnt/ubuntu/dev
    ubuntu@ubuntu:~$ sudo chroot /mnt/ubuntu
    
    Dann bin ich "root@ubuntu:/#"
    Wenn ich nun "grub-install /dev/hda" eingebe gibt er etwas aus und wechselt sofort zu grub.
    "grub[spitze klammer]"
    Nun ist es genauso, als wenn ich den PC starte.
    Es gibt nichts zur Auswahl und ich kann mit TAB eine Auswahl an Befehlen ansehen, mehr nicht.
    Bei einem "boot (hd0,2)" sagt er mir, dass zuerst der kernel geladen werden muss.
    Das passiert, wenn ich ihn updaten möchte.
    Code:
    root@ubuntu:/# update-grub
    Searching for GRUB installation directory ... found: /boot/grub
    Testing for an existing GRUB menu.list file ... found: /boot/grub/menu.lst
    Searching for splash image ... none found, skipping ...
    Updating /boot/grub/menu.lst ... done
    
    War soweit alles richtig?
     
  7. #6 Goodspeed, 23.11.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Das ist die Grub-Shell ... aber was er da "ausgibt" wäre vielleicht interessant ...
     
  8. #7 valenterry, 23.11.2006
    valenterry

    valenterry Mitglied

    Dabei seit:
    04.10.2006
    Beiträge:
    29
    Zustimmungen:
    0
    Hallo.

    Leider kann ich "grub-install /dev/hda" nicht mehr ausführen.
    Code:
    To run a command as administrator (user "root"), use "sudo <command>".
    See "man sudo_root" for details.
    
    ubuntu@ubuntu:~$ sudo mkdir /mnt/ubuntu
    ubuntu@ubuntu:~$ sudo mount /dev/hda3 /mnt/ubuntu
    ubuntu@ubuntu:~$ sudo mount -o bind /dev /mnt/ubuntu/dev
    ubuntu@ubuntu:~$ sudo chroot /mnt/ubuntu
    root@ubuntu:/# grub-install /dev/hda
    /dev/hda4: Not found or not a block device.
    root@ubuntu:/# grub-install /dev/hda3
    /dev/hda4: Not found or not a block device.
    root@ubuntu:/#
    
    Ich habe aber genau das gleiche gemacht wie vorher und da ging es.
    (Hab es auch nach einem Neustart noch einmal probiert.)
    Die grub-shell sah in etwa so wie bei einem normalen Start aus:
    Code:
    GNU GRUB version 0.97 (637 lower/782272 upper memory)
    [Minimal BASH-like line editing is supported. For
    the first wird, TAB lists possible command
    completions. Anywhere else TAB lists the possible
    completions of a device/filenam.]
    
    grub>
    
    Ich bin mir aber nicht ganz sicher, ob es genau die gleiche Ausgabe war.
    Falls du das meintest, was ausgegeben wird, bevor die grub-shell erscheint, dann sag mir bitte, wie ich es verhindern kann, dass es gleich wieder verschwindet.
     
  9. #8 Goodspeed, 23.11.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Wie kommt der denn auf /dev/hda4???
    Schau bitte nochmal in die menu.lst und die device.map ...
     
  10. #9 kbdcalls, 23.11.2006
    kbdcalls

    kbdcalls Master of Universe

    Dabei seit:
    16.10.2006
    Beiträge:
    518
    Zustimmungen:
    0
    Was wollt ihr alle mit /dev/hda4 ?
    Code:
    Disk /dev/hda: 80.0 GB, 80026361856 bytes
    255 heads, 63 sectors/track, 9729 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/hda1               1        6699    53809686    7  HPFS/NTFS
    /dev/hda2            6700        6808      875542+  82  Linux swap / Solaris
    /dev/hda3   *        6809        9729    23462932+  83  Linux
    _
    _
    
    Linux ist demnach auf /dev/hda3
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. #10 Goodspeed, 23.11.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Wer lesen kann ist klar im Vorteil ... das gibt doch Grub "beschwerdemäßig" aus
    Code:
    root@ubuntu:/# grub-install /dev/hda
    [B]/dev/hda4[/B]: Not found or not a block device.
    
    Und ich glaub nicht, dass sowas vom Himmel fällt ...
    Und wenn man herausfindent, woher er das zieht, findet man womöglich auch heraus, warum die Install in die Hose geht ...
     
  13. #11 kbdcalls, 23.11.2006
    Zuletzt bearbeitet: 23.11.2006
    kbdcalls

    kbdcalls Master of Universe

    Dabei seit:
    16.10.2006
    Beiträge:
    518
    Zustimmungen:
    0
    Ist schon etwas komisch . Die menu.lst dürfte eigentlich keine Rolle spielen. Wenn dann allerhöchstens die device.map. Die entweder löschen, oder den Parameter --recheck benutzen. So das man ihn zwingt den Laufwerkscheck durchzuführen trotz device.map . Ist aber auch schwer vorstellerbar das er daran scheiter es steht nix von Partionen drinne. Kann es sein das in der fstab von hda4 steht ? Möglich wäre noch das fehlende procfs bzw. sysfs

    So sieht die bei mir aus Beispielsweise.

    Code:
    (hd0)   /dev/sda
    (hd1)   /dev/sdb
    
    Code:
    
    
    Nachtrag: Die Ubuntucd läßt sich aber auch im Recuemodus starten. Hab mit der hier ausprobiert

    http://ubuntu.intergenia.de/releases/6.06.1/ubuntu-6.06.1-alternate-i386.iso
     
Thema:

Linux bootet nicht mehr/grub verunstaltet

Die Seite wird geladen...

Linux bootet nicht mehr/grub verunstaltet - Ähnliche Themen

  1. Fesplatte im Wechselrahmen - ohne bootet linux nicht

    Fesplatte im Wechselrahmen - ohne bootet linux nicht: Hallo zusammen! ich habe in meinem Rechner zwei Festplatten. Liefen immer problemlos. Nun habe ich die eine (slave) in einen Wechselrahmen...
  2. Habe Linux blind gelöscht -> WinXP bootet nicht mehr

    Habe Linux blind gelöscht -> WinXP bootet nicht mehr: Hallo zusammen, hoffentlich könnt ihr mir helfen. Ich klicke mich schon seit einigen Stunden durchs Netz, finde aber keine passende Hilfe zu...
  3. grub bootet kein linux mehr

    grub bootet kein linux mehr: hi, ich hab vor kurzem mein windows neu aufgesetzt. Da ich gelesen hab, dass nach einer windows neuinstallation grub nicht mehr funktioniert, bin...
  4. Linux Bootet nicht ...

    Linux Bootet nicht ...: Hi, wenn ich archlinux-x86 oder ubuntu-x64 installiere, dann kommt vollgendes beim booten: Loading the Kernel ALERT! /dev/hdc7 does not...
  5. GRUB bootet Linux nicht

    GRUB bootet Linux nicht: Hallo, ich muss zunächst sagen dass ich mich bisher wenig mit Linux beschäftigt habe, obwohl es mich schon interessiert ... leider verzettle...