Kenrnel Update schiefgegangen

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von netbui, 30.09.2006.

  1. netbui

    netbui Eroberer

    Dabei seit:
    08.06.2006
    Beiträge:
    61
    Zustimmungen:
    0
    Hallo,

    hatte den ZMD falsch eingestellt und daduch lange Zeit kein einziges Update für Suse 10.1 64 bekommen. Nachdem ich das korrigiert hatte und einen Updateserver engetragen hatt, wurden über 300 Pakete akualisiert, u.a. auch der Kernel. Ich habe den Computer die Nacht durchaulfen lassen und ihn am Morgen ausgschaltet. Dabei kam irgendeine Fehlermeldung, dass das Update nicht erfolgreich war... und da ich schnell zur Sbahn musste habe ich sie weggeklickt. Am Abend dann die Überrschaung: System startet nicht mehr - Kernelpanic. Grmpf

    Ich habe dann von der Suse DVD gebootet, ein chroot auf das installierte System durchgeführt und den Kernel 2.6.16.21-0.25-default mit yast2 erst gelöscht und dann wieder eingespielt. Die Fehlermeldung hat sich verändert, nun bekomme ich beim booten:

    Code:
    Faild to execute /init 
    Kernel Panic - not syncing: no init found. Try passing init= option to the kernel
    meiene fstab:
    Code:
    title SUSE Linux 10.1
        root (hd0,1)
        kernel /vmlinuz-2.6.16.21-0.25-default root=/dev/hda3 vga=0x31a splash=silent showopts   
     initrd /initrd-2.6.16.21-0.25-default
    la /boot
    Code:
    ../
    boot/
    grub/
    lost+found/
    System.map-2.6.16.21-0.25-default
    System.map-2.6.16.21-0.25-smp
    System.map-2.6.16.21-0.25-xen
    System.map-2.6.17-gentoo-r7
    backup_mbr
    config-2.6.16.21-0.25-default
    config-2.6.16.21-0.25-smp
    config-2.6.16.21-0.25-xen
    config-2.6.17-gentoo-r7
    gengen
    gentoo
    initramfs-genkernel-x86-2.6.15-gentoo-r5
    initrd
    initrd-2.6.16.21-0.25-default
    initrd-2.6.16.21-0.25-smp
    initrd-2.6.16.21-0.25-xen
    initrd-xen
    initrd.previous
    kernel-default-2.6.16.13-4.i586.rpm
    kernel-genkernel-x86-2.6.15-gentoo-r5
    la.txt
    symsets-2.6.16.21-0.25-default.tar.gz
    symsets-2.6.16.21-0.25-smp.tar.gz
    symsets-2.6.16.21-0.25-xen.tar.gz
    symtypes-2.6.16.21-0.25-default.gz
    symtypes-2.6.16.21-0.25-smp.gz
    symtypes-2.6.16.21-0.25-xen.gz
    symvers-2.6.16.21-0.25-default.gz
    symvers-2.6.16.21-0.25-smp.gz
    symvers-2.6.16.21-0.25-xen.gz
    vmlinux-2.6.16.21-0.25-default.gz
    vmlinux-2.6.16.21-0.25-smp.gz
    vmlinux-2.6.16.21-0.25-xen.gz
    vmlinuz
    vmlinuz-2.6.16.21-0.25-default
    vmlinuz-2.6.16.21-0.25-smp
    vmlinuz-2.6.16.21-0.25-xen
    vmlinuz-2.6.17-gentoo-r7
    vmlinuz-xen
    vmlinuz.previous
    xen-3.0.2_09749-0.7.gz
    xen-3.0.gz
    xen-3.gz
    xen-dbg-3.0.2_09749-0.7.gz
    xen-dbg-3.0.gz
    xen-dbg-3.gz
    xen-dbg.gz
    xen-syms
    xen-syms-3.0.2_09749-0.7
    xen-syms-dbg
    xen-syms-dbg-3.0.2_09749-0.7
    xen.gz

    Hat jemand einen Tipp für mich? Wie ist die Meldung "Try passing init= option to the kernel" zu verstehen? In der menue.lst habe ich ja stehen: initrd /initrd-2.6.16.21-0.25-default, oder ist damit etwas anderes gemeint?


    Als wenn jemand eine Idee hätte....
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Lumpi

    Lumpi Haudegen

    Dabei seit:
    14.06.2006
    Beiträge:
    663
    Zustimmungen:
    0
    Ort:
    Dessau
    Der Kernel erzeugt beim booten eine Initial-Ramdisk
    ,die er dann in ein Verzeichnis ablegen will und das nicht findet
    Ist wohl eher ein Bootloader ;)
    Bei meiner Suse 10.0 (Kernel 2.6.13-15.12-default)
    ist dieser Eintrag im Grub

    title SUSE LINUX 10.0
    root (hd0,1)
    kernel /boot/vmlinuz root=/dev/hda2 vga=0x31a selinux=0 resume=/dev/hda3 splash=silent showopts
    initrd /boot/initrd

    Das ist aber wie gesagt "MEINE" Einstellung.

    Gruß Lumpi
     
  4. netbui

    netbui Eroberer

    Dabei seit:
    08.06.2006
    Beiträge:
    61
    Zustimmungen:
    0
    Moin,

    danke für den Tipp. Ich habe

    Code:
    title SUSE Linux 10.1
        root (hd0,1)
        kernel /vmlinuz-2.6.16.21-0.25-default root=/dev/hda3 vga=0x31a splash=silent showopts   
     initrd /initrd-2.6.16.21-0.25-default
    durch

    Code:
    title SUSE Linux 10.1
        root (hd0,1)
        kernel [B]/boot/[/B]vmlinuz-2.6.16.21-0.25-default root=/dev/hda3 vga=0x31a splash=silent showopts   
     initrd [B]/boot/[/B]initrd-2.6.16.21-0.25-default
    ersetzt, leider bleibt die Fehlermeldung identisch. Auf Deiner Installation ist ein Symlink auf den Kernel und die Initrmdisk gesetzt, ich habe sie fest verdrahtet und das ging ja vorher auch.
     
  5. #4 nikster77, 30.09.2006
    nikster77

    nikster77 Routinier

    Dabei seit:
    15.03.2004
    Beiträge:
    307
    Zustimmungen:
    0
    Hmm... ich glaub initrd interessiert dabei nicht sonderlich.
    no init found heisst einfach das /sbin/init nicht gefunden werden kann was entweder heisst:
    a) es ist nicht vorhanden
    b) es ist kaputt
    c) (wahrscheinlich) ddie Rootpartition ist falsch gesetzt bzw. wird nicht als solche
    erkannt.

    Da du Grub hast: einfach mal am bootprompt die Grubshell starten und verschiedene Rootpartitionen durchtesten.

    Ansonsten mal reinchrooten und /sbin/init fixen.
     
  6. netbui

    netbui Eroberer

    Dabei seit:
    08.06.2006
    Beiträge:
    61
    Zustimmungen:
    0
    Code:
    Disk /dev/hda: 120.0 GB, 120060444672 bytes
    255 heads, 63 sectors/track, 14596 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/hda1               1        3916    31455238+   7  HPFS/NTFS
    /dev/hda2   *        3917        3929      104422+  83  Linux
    /dev/hda3            3930       13289    75184200   83  Linux
    /dev/hda4           13290       14596    10498477+  83  Linux
    
    Ich hatte die Partitionen während des Updates nicht verändert, das System lief mit der menue.lst längere Zeit. /dev/hda2 ist dir Bootpartition, /dev/hda3 die Systempartition.

    Code:
    ws:/sbin# cd /
    ws:/# /sbin/init
    Usage: init 0123456SsQqAaBbCcUu
    Init ist vorhanden und läßt sich starten.
    Code:
    ws:/# mount
    /dev/hda3 on / type auto (rw)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    debugfs on /sys/kernel/debug type debugfs (rw)
    udev on /dev type tmpfs (rw)
    devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
    /dev/hda2 on /boot type ext2 (rw,acl,user_xattr)
    Hat sonst noch jemand ne Idee?
     
  7. #6 nikster77, 30.09.2006
    nikster77

    nikster77 Routinier

    Dabei seit:
    15.03.2004
    Beiträge:
    307
    Zustimmungen:
    0
    Bau dir im chroot einen neuen Kernel, da wird ein Treiber fehlen bzw. einer zuviel sein, evtl. hast du irgendein "bootoff onboard chipset first" oder so da drin.
    Kannst aich mal bei SuSE im Bugzilla schauen ob mehrere Leute das Prob mit dem Kernel hatten.

    Versuch mal initrd auszukommentieren evtl. ist da irgendwas verfranst.
     
  8. netbui

    netbui Eroberer

    Dabei seit:
    08.06.2006
    Beiträge:
    61
    Zustimmungen:
    0
    Ich habe mal den alten Kernel 2.6.13-15.12 installiert - leider mit dem selben Ergebnis.
    Da ich keine Bock habe, mich weiterhin mit de Problem zu beschäftigen, kommt nun auch auf dieses System Gentoo :-)

    By By Suse... und vielen Dank für eure Hilfe.
     
  9. #8 Keruskerfürst, 02.10.2006
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Man kann auch mit dem Rettungssystem das installierte System booten.
    Dazu einfach die erste CD oder DVD verwenden.
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 supersucker, 02.10.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    [Klugscheissmodus]

    Nein.

    Wozu sollte der Kernel dass tun?

    Die initrd wird nicht vom Kernel erzeugt, und schon gar nicht während des Bootens.

    siehe hier

    [/Klugscheissmodus]
     
  12. netbui

    netbui Eroberer

    Dabei seit:
    08.06.2006
    Beiträge:
    61
    Zustimmungen:
    0
    Hi,

    ich betreibe das System seit Letzten Donnerstag mit der Suse DVD und boot damit meine Installation, binn also nicht total aufgeschmissen. Wie schon geschrieben, ich habe gestern ein Abbild meiner Gentoo Installation vom meinem Gentoo-VDR- Fileserver rüberkopirt und werde das System heute Abend hoffentlch das erste Mal erfolgreich unter Gentoo booten :-)
     
Thema:

Kenrnel Update schiefgegangen

Die Seite wird geladen...

Kenrnel Update schiefgegangen - Ähnliche Themen

  1. Update auf Apache >=2.4.12 unter Debian Jessie

    Update auf Apache >=2.4.12 unter Debian Jessie: Hi, aufgrund eines Bugs in Apache 2.4 benötige ich zum Deployment von Seafile unter Debian Jessie das Paket apache2 in der Version >= 2.4.12...
  2. Nicht erkannte Zeichen nach Update

    Nicht erkannte Zeichen nach Update: Hi, nachdem ich mein Kali Linux geupdated habe, ist mir aufgefallen dass viele Zeichen auf verschiedenen Nutzeroberflächen nur fehlerhaft...
  3. Nach Update debian 8 ist der Zugriff auf samba4 nicht möglich

    Nach Update debian 8 ist der Zugriff auf samba4 nicht möglich: Gerade habe ich debian mit dem Befehl "apt-get ugrade" aktualisiert. Es gab zahlreiche neue Daten unteranderen samba files. Nach neuem Start kann...
  4. Autehtifizierung gegen Password Server nach Update SAMBA 3.6.6

    Autehtifizierung gegen Password Server nach Update SAMBA 3.6.6: Hi... ich bekomme einfach den "Dreh" nicht an meine Recherche/Suche nach einer Lösung: Ein Samba 3.5.6 (läßt sich leider z.Z. nicht updaten) läuft...
  5. Autor von xscreensaver kritisiert Debian-Update-Strategie

    Autor von xscreensaver kritisiert Debian-Update-Strategie: Jamie Zawinski, der Autor von xscreensaver, ärgert sich über Meldungen von Fehlern, die in neueren Versionen seiner Software längst behoben sind....