Java will nicht

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von tarabaz, 02.02.2007.

  1. #1 tarabaz, 02.02.2007
    Zuletzt bearbeitet: 02.02.2007
    tarabaz

    tarabaz Jungspund

    Dabei seit:
    06.04.2005
    Beiträge:
    14
    Zustimmungen:
    0
    [gelöst] Java will nicht (LiquidLookAndFeel)

    Hi,

    wenn ich Java-Anwendungen starten möchte, bekomme ich folgende meldung:


    --------------------------------------------------------------
    Exception in thread "AWT-XAWT" java.lang.Error: can't load com.birosoft.liquid.LiquidLookAndFeel
    at javax.swing.UIManager.initializeDefaultLAF(UIManager.java:1176)
    at javax.swing.UIManager.initialize(UIManager.java:1257)
    at javax.swing.UIManager.maybeInitialize(UIManager.java:1245)
    at javax.swing.UIManager.getDefaults(UIManager.java:556)
    at javax.swing.UIManager.getColor(UIManager.java:590)
    at com.sun.java.swing.plaf.motif.MotifBorders$BevelBorder.<init>(MotifBorders.java:43)
    at com.sun.java.swing.plaf.motif.MotifLookAndFeel.initComponentDefaults(MotifLookAndFeel.java:197)
    at sun.awt.X11.XAWTLookAndFeel.initComponentDefaults(XAWTLookAndFeel.java:81)
    at javax.swing.plaf.basic.BasicLookAndFeel.getDefaults(BasicLookAndFeel.java:107)
    at sun.awt.X11.XToolkit.initUIDefaults(XToolkit.java:232)
    at sun.awt.X11.XToolkit.run(XToolkit.java:437)
    at java.lang.Thread.run(Thread.java:595)
    WARNING: LeafQuality not given, using default value(1.0)
    WARNING: Smooth not given, using default value(0.5)
    WARNING: Levels not given, using default value(3)
    WARNING: Ratio not given, using default value(0.05)
    WARNING: RatioPower not given, using default value(1.0)
    WARNING: Shape not given, using default value(0)
    WARNING: BaseSize not given, using default value(0.25)
    WARNING: Flare not given, using default value(0.5)
    WARNING: Lobes not given, using default value(0)
    WARNING: LobeDepth not given, using default value(0.0)
    WARNING: Leaves not given, using default value(0)
    WARNING: LeafShape not given, using default value(0)
    WARNING: LeafScale not given, using default value(0.2)
    WARNING: LeafScaleX not given, using default value(0.5)
    WARNING: LeafStemLen not given, using default value(0.5)
    WARNING: LeafDistrib not given, using default value(4)
    WARNING: LeafBend not given, using default value(0.3)
    WARNING: Scale not given, using default value(10.0)
    WARNING: ScaleV not given, using default value(0.0)
    WARNING: 0Scale not given, using default value(1.0)
    WARNING: 0ScaleV not given, using default value(0.0)
    WARNING: AttractionUp not given, using default value(0.0)
    WARNING: PruneRatio not given, using default value(0.0)
    WARNING: PrunePowerLow not given, using default value(0.5)
    WARNING: PrunePowerHigh not given, using default value(0.5)
    WARNING: PruneWidth not given, using default value(0.5)
    WARNING: PruneWidthPeak not given, using default value(0.5)
    WARNING: 0BaseSplits not given, using default value(0)
    WARNING: Species not given, using default value(default)
    WARNING: 0Taper not given, using default value(1.0)
    WARNING: 0CurveRes not given, using default value(3)
    WARNING: 0Curve not given, using default value(0.0)
    WARNING: 0CurveV not given, using default value(0.0)
    WARNING: 0CurveBack not given, using default value(0.0)
    WARNING: 0Length not given, using default value(1.0)
    WARNING: 0LengthV not given, using default value(0.0)
    WARNING: 0SegSplits not given, using default value(0.0)
    WARNING: 0SplitAngle not given, using default value(0.0)
    WARNING: 0SplitAngleV not given, using default value(0.0)
    WARNING: 0Branches not given, using default value(1)
    WARNING: 0BranchDist not given, using default value(0.0)
    WARNING: 0DownAngle not given, using default value(0.0)
    WARNING: 0DownAngleV not given, using default value(0.0)
    WARNING: 0Rotate not given, using default value(0.0)
    WARNING: 0RotateV not given, using default value(0.0)
    WARNING: 1Taper not given, using default value(1.0)
    WARNING: 1CurveRes not given, using default value(3)
    WARNING: 1Curve not given, using default value(0.0)
    WARNING: 1CurveV not given, using default value(0.0)
    WARNING: 1CurveBack not given, using default value(0.0)
    WARNING: 1Length not given, using default value(0.5)
    WARNING: 1LengthV not given, using default value(0.0)
    WARNING: 1SegSplits not given, using default value(0.0)
    WARNING: 1SplitAngle not given, using default value(0.0)
    WARNING: 1SplitAngleV not given, using default value(0.0)
    WARNING: 1Branches not given, using default value(10)
    WARNING: 1BranchDist not given, using default value(1.0)
    WARNING: 1DownAngle not given, using default value(30.0)
    WARNING: 1DownAngleV not given, using default value(0.0)
    WARNING: 1Rotate not given, using default value(120.0)
    WARNING: 1RotateV not given, using default value(0.0)
    WARNING: 2Taper not given, using default value(1.0)
    WARNING: 2CurveRes not given, using default value(1)
    WARNING: 2Curve not given, using default value(0.0)
    WARNING: 2CurveV not given, using default value(0.0)
    WARNING: 2CurveBack not given, using default value(0.0)
    WARNING: 2Length not given, using default value(0.5)
    WARNING: 2LengthV not given, using default value(0.0)
    WARNING: 2SegSplits not given, using default value(0.0)
    WARNING: 2SplitAngle not given, using default value(0.0)
    WARNING: 2SplitAngleV not given, using default value(0.0)
    WARNING: 2Branches not given, using default value(5)
    WARNING: 2BranchDist not given, using default value(1.0)
    WARNING: 2DownAngle not given, using default value(30.0)
    WARNING: 2DownAngleV not given, using default value(0.0)
    WARNING: 2Rotate not given, using default value(120.0)
    WARNING: 2RotateV not given, using default value(0.0)
    WARNING: 3BranchDist not given, using default value(1.0)
    WARNING: 3DownAngle not given, using default value(30.0)
    WARNING: 3DownAngleV not given, using default value(0.0)
    WARNING: 3Rotate not given, using default value(120.0)
    WARNING: 3RotateV not given, using default value(0.0)
    Exception in thread "main" java.lang.NullPointerException
    at javax.swing.MultiUIDefaults.getUIError(MultiUIDefaults.java:117)
    at javax.swing.UIDefaults.getUI(UIDefaults.java:721)
    at javax.swing.UIManager.getUI(UIManager.java:860)
    at javax.swing.JPanel.updateUI(JPanel.java:104)
    at javax.swing.JPanel.<init>(JPanel.java:64)
    at javax.swing.JPanel.<init>(JPanel.java:87)
    at javax.swing.JPanel.<init>(JPanel.java:95)
    at javax.swing.JRootPane.createGlassPane(JRootPane.java:482)
    at javax.swing.JRootPane.<init>(JRootPane.java:313)
    at javax.swing.JFrame.createRootPane(JFrame.java:247)
    at javax.swing.JFrame.frameInit(JFrame.java:228)
    at javax.swing.JFrame.<init>(JFrame.java:195)
    at net.sourceforge.arbaro.gui.Workplace.<init>(Workplace.java:149)
    at net.sourceforge.arbaro.arbaro_gui.main(arbaro_gui.java:36)


    --------------------------------------------------------------

    Ich hab OpenSuse 10.2 i586 laufen.
    Java runtime 5 und sdk sind istalliert (version 1.5.0) und scheinen auch richtig angesprochen zu werden:


    --------------------------------------------------------------
    tarabaz@linux-cc2p:~/Desktop/arbaro_1_9_6> java -version
    java version "1.5.0_10"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_10-b03)
    Java HotSpot(TM) Client VM (build 1.5.0_10-b03, mixed mode, sharing)
    tarabaz@linux-cc2p:~/Desktop/arbaro_1_9_6>


    --------------------------------------------------------------

    Hat villeicht jemand eine Idee wie sich das Problem lösen lässt?

    MFG

    Tarabaz
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 nequiquam, 02.02.2007
    nequiquam

    nequiquam Tripel-As

    Dabei seit:
    11.01.2007
    Beiträge:
    169
    Zustimmungen:
    0
    Hi,

    probier mal folgendes:

    (Quelle: http://www.linux-club.de/viewtopic.php?p=432725)

    Liebe Grüße, neq
     
  4. #3 tarabaz, 02.02.2007
    tarabaz

    tarabaz Jungspund

    Dabei seit:
    06.04.2005
    Beiträge:
    14
    Zustimmungen:
    0
    Hi,

    vielen Dank für deine Hilfe.

    Von "liquidlnf" steht da bei mir zwar nichts, aber ich hab die folgenden 2 Zeilen, die sich auf das "LiquidLookAndFeel" beziehen einfach auskommentiert (#-Zeichen an den anfang der Zeilen) und jetzt funktioniert es.

    ____________________________________________________________

    # swing.installedlaf.liquid.class = com.birosoft.liquid.LiquidLookAndFeel
    # swing.defaultlaf=com.birosoft.liquid.LiquidLookAndFeel
    ____________________________________________________________

    MFG

    Tarabaz
     
  5. #4 Kinkster, 02.02.2007
    Kinkster

    Kinkster Jungspund

    Dabei seit:
    17.10.2006
    Beiträge:
    18
    Zustimmungen:
    0
    Ort:
    bei Münster
    Ich habe ein ähnliches Problem.
    Habe cabaret installiert und Java ist auch installiert. Beim Start kommt aber

    Die Datei /usr/lib/jvm/jre/lib/swing.properties gibt es bei mir gar nicht :think:
     
  6. #5 supersucker, 02.02.2007
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Prüf mal welche Java-Version deine cabaret-Version benötigt und ob das passt.

    Ich vermute mal das hier das Problem liegt.
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 nequiquam, 02.02.2007
    nequiquam

    nequiquam Tripel-As

    Dabei seit:
    11.01.2007
    Beiträge:
    169
    Zustimmungen:
    0
    Hi,

    äh cabaret? Das Musical? :) Hab über Google http://www.cabaret-solutions.com/de/products/stage/details/
    gefunden.

    Da steht:
    Deckt sich ziemlich gut mit Deiner Fehlermeldung:
    Hast vermutlich Java 1.49 installiert. Brauchst aber mindestens Java 1.5.
    Probier es mal mit einer neueren Javaversion.

    Liebe Grüße, neq
     
  9. #7 Kinkster, 02.02.2007
    Kinkster

    Kinkster Jungspund

    Dabei seit:
    17.10.2006
    Beiträge:
    18
    Zustimmungen:
    0
    Ort:
    bei Münster
    Tatsache.
    War eigentlich überzeugt davon die neueste Version zu haben.
    Hab ein Update gemacht. Jetzt läufts.

    Danke :)
     
Thema:

Java will nicht

Die Seite wird geladen...

Java will nicht - Ähnliche Themen

  1. Ubuntu deinstalliert Oracle Java doch nicht

    Ubuntu deinstalliert Oracle Java doch nicht: Die ursprünglich von Canonical vorgetragene Idee, das Oracle-Java-6-Paket aus Sicherheitsgründen automatisch zu deinstallieren, wird doch nicht in...
  2. Debian 6... Java Installation nicht möglich (Abhängigkeiten)

    Debian 6... Java Installation nicht möglich (Abhängigkeiten): Moin, Vorher benutzte ich Linux Mint Lubuntu und oder Xubuntu. Heute habe ich mir Debian mit XFCE installiert. Habe in der Source.list...
  3. Nach diversen Package-Updates geht Java-Applikation nicht mehr

    Nach diversen Package-Updates geht Java-Applikation nicht mehr: Hallo, ich hab von einem Kollegen die Administration eines Debian-Lenny-Servers übernommen. Der Kollege hatte dort zu Beginn das von uns...
  4. Java, manche Schriften sind nicht mehr erkennbar!

    Java, manche Schriften sind nicht mehr erkennbar!: Ich habe scheinbar ein Problem mit dem JAVA :/ Siehe Screenie von JDownloader: [IMG] Das gleiche habe ich auch bei manchen Schriften im...
  5. Jalbum lässt sich nicht installieren, meckert Java an

    Jalbum lässt sich nicht installieren, meckert Java an: Habe bei der installation scheinbar ein Javaproblem. Das Programm setzt Java voraus. Die neuste Version ist installiert. Hier ist der log den ich...