Intel Grafik 915GM und XGL FEHLER (SUSE 10.2-i586) !!!!

Dieses Thema im Forum "Grafik / Video" wurde erstellt von Linux_starter, 08.01.2007.

  1. #1 Linux_starter, 08.01.2007
    Zuletzt bearbeitet: 08.01.2007
    Linux_starter

    Linux_starter Tripel-As

    Dabei seit:
    19.12.2006
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Warschau
    Hallo mal wieder sachen die mir zu weit gehen !

    Ich habe mein tolles Siemens Notbook mit dem Intel 915 Express GM Chipsatz. Als Treiber hat SUSE bei mir i810 installiert. Nun moechte ich den XGL Server verwenden um einen 3D Desktop zum laufen zu bringen.

    Leider ohne Erfolg. Nach der Aktivierung des 3D Desktop und neustart von KDE komme ich gar nicht mehr in KDE rei, da er automatisch wieder raus geht. Ich habe in meinem SUSE 10.2 ein Programm 3Ddiag gefunden und ausgefuehrt und das Resultat:

    -------------------------------------------------------------
    3Ddiag version 0.738
    Verifying 3D configuration:
    Using 3dinfo
    ************************************************************

    Verifying 3D configuration for 3D board "Intel Corporation 915 GM (8086@2592)":


    Tests for X.Org configuration:
    Config File /etc/X11/xorg.conf ... done.
    Driver ... done.
    Extensions ... failed!
    ================================================================
    3D Hardware acceleration is not used. To use 3D
    Hardware acceleration please specify these entries

    Load "dri"

    in the Section "Module" of your /etc/X11/xorg.conf.
    ================================================================
    Options ... done.


    Checking GL/GLU/glut runtime configuration:
    GL/GLU ... done (package Mesa)
    glut ... done (package freeglut)
    --------------------------------------------------------------------------

    Jetz was ist zum Beispiel DRI ? Muss ich das installieren oder soll ich es mit dem Intel Treiber installieren ? Mit Mandriva hat es auch funktioniert? also was habe ich fuer ein Problem ?

    Danke fuer Hilfe
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    glxinfo gab das aus wenn es jemand weiterhilft ;-)

    name of display: :0.0
    display: :0 screen: 0
    direct rendering: Yes
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
    client glx vendor string: SGI
    client glx version string: 1.4
    client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
    GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGI_swap_control, GLX_SGI_video_sync, GLX_SGIS_multisample,
    GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
    OpenGL vendor string: Tungsten Graphics, Inc
    OpenGL renderer string: Mesa DRI Intel(R) 915GM 20050225 x86/MMX/SSE2
    OpenGL version string: 1.3 Mesa 6.5.1
    OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_fragment_program, GL_ARB_imaging,
    GL_ARB_multisample, GL_ARB_multitexture, GL_ARB_point_parameters,
    GL_ARB_shadow, GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
    GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
    GL_ARB_texture_rectangle, GL_ARB_transpose_matrix,
    GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_window_pos,
    GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
    GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_cull_vertex, GL_EXT_compiled_vertex_array, GL_EXT_convolution,
    GL_EXT_copy_texture, GL_EXT_draw_range_elements, GL_EXT_fog_coord,
    GL_EXT_histogram, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,
    GL_EXT_point_parameters, GL_EXT_polygon_offset, GL_EXT_rescale_normal,
    GL_EXT_secondary_color, GL_EXT_separate_specular_color,
    GL_EXT_shadow_funcs, GL_EXT_stencil_wrap, GL_EXT_subtexture,
    GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
    GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_rectangle,
    GL_EXT_vertex_array, GL_3DFX_texture_compression_FXT1,
    GL_APPLE_client_storage, GL_APPLE_packed_pixels,
    GL_ATI_blend_equation_separate, GL_IBM_rasterpos_clip,
    GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate,
    GL_MESA_pack_invert, GL_MESA_ycbcr_texture, GL_MESA_window_pos,
    GL_NV_blend_square, GL_NV_light_max_exponent, GL_NV_texture_rectangle,
    GL_NV_texgen_reflection, GL_NV_vertex_program, GL_NV_vertex_program1_1,
    GL_OES_read_format, GL_SGI_color_matrix, GL_SGI_color_table,
    GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SGIX_depth_texture,
    GL_SUN_multi_draw_arrays
    glu version: 1.3
    glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

    visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
    id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
    ----------------------------------------------------------------------
    0x23 24 tc 0 32 0 r y . 8 8 8 8 0 0 0 0 0 0 0 0 0 None
    0x24 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 None
    0x25 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
    0x26 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
    0x27 24 tc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 Slow
    0x28 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 Slow
    0x29 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
    0x2a 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
    0x2b 24 dc 0 32 0 r y . 8 8 8 8 0 0 0 0 0 0 0 0 0 None
    0x2c 24 dc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 None
    0x2d 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
    0x2e 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
    0x2f 24 dc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 Slow
    0x30 24 dc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 Slow
    0x31 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
    0x32 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Und da noch meine x.org conf
    ----------------------------------------
    # /.../
    # SaX generated X11 config file
    # Created on: 2007-01-07T19:23:26+0100.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    FontPath "unix/:7100"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    EndSection

    Section "Module"
    Load "extmod"
    Load "type1"
    Load "glx"
    Load "freetype"
    Load "dbe"
    Load "v4l"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "pl"
    Option "XkbModel" "pc104"
    Option "XkbRules" "xfree86"
    EndSection


    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "Logitech Optical USB Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    Driver "synaptics"
    Identifier "Mouse[3]"
    Option "AccelFactor" "0.01"
    Option "BottomEdge" "650"
    Option "CircScrollDelta" "0.1"
    Option "CircScrollTrigger" "2"
    Option "CircularScrolling" "1"
    Option "Device" "/dev/input/mice"
    Option "EdgeMotionMaxSpeed" "15"
    Option "EdgeMotionMinSpeed" "15"
    Option "Emulate3Buttons" "on"
    Option "EmulateMidButtonTime" "75"
    Option "FingerHigh" "15"
    Option "FingerLow" "14"
    Option "HorizScrollDelta" "20"
    Option "LeftEdge" "120"
    Option "MaxSpeed" "0.5"
    Option "MaxTapMove" "110"
    Option "MaxTapTime" "180"
    Option "MinSpeed" "0.2"
    Option "Name" "Touchpad"
    Option "Protocol" "auto-dev"
    Option "RightEdge" "830"
    Option "SHMConfig" "on"
    Option "TopEdge" "120"
    Option "UpDownScrolling" "1"
    Option "Vendor" "ALPS"
    Option "VertScrollDelta" "20"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 304 228
    HorizSync 30-50
    Identifier "Monitor[0]"
    ModelName "CPT LCD MONITOR"
    Option "DPMS"
    VendorName "CPT"
    VertRefresh 43-60
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "915 GM"
    BusID "0:2:0"
    Driver "i810"
    Identifier "Device[0]"
    Option "SaXDualHead"
    Option "NoDDC"
    Option "usevnc" "no"
    Option "SaXDualMonitorVendor" "--> VESA"
    Option "SaXDualVSync" "50-60"
    Option "MonitorLayout" "CRT,LFP"
    Option "MetaModes" "1024x768-1024x768;1024x600-1024x600;800x600-800x600;768x576-768x576;640x480-640x480"
    Option "SecondMonitorHorizSync" "31-50"
    Option "SaXDualOrientation" "LeftOf"
    Option "SaXDualResolution" "1024x768"
    Option "SecondMonitorVertRefresh" "50-60"
    Option "SaXDualHSync" "31-50"
    Option "Clone" "yes"
    Option "SaXDualMonitorModel" "1024X768@60HZ"
    Screen 0
    VendorName "Intel"
    EndSection


    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    InputDevice "Mouse[3]" "SendCoreEvents"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    EndSection
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Zuerstmal packe bitte deine Konfigurationen und Outputs in Zukunft bitte in einen Code-Block. Überprüfe, ob das Modul 'dri' in der xorg.conf eingetragen ist oder poste deine xorg.conf (bitte in einem Code-Block!). Ausserdem solltest du nachschauen, ob die Kernel-Module i915, drm und i810 geladen sind. (lsmod als root ausführen listet alle geladenen Kernel-Module)
     
  4. #3 Linux_starter, 08.01.2007
    Linux_starter

    Linux_starter Tripel-As

    Dabei seit:
    19.12.2006
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Warschau
    Ich habe glaube ich Fortschritte gemacht. Und ich denke mal auch was du mit TextBlock meinst ! Sorry !
     

    Anhänge:

  5. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Ist dein Benutzer in der Gruppe 'video'? Die 'Option "NoDDC"' ist bei mir nicht drin, hab aber auch eine 945er Karte und glaube auch nicht, dass diese Option das Problem verursacht. glxinfo zeigt ja auch an, dass alles ok ist. Stelle doch mal XGL ein, logge dich aber nicht über den grafischen Login ein, sondern mache diesen aus und starte X mit 'startx'. Wenn er dann wieder aus KDE raus geht, dann poste doch mal die Xorg.0.log dieses Versuchs (also irgendwoanders hinkopieren bevor du X ohne XGL neu startest und dann hier posten). Per Default findest du diese unter /var/log/.

    Mit einer Code-Box meinte ich zwar keine Anhänge, ist aber auch OK. Ich meinte eher die code-Tags, die dir im erweiterten Editor hinter dem #-Button zur Verfügung stehen. Wenn du damit einen langen Output oder einen Log-Auszug "einrahmst", wird das ganze mit fester Schriftbreite und in einem scrollbaren Container angezeigt. Ausserdem bleiben Einrückungen erhalten.
     
  6. #5 Linux_starter, 08.01.2007
    Linux_starter

    Linux_starter Tripel-As

    Dabei seit:
    19.12.2006
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Warschau
    Naja also es hat wieder nicht geklappt. bin wieder hochkannt raus gefallen. Habe dir hier die Dateil LOG angehaengt. Ich glaube ich habe irgend ein Treiber Problem? Der User mit dem ich es gerade versuche ist Admin also das sollte kein Problem sein oder ?
     

    Anhänge:

  7. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Hmm, seltsam. Keine Fehler in der Log. Hast du mal ein System-Update gemacht?
     
  8. #7 Linux_starter, 09.01.2007
    Linux_starter

    Linux_starter Tripel-As

    Dabei seit:
    19.12.2006
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Warschau
    ja das ist auf dem neusten stand ? Kann das vielleicht mit dem Bildschirmanager zusammenhaengen oder Windiwsmanager ?
     
  9. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Du kannst es ja einfach mal mit einem anderen (z.B. Gnome) versuchen.
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 Linux_starter, 10.01.2007
    Linux_starter

    Linux_starter Tripel-As

    Dabei seit:
    19.12.2006
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Warschau
    Also ich habe es bis jetzt hin und her versucht, hatt aber nicht funktioniert. Jetzt habe ich mich entschlossen mein Mandriva Power Pack wieder zu installieren. Und siehe da es funktioniert :-) Aber danke fuer die Hilfe ......
     
  12. #10 Linux_starter, 16.02.2007
    Linux_starter

    Linux_starter Tripel-As

    Dabei seit:
    19.12.2006
    Beiträge:
    169
    Zustimmungen:
    0
    Ort:
    Warschau
    Nachdem ich jetzt das Mandriva wieder runter geschmissen und Suse installiert habe klappt es auch mit 3D aber leider nur mit XGL und das ist mit meiner 915 Karte zu langsam. Naja werde weiter probieren das mit AIGLX hinzubekommen da die Performance da besser ist.
     
Thema:

Intel Grafik 915GM und XGL FEHLER (SUSE 10.2-i586) !!!!

Die Seite wird geladen...

Intel Grafik 915GM und XGL FEHLER (SUSE 10.2-i586) !!!! - Ähnliche Themen

  1. Neue Intel-Grafikprozessoren nutzen proprietäre Firmware-Dateien

    Neue Intel-Grafikprozessoren nutzen proprietäre Firmware-Dateien: Ein neulich getätigter Beitrag zum Linux-Kernel zeigt, dass einige der neueren i915-Grafikprozessoren nun erstmals auf Firmware angewiesen sind,...
  2. Intel stellt eigenen Grafiktreiber-Installer vor

    Intel stellt eigenen Grafiktreiber-Installer vor: Der Hard- und Softwarehersteller Intel hat ein Installationswerkzeug für die eigenen, offenen Grafikkarten-Treiber vorgestellt. Das grafische...
  3. Ubuntu Intel GMA HD GPU - Probleme mit Grafiktreiber

    Ubuntu Intel GMA HD GPU - Probleme mit Grafiktreiber: Hallo. Ich hatte vor nem halben Jahr auf meinem Tecra A11-127 Ubuntu installiert. Da ist eine Intel GMA HD Grafik eingebaut. Die Auflösung des...
  4. Intel grafik treiber frieren system ein.

    Intel grafik treiber frieren system ein.: Hallo, wenn ich versuche X mit dem intel Treiber zu starten friert mein System ein, noch bevor es eine Xorg.0.log generieren kann. Um es...
  5. OpenSuse 10.2: Installation von Grafik Intel G965

    OpenSuse 10.2: Installation von Grafik Intel G965: Hardware: Hauptplatine Asus P5B-V, Intel G965, Intel Graphics Media Accelerator X3000 (onboard) System: OpenSuse 10.2 (x86-64) Situation:...