.htaccess unter apache2 auf Suse 9.3

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von PhoenixDH, 26.08.2005.

  1. #1 PhoenixDH, 26.08.2005
    PhoenixDH

    PhoenixDH NOOB

    Dabei seit:
    26.08.2005
    Beiträge:
    93
    Zustimmungen:
    0
    Habe da ein Problem mit meinem Webserver unter Suse 9.3 !
    möchte ein Verzeichnis mit .htaccess schützen, doch leider kommt keine Passwortabfrage wenn ich in das Verzeichnis per Browser wechsle !

    Wieso nicht, woran liegt das ?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 damager, 26.08.2005
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    evtl liegt es an AllowOverride?
    http://httpd.apache.org/docs/2.0/mod/core.html#allowoverride

    ist das für das directory gesetzt und wenn ja ..wie?
    sollte imho auf AllowOverride None gesetzt sein für das directory.

    wie z.b:
     
  4. #3 PhoenixDH, 26.08.2005
    PhoenixDH

    PhoenixDH NOOB

    Dabei seit:
    26.08.2005
    Beiträge:
    93
    Zustimmungen:
    0
    Ah ja, jetzt kommt Fehler 403 !
    Wie kann ich dem jetzt sagen das er die htpasswd verwenden soll um User da reinzulassen ?
     
  5. #4 damager, 26.08.2005
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    wie sieht den dein .htaccess den aus?
    hast du schon nen user + passwort angelegt (z.b_ htpasswd -c /home/user/html_auth/htpasswd user)?
    dann müsste die .htaccess mit der option "AccessFileName" ganau auf diese zeigen und der user unterdem der apache läuft muss diese datei natürlich lesen dürfen (rechte).
     
  6. #5 PhoenixDH, 26.08.2005
    PhoenixDH

    PhoenixDH NOOB

    Dabei seit:
    26.08.2005
    Beiträge:
    93
    Zustimmungen:
    0
    Meine httpd.conf sieht jetzt so aus:
    Code:
    # forbid access to the entire filesystem by default
    <Directory />
        Options None
        AllowOverride None
        Order deny,allow
        Deny from all
    </Directory>
    
    <Directory "/srv/www/htdocs">
        Options None
        AllowOverride None
        Order deny,allow
        Deny from all
    </Directory>
    
    # use .htaccess files for overriding,
    AccessFileName /srv/www/htdocs/.htaccess
    # and never show them
    <Files ~ "^\.ht">
        Order allow,deny
        Deny from all
    </Files>
    
    und meine .htaccess so:
    Code:
    AuthType Basic
    AuthName "Linuxweb"
    AuthUserFile /srv/www/htdocs/.htpasswd
    require valid-user
    
    .htaccess und .htpasswd liegen im gleichen Verzeichnis !
    Es geht aber noch nicht, es kommt keine Abfrage !
     
  7. #6 damager, 26.08.2005
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
  8. #7 PhoenixDH, 26.08.2005
    PhoenixDH

    PhoenixDH NOOB

    Dabei seit:
    26.08.2005
    Beiträge:
    93
    Zustimmungen:
    0
    Ich werd mir das ganze mal anschaun !
     
  9. #8 PhoenixDH, 29.08.2005
    PhoenixDH

    PhoenixDH NOOB

    Dabei seit:
    26.08.2005
    Beiträge:
    93
    Zustimmungen:
    0
    So, habe das ganze hinbekommen für die Seite die in htdocs, sprich / liegt !
    Aber jetzt habe ich das Problem, das ich auch noch cgi-bin schützen muss.
    Dazu hab ich folgenden Eintrag in der httpd.conf gemacht:
    Code:
    <Directory /srv/www/cgi-bin>
        Options None
        AllowOverride ALL
        Order deny,allow
        Deny from all
    </Directory>
    
    die .htaccess und .htusers hab ich in das Verzeichnis kopiert und den Pfad angepasst, aber es kommt immer noch kein Eingabeaufforderung !

    .htaccess:
    Code:
    AuthType Basic
    AuthName "Linuxweb CGI-BIN"
    AuthUserFile /srv/www/cgi-bin/.htusers
    require valid-user
    
     
  10. #9 damager, 29.08.2005
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    was sagen die logfiles?
    /var/log/apache2/access_log
    /var/log/apache2/error_log
     
  11. #10 PhoenixDH, 29.08.2005
    PhoenixDH

    PhoenixDH NOOB

    Dabei seit:
    26.08.2005
    Beiträge:
    93
    Zustimmungen:
    0
    In der access_log steht der Zugriffsversuch von der IP als erfolgreich drin und die error_log bleibt leer !
     
  12. #11 damager, 29.08.2005
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    schon mal mit der:
    AllowOverride None
    probiert?
     
  13. #12 PhoenixDH, 29.08.2005
    PhoenixDH

    PhoenixDH NOOB

    Dabei seit:
    26.08.2005
    Beiträge:
    93
    Zustimmungen:
    0
    Ja hab ich eben, hab den Pfad im DIRECTORY auch schon in " gesetzt, da tut sich nix !

    Das andere geht mit der normalen Seite, da sieht das so aus:
    Code:
    <Directory />
        Options None
        AllowOverride ALL
        Order deny,allow
        Deny from all
    </Directory>
    
    Hab quasi nur den Pfad geändert, die Zugriffsdateien sind gleich !
     
  14. #13 damager, 29.08.2005
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    aber das / ist doch nur ein alias oder?
    oder gibts du bei dir alle filesysteme über den webserver frei?

    weiter oben schreibst du das bei dir in der httpd.conf:
    steht.
    das ist aber nicht das welches in dem cgi-directory ist oder?

    benutzen nur:
    AccessFileName .htaccess damit alle .htaccess files, egal wo die liegen, benutzt werden.
    zusätzlich würde ich noch den eintrag:
    <Files ~ "^\.ht">
    Order allow,deny
    Deny from all
    </Files>

    empfehlen damit diese nicht angezeigt bzw. gelesen werden können per browser.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 PhoenixDH, 29.08.2005
    PhoenixDH

    PhoenixDH NOOB

    Dabei seit:
    26.08.2005
    Beiträge:
    93
    Zustimmungen:
    0
    Habs hinbekommen, lag an AccessFileName !
     
  17. #15 PhoenixDH, 30.08.2005
    PhoenixDH

    PhoenixDH NOOB

    Dabei seit:
    26.08.2005
    Beiträge:
    93
    Zustimmungen:
    0
    Aber mir ist aufgefallen, das es nur klappt, wenn ich das so mache:
    Code:
    # forbid access to the entire filesystem by default
    <Directory />
        Options None
        AllowOverride ALL
        Order deny,allow
        Deny from all
    </Directory>
    
    <Directory /srv/www/cgi-bin/>
        Options None
        AllowOverride ALL
        Order deny,allow
        Deny from all
    </Directory>
    
    AccessFileName /srv/www/cgi-bin/.htaccess
    # and never show them
    <Files ~ "^\.ht">
        Order allow,deny
        Deny from all
    </Files>
    
    AccessFileName /srv/www/htdocs/.htaccess
    # and never show them
    <Files ~ "^\.ht">
        Order allow,deny
        Deny from all
    </Files>
    
    Aber in den .htaccess Dateien haben die Bereiche andere Namen, aber es wird immer die ein und selbe verwendet, woran liegt das ?
     
Thema:

.htaccess unter apache2 auf Suse 9.3

Die Seite wird geladen...

.htaccess unter apache2 auf Suse 9.3 - Ähnliche Themen

  1. Wie aktiviert man unter openSUSE .htaccess?

    Wie aktiviert man unter openSUSE .htaccess?: Bei openSUSE sind die Einstellungen für den Apachen auf mehrere Dateien verteilt. Ich habe das ganze soweit hinbekommen, dass die das URL rewrite...
  2. htaccess, Weiterleitung mit www und ohne www

    htaccess, Weiterleitung mit www und ohne www: Hallo zusammen, wie richtet man eine Weiterleitung einer alten Domain auf eine neue Domain, aber auch mit der Option ohne „www“ in der URL, dh...
  3. Domainabhängiger .htaccess-Zugriffsschutz, nur ein Doc-Root

    Domainabhängiger .htaccess-Zugriffsschutz, nur ein Doc-Root: Hi, ich habe gerade folgendes Problem und über Google soweit aber noch nix gefunden: Ich habe ein Wurzelverzeichnis, auf das mehrere Domains...
  4. .htaccess mit Apache 2.2.9 funktionier nicht???

    .htaccess mit Apache 2.2.9 funktionier nicht???: Hi, habe versucht Webinhalte mit .htaccess zu schützen. Aber Apache 2.2.9 zieht Dateien nicht an. Wo muss ich noch Einträge bei Apache...
  5. .htaccess - Frage zu geschütztem Verzeichnis

    .htaccess - Frage zu geschütztem Verzeichnis: Hallo Community, ist mein erster Post und ich hoffe er ist nicht gleich in der falschen Kategorie hier. :) Ich habe folgende Frage. Ich...