Hamachi unter suse Linux 10.0

Dieses Thema im Forum "Installation & Basiskonfiguration" wurde erstellt von rasputin_att, 27.03.2007.

  1. #1 rasputin_att, 27.03.2007
    rasputin_att

    rasputin_att Knowledge base'ler

    Dabei seit:
    27.03.2007
    Beiträge:
    51
    Zustimmungen:
    0
    Ort:
    Attendorn
    Also ich möchte gerne mit Hamachi ein Netzwerk mit ein paar Freunden erstellen.
    Da ich einen Server habe bietet es sich ja an diesen als Hamachi-server zu benutzen. Nebenbei läuft darauf ein Teamspeak-, Css- und DOD- Server.
    Wobei der css und der dod sich abwechseln... also laufen ncht gleichzeitig.

    Als ich am WE vor diesem Problem stand habe ich, als braver und gewissenhafter PC-Benutzer gegoogelt. Leider wurde ich nur bedingt fündig.

    Ich fand raus das ich einen Tun device brauche. Das stand unter "http://hamachi.cc/tuntap/"

    also wollte ich dieses installieren. Habe noch ein wenig weiter getüftelt. Hier mal das was rauskam:
    ===============================================================
    Console:
    user:~ # mknod /dev/net/tun c 10 200
    user:~ # /etc/modules.conf
    -bash: /etc/modules.conf: Keine Berechtigung
    user:~ # vi /etc/modules.conf
    user:~ # depmod -a
    WARNING: Couldn't open directory /lib/modules/2.6.9-023stab033.9-smp: No such file or directory
    FATAL: Could not open /lib/modules/2.6.9-023stab033.9-smp/modules.dep.temp for writing: No such file or directory 'Da dacht ich mir bau ich das Verzeichniss mal, vergeblich
    user:~ # mkdir /lib/modules/2.6.9-023stab033.9-smp
    user:~ # depmod -a
    user:~ # cd hamachi/
    user:~/hamachi # hamachi start
    27 14:02:09.407 [ 0] [22193] tap: bad response from tuncfg - 0200000d
    27 14:02:09.407 [ 0] [22193] open('/dev/net/tun') failed with 13 (Permission denied)
    ===============================================================

    Ich habe es mit root rechten und mit nem eigens angelegten user getestet...

    Irgendwie mach ich da was falsch. ich habe auch bei meinem provider nachgeschaut, ich habe die verlangte linux version(2.6.9-023stab033.9)

    Tja gehen tut es nicht, ich weiß nicht warum.

    Wie gesagt ich habe beim googeln etc nichts entdeckt. Wenn es einen thread hier gibt könnt ihr mir ja den Link schicken.

    Um schnelle Hilfe wäre ich sehr dankbar..=)

    MfG Ben 'Rasputin'
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 rasputin_att, 30.03.2007
    rasputin_att

    rasputin_att Knowledge base'ler

    Dabei seit:
    27.03.2007
    Beiträge:
    51
    Zustimmungen:
    0
    Ort:
    Attendorn
    Weiß keiner eine möglichkeit? Oh bitte...helft mir das klappt immer noch nicht, ich habe ers auch noch einmal mit einem .rpm probiert...geht auch nicht...

    MfG Rasputin
     
  4. #3 Wolfgang, 30.03.2007
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hallo
    Ich kenn mich speziell mit diesem Hamachi nicht aus, aber das sieht so aus, alsob du die Kernelheader brauchst.

    Unter lib/modules/<KERNELVERSION> liegen die Module, die zu deinem Kernel passen.
    Das selbst anlegen macht keinen Sinn.
    Du wirst wohl das Modul erst bauen müssen.
    Dazu brauchst du die Kernelheader zu deinem Kernel, oder den ganzen Sourcetree.

    Gruß Wolfgang
     
  5. #4 slash-ex, 30.03.2007
    slash-ex

    slash-ex Doppel-As

    Dabei seit:
    04.10.2006
    Beiträge:
    130
    Zustimmungen:
    0
    ich benutze hamachi mit suse 10.2 und da scheint es zu funktioniere. also bügle doch im zweifelsfall den aktuellen kernel drüber.
     
  6. #5 rasputin_att, 30.03.2007
    rasputin_att

    rasputin_att Knowledge base'ler

    Dabei seit:
    27.03.2007
    Beiträge:
    51
    Zustimmungen:
    0
    Ort:
    Attendorn
    Wo bekomme ich einen solchen source tree? Gibts da anleitungen? Hast du einen Link?

    Aha, auf meinem Server ist Suse 10.0! Kann man auf einem I-net Server mal eben so den aktuellen Kernel drüber "bügeln"???

    oder sollte ich den support anrufen? Machen die das?

    Bei meinem Notebook, klar habe ich das mit dvd gemacht, tja, leider kann ich ja nicht in rz nach frankfurt...xD...achja, schön wärs schon^^

    Auf antworten gespannt....MfG Ra_att
    :))
     
  7. #6 Wolfgang, 30.03.2007
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hallo
    Da du SuSe hast, solltest du lieber nach Kernel-Paketen mit deinem Paket-Management suchen.
    IMHO Backen die ja eigene Kernel. (kann mich erinnern, dass da mal etwas war)
    Sorry, habe keine SuSe.
    Du brauchst aber die Version, die dein laufender Kernel hat.
    uname -a
    Aber du solltest natürlich auch von kernel.org den Kernel bekommen.
    Notfalls selber einen neuen bauen.

    Dazu findest du im Netzt genügend Hinweise.

    Um Module zu bauen, genügen aber die passenden Kernelheader.

    Gruß Wolfgang
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 rasputin_att, 31.03.2007
    rasputin_att

    rasputin_att Knowledge base'ler

    Dabei seit:
    27.03.2007
    Beiträge:
    51
    Zustimmungen:
    0
    Ort:
    Attendorn
    Mhh ich kann dir zwar folgen aber leider habe ich eine frage...
    wie kommt man in den paket manager? das is mir jetzt mal ganz neu...

    Wäre über hilfe erfreut...
     
  10. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    -> Yast - Software installieren ...
     
Thema:

Hamachi unter suse Linux 10.0

Die Seite wird geladen...

Hamachi unter suse Linux 10.0 - Ähnliche Themen

  1. Arch Linux via Hamachi zu bestehendem VPN verbinden

    Arch Linux via Hamachi zu bestehendem VPN verbinden: Guten Tag zusammen! Ich betreibe zu Hause einen kleinen Server für Minecraft und samba file sharing und möchte diesen nun zu meinem bestehenden...
  2. Gameserver über 2 LAN Karten erreichbar machen. Hamachi+LAN

    Gameserver über 2 LAN Karten erreichbar machen. Hamachi+LAN: Tag! Hoffentlich kennt sich jemand damit aus... Ich habe ein FreeBSD RooT Server und würder ein Gameserver (CS:S CS L4D...) aufmachen aber...
  3. Hamachi + Wc3 (Cedega)

    Hamachi + Wc3 (Cedega): Hi, Ein Kumpel von mir, möchte mit mir Wc3 über Hamachi spielen. Sowohl das installieren, wie auch das starten und einloggen von Hamachi...
  4. hamachi - tap: connect() failed

    hamachi - tap: connect() failed: Guten Abend. Ich beschäftige mich jetzt seit ein paar Tagen mit dem Hamachi. Allerdings mit der Windows-Version. Nun hab ich auch mitbekommen...
  5. Update auf Apache >=2.4.12 unter Debian Jessie

    Update auf Apache >=2.4.12 unter Debian Jessie: Hi, aufgrund eines Bugs in Apache 2.4 benötige ich zum Deployment von Seafile unter Debian Jessie das Paket apache2 in der Version >= 2.4.12...