Fehlermeldung beim Kompilieren

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Exzel, 17.06.2007.

  1. Exzel

    Exzel Jungspund

    Dabei seit:
    30.09.2006
    Beiträge:
    24
    Zustimmungen:
    0
    Hallo zusammen,

    hab' ein bisschen am Kernel herumgebastelt und wollte ihn mit dem Befehl

    make-kpkg --append-to-version -new modules --initrd kernel-image

    kompilieren.

    Doch leider bekomme ich die Fehlermeldung

    The UTS Release version in include/linux/version.h
    ""
    does not match current version:
    "2.6.18-new"
    Please correct this.
    make: *** [modules] Fehler 2

    Was muss ich jetzt tun?

    THX
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Goodspeed, 17.06.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    mach mal vorher ein
    Code:
    make-kpkg clean modules_clean
    
     
  4. Exzel

    Exzel Jungspund

    Dabei seit:
    30.09.2006
    Beiträge:
    24
    Zustimmungen:
    0
    Hallo und danke für die Antwort.

    leider bekomme ich noch immer die Fehlermeldung.


    Was ist eigentlich UTS?

    PS:Ich habe Debian 4 auf meinem Rechner und als Kernel ist der 2.6.18-4-k7 installiert.


    THX
     
  5. #4 Goodspeed, 17.06.2007
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Warum nimmst Du eigentlich modules und nicht modules_image?
     
  6. Exzel

    Exzel Jungspund

    Dabei seit:
    30.09.2006
    Beiträge:
    24
    Zustimmungen:
    0
    Leider funktioniert es auch nicht mit modules-image.
     
  7. #6 Bâshgob, 17.06.2007
    Bâshgob

    Bâshgob freies Radikal

    Dabei seit:
    29.07.2004
    Beiträge:
    2.334
    Zustimmungen:
    0
    Ort:
    Hannover
    Für mich sieht das so aus als ob Kernelheader und Sourcen nicht miteinander wollen. Mal apt-get update && apt-get upgrade durchlaufen lassen und nochmal probieren.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. Exzel

    Exzel Jungspund

    Dabei seit:
    30.09.2006
    Beiträge:
    24
    Zustimmungen:
    0
    Hallo und sorry für die späte Antwort,

    hab' vorher ein apt-get update && apt-get upgrade laufen lassen wieder mit dem gleichen Ergebnis.

    The UTS-Release-Version...
     
  10. Exzel

    Exzel Jungspund

    Dabei seit:
    30.09.2006
    Beiträge:
    24
    Zustimmungen:
    0
    Hallo nochmal,

    wollte nur bescheid sagen, dass jetzt alles funktioniert. Hab' gestern nochmal gegoogelt. Bei make-kpkg --initrd kernel-image werden die Module mit erstellt, was auch einwandfrei funktionierte.

    Auch wenn make-kpkg modules-image trotzdem nicht funktionierte,konnte ich das Kernelpaket inkl. Module erfolgreich installieren.

    THX
     
Thema:

Fehlermeldung beim Kompilieren

Die Seite wird geladen...

Fehlermeldung beim Kompilieren - Ähnliche Themen

  1. Fehlermeldung beim SSH-Login / Server nicht mehr erreichbar

    Fehlermeldung beim SSH-Login / Server nicht mehr erreichbar: Hallo, nach einem Neustart ist mein Lenny (Root-Server bei Hetzner) leider nicht mehr so richtig aufgewacht. Die Symptome: - Websites sind...
  2. Fehlermeldungen beim Löschen von Dateien

    Fehlermeldungen beim Löschen von Dateien: Hallo, ich bekomme beim Löschen eines Verzeichnisses Fehlermeldungen und kann daher dieses Verzeichnis nicht löschen. Beispiel: rm Downloads -R...
  3. Fehlermeldung beim starten von Yast

    Fehlermeldung beim starten von Yast: Hallo wenn ich Yast starten will kriege ich die fehlermeldung "Yast got signal 11 at YCP file PackagesUI.ycp:240 /sbin/yast2: line 440: 4042...
  4. GDM: Fehlermeldung beim Anmelden

    GDM: Fehlermeldung beim Anmelden: GDM: Fehlermeldung beim Anmelden [gelöst] hallo liebe community, ich kriege seid neustem beim anmelden einer Gnomesession als Benutzer (opensuse...
  5. Fehlermeldung beim Auslesen einer Exceldatei

    Fehlermeldung beim Auslesen einer Exceldatei: Hallo Zusammen, ich bin ziemlich neu hier in der ganzen Materie und hab folgendes Problem. Ich möchte die 5. Spalte einer Exceldatei...