Fehler in den Abhängigkeiten apt-get

Dieses Thema im Forum "Anwendungen" wurde erstellt von jimmyone, 10.05.2008.

  1. #1 jimmyone, 10.05.2008
    jimmyone

    jimmyone Eroberer

    Dabei seit:
    21.02.2008
    Beiträge:
    70
    Zustimmungen:
    0
    Hallo zusammen,

    da ich mit Yast (Suse9.2) irgendwie nicht zurecht komme, habe ich mir apt auf meine Maschine installiert. Aber irgendwie gibts da ein Problem mit den Abhängigkeiten denn jedes Paket, das ich installieren will (in dem Fall gcc) bricht mit folgendem Fehler ab. Ich weiß nun nicht mehr was ich tun soll...

    Code:
    srv02:~ # apt-get install gcc
    Reading Package Lists... Done
    Building Dependency Tree... Done
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
      gcc: Depends: glibc-devel but it is not going to be installed
           Depends: cpp (= 3.3.4-11) but it is not going to be installed
      mod_php4-apache2: Obsoletes: apache2-mod_php4 but 4.3.8-8.28.1.swsoft is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    
    Danke für die Hilfe.
    Ich weiß auch, das Suse9.2 sehr veraltet ist. Mein Hoster setzt es aber stur wie ein Esel ein und lässt mich net ausm Vertrag.
    Deshalb ist das Teil primär nur noch ein Spielserver. Alles wichtige liegt bei nem richtigen Hoster.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 gropiuskalle, 11.05.2008
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Es gibt keine aktuellen Pakete mehr für die 9.2, und daran hakt es.
     
  4. #3 bitmuncher, 11.05.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Ich vermute mal, dass du das Repository von deinem Hoster nutzt. Erstmal würde ich das tun, was die Fehlermeldung besagt, nämlich ein 'apt-get -f install'. Danach ein 'apt-get update' und dann nochmal die Installation versuchen. Ggf. musst du auch ein Update deiner installierten Pakete machen. Auch wenn es so scheint, macht 'apt-get update' kein System-Update, sondern aktualisiert lediglich die Paket-Datenbank.
     
  5. #4 jimmyone, 11.05.2008
    jimmyone

    jimmyone Eroberer

    Dabei seit:
    21.02.2008
    Beiträge:
    70
    Zustimmungen:
    0
    Das apt-get -f install habe ich schon probiert, er kann den Fehler nicht ausbügeln...

    Edit:

    Ist es möglich, eine neue Distribution auf einen vServer aufzuspielen?
    Ich bin mir da nicht sicher, wie das ganze ablaufen soll. Dann würde ich das nämlich einfach tun.
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Fehler in den Abhängigkeiten apt-get

Die Seite wird geladen...

Fehler in den Abhängigkeiten apt-get - Ähnliche Themen

  1. Terminal Fehlermeldung

    Terminal Fehlermeldung: Hola, mir ist aufgefallen das ständig ein Fehler erscheint sobald ich einen Terminal öffne. Hat zwar keine Auswirkung auf die Arbeit damit sieht...
  2. LibreOffice 5.1.1 korrigiert Fehler

    LibreOffice 5.1.1 korrigiert Fehler: Das LibreOffice-Projekt hat die Verfügbarkeit der Version 5.1.1 der freien Office-Suite bekannt gegeben. In diesem planmäßigen Update werden...
  3. Fehler in glibc gefährdet zahlreiche Systeme

    Fehler in glibc gefährdet zahlreiche Systeme: Sicherheitsforscher haben eine Sicherheitslücke in der glibc-Bibliothek entdeckt, die sich von externen Angreifern über das Netzwerk ausnutzen...
  4. LibreOffice veranstaltet Fehlerjagd

    LibreOffice veranstaltet Fehlerjagd: Das LibreOffice-Projekt hat angekündigt, vom 15. bis 17. Januar die mittlerweile dritte öffentliche »Bug Hunting Session« für Version 5.1 der...
  5. Linux.Encoder: Das Laster der fehlerhaften Kryptografie

    Linux.Encoder: Das Laster der fehlerhaften Kryptografie: Der mittlerweile in der dritten Generation nun vorliegende Ransomware »Linux.Encoder« kann immer noch kaum Schrecken unter Linux verbreiten -...