bind failed on port 445 und 139

Dieses Thema im Forum "Samba" wurde erstellt von Eydamos, 13.08.2011.

  1. #1 Eydamos, 13.08.2011
    Eydamos

    Eydamos Jungspund

    Dabei seit:
    12.03.2011
    Beiträge:
    17
    Zustimmungen:
    0
    Hallo,

    ich weiß es gibt tausender solcher Threads, leider konnte keiner davon mir bisher weiterhelfen. Also starte ich diesen hier um (hoffentlich) mit euch dieses exakte Probleme auf meinem Server zu lösen.

    Ich habe ein RHEL 5 laufen. Alle Partitionen sind ext3 formatiert und ich habe zwei 2TB Platte im RAID0 als /data gemountet.
    iptables habe ich nach einer Anleitung die ich mal gegoogelt hatte deaktiviert.

    Um sicher zu sein, das es nicht an der config liegt ist meine smb.conf entsprechend klein:
    Code:
    [global]
            workgroup = FAMILY
            log level = 2
            log file = /etc/samba/logs/log.%m
    
    netstat -tulpen vor dem starten:
    Code:
    Aktive Internetverbindungen (Nur Server)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       Benutzer   Inode      PID/Program name
    tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN      0          8503       2359/portmap
    tcp        0      0 0.0.0.0:884                 0.0.0.0:*                   LISTEN      0          8650       2398/rpc.statd
    tcp        0      0 127.0.0.1:631               0.0.0.0:*                   LISTEN      0          10822      2671/cupsd
    tcp        0      0 127.0.0.1:25                0.0.0.0:*                   LISTEN      0          10974      2710/sendmail: acce
    tcp        0      0 :::22                       :::*                        LISTEN      0          10768      2658/sshd
    udp        0      0 0.0.0.0:44970               0.0.0.0:*                               70         11397      2799/avahi-daemon:
    udp        0      0 0.0.0.0:68                  0.0.0.0:*                               0          8052       2174/dhclient
    udp        0      0 0.0.0.0:5353                0.0.0.0:*                               70         11395      2799/avahi-daemon:
    udp        0      0 0.0.0.0:878                 0.0.0.0:*                               0          8631       2398/rpc.statd
    udp        0      0 0.0.0.0:111                 0.0.0.0:*                               0          8502       2359/portmap
    udp        0      0 0.0.0.0:881                 0.0.0.0:*                               0          8641       2398/rpc.statd
    udp        0      0 0.0.0.0:631                 0.0.0.0:*                               0          10825      2671/cupsd
    udp        0      0 :::59339                    :::*                                    70         11398      2799/avahi-daemon:
    udp        0      0 :::5353                     :::*                                    70         11396      2799/avahi-daemon:
    
    nach dem Start des Server mit /etc/init.d/smb start habe ich folgendes in der log.smbd stehen:
    Code:
    rlimit_max: rlimit_max (1024) below minimum Windows limit (16384)
    [2011/08/13 10:38:22.711106,  2] printing/print_cups.c:550(cups_async_callback)
      cups_async_callback: failed to read a new printer list
    [2011/08/13 10:38:22.723721,  2] printing/print_cups.c:550(cups_async_callback)
      cups_async_callback: failed to read a new printer list
    [2011/08/13 10:38:22.725572,  2] lib/interface.c:340(add_interface)
      added interface eth1 ip=fe80::2e0:7dff:fe97:94ff%eth1 bcast=fe80::ffff:ffff:ffff:ffff%eth1 netmask=ffff:ffff:ffff:ffff::
    [2011/08/13 10:38:22.725734,  2] lib/interface.c:340(add_interface)
      added interface eth1 ip=192.168.178.31 bcast=192.168.178.255 netmask=255.255.255.0
    [2011/08/13 10:38:22.725953,  0] smbd/server.c:1165(main)
      standard input is not a socket, assuming -D option
    [2011/08/13 10:38:22.748055,  2] lib/util_sock.c:875(open_socket_in)
      bind failed on port 445 socket_addr = 0.0.0.0.
      Error = Die Adresse wird bereits verwendet
    [2011/08/13 10:38:22.749037,  0] smbd/server.c:500(smbd_open_one_socket)
      smbd_open_once_socket: open_socket_in: Die Adresse wird bereits verwendet
    [2011/08/13 10:38:22.749466,  2] lib/util_sock.c:875(open_socket_in)
      bind failed on port 139 socket_addr = 0.0.0.0.
      Error = Die Adresse wird bereits verwendet
    [2011/08/13 10:38:22.749547,  0] smbd/server.c:500(smbd_open_one_socket)
      smbd_open_once_socket: open_socket_in: Die Adresse wird bereits verwendet
    [2011/08/13 10:38:22.750300,  2] smbd/server.c:721(smbd_parent_loop)
      waiting for connections
    
    nach dem start des Servers:
    Code:
    Aktive Internetverbindungen (Nur Server)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       Benutzer   Inode      PID/Program name
    tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN      0          8503       2359/portmap
    tcp        0      0 0.0.0.0:884                 0.0.0.0:*                   LISTEN      0          8650       2398/rpc.statd
    tcp        0      0 127.0.0.1:631               0.0.0.0:*                   LISTEN      0          10822      2671/cupsd
    tcp        0      0 127.0.0.1:25                0.0.0.0:*                   LISTEN      0          10974      2710/sendmail: acce
    tcp        0      0 :::139                      :::*                        LISTEN      0          14993      3251/smbd
    tcp        0      0 :::22                       :::*                        LISTEN      0          10768      2658/sshd
    tcp        0      0 :::445                      :::*                        LISTEN      0          14991      3251/smbd
    udp        0      0 192.168.178.255:137         0.0.0.0:*                               0          15012      3255/nmbd
    udp        0      0 192.168.178.31:137          0.0.0.0:*                               0          15011      3255/nmbd
    udp        0      0 0.0.0.0:137                 0.0.0.0:*                               0          15006      3255/nmbd
    udp        0      0 192.168.178.255:138         0.0.0.0:*                               0          15014      3255/nmbd
    udp        0      0 192.168.178.31:138          0.0.0.0:*                               0          15013      3255/nmbd
    udp        0      0 0.0.0.0:138                 0.0.0.0:*                               0          15007      3255/nmbd
    udp        0      0 0.0.0.0:44970               0.0.0.0:*                               70         11397      2799/avahi-daemon:
    udp        0      0 0.0.0.0:68                  0.0.0.0:*                               0          8052       2174/dhclient
    udp        0      0 0.0.0.0:5353                0.0.0.0:*                               70         11395      2799/avahi-daemon:
    udp        0      0 0.0.0.0:878                 0.0.0.0:*                               0          8631       2398/rpc.statd
    udp        0      0 0.0.0.0:111                 0.0.0.0:*                               0          8502       2359/portmap
    udp        0      0 0.0.0.0:881                 0.0.0.0:*                               0          8641       2398/rpc.statd
    udp        0      0 0.0.0.0:631                 0.0.0.0:*                               0          10825      2671/cupsd
    udp        0      0 :::59339                    :::*                                    70         11398      2799/avahi-daemon:
    udp        0      0 :::5353                     :::*                                    70         11396      2799/avahi-daemon:
    Es läuft offensichtlich kein Prozess auf Port 139 bevor ich den smb starte. Wo also liegt der Fehler?
    Es steht zwar da :::139 und :::445 aber ich gehe jetzt mal davon aus das die Ausgabe eher so wie bei Port 137 und 138 aussehen sollte oder?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 sinn3r, 13.08.2011
    Zuletzt bearbeitet: 13.08.2011
    sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Wenn mich nicht alles täuscht, sind das IPv6 Adressen.

    Damit sollte alles okay sein, und laut dem hier lauschen IPv6 Geschichten auch auf IPv4. Kann ich weder bestätigen noch verneinen.

    Falls dich das stört, versuch es mal mit
    Code:
    bind interfaces only = yes
    interfaces = 127.0.0.1 host_ip_address
    in der smb.conf.
     
  4. #3 Eydamos, 13.08.2011
    Eydamos

    Eydamos Jungspund

    Dabei seit:
    12.03.2011
    Beiträge:
    17
    Zustimmungen:
    0
    Danke das hat geholfen, nun ist der Fehler weg.
    Allerdings muss es die IP des Servers sein und nicht die des Hosts ;)

    Nun kann ich auch problemlos auf den Server verbinden. Nur in den share komme ich nicht rein.

    meine nun erweiterte smb.conf:
    Code:
    [global]
            workgroup = FAMILY
            log level = 2
            log file = /etc/samba/logs/log.%m
            bind interfaces only = yes
            interfaces = 127.0.0.1 192.168.178.31
            netbios name = CABAL
    [share]
        writeable = yes
        path = /data/share/
        public = yes
        available = yes
    
    Wenn ich mit meinem Windows 7 PC auf Cabal zugreife fragt er nach dem Passwort des users das gebe ich dann ein und anschließend bekomme ich die Freigabe "share" auch zu sehen. Darauf zugreifen kann ich aber nicht.

    log.smbd:
    Code:
    rlimit_max: rlimit_max (1024) below minimum Windows limit (16384)
    [2011/08/13 15:05:29.746103,  2] param/loadparm.c:7859(do_section)
      Processing section "[share]"
    [2011/08/13 15:05:29.759124,  2] printing/print_cups.c:550(cups_async_callback)
      cups_async_callback: failed to read a new printer list
    [2011/08/13 15:05:29.771803,  2] printing/print_cups.c:550(cups_async_callback)
      cups_async_callback: failed to read a new printer list
    [2011/08/13 15:05:29.773822,  2] lib/interface.c:340(add_interface)
      added interface lo ip=127.0.0.1 bcast=127.255.255.255 netmask=255.0.0.0
    [2011/08/13 15:05:29.773940,  2] lib/interface.c:340(add_interface)
      added interface eth1 ip=192.168.178.31 bcast=192.168.178.255 netmask=255.255.255.0
    [2011/08/13 15:05:29.774181,  0] smbd/server.c:1165(main)
      standard input is not a socket, assuming -D option
    [2011/08/13 15:05:29.795677,  2] smbd/server.c:721(smbd_parent_loop)
      waiting for connections
    
    log.eydamos:
    Code:
    [2011/08/13 15:05:34.341447,  2] auth/auth.c:304(check_ntlm_password)
      check_ntlm_password:  authentication for user [smbuser] -> [smbuser] -> [smbuser] succeeded
    [2011/08/13 15:05:34.437119,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:34.439082,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:35.592478,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:35.595604,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:35.600240,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:35.603459,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:35.748829,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:35.751858,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:35.755862,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:35.759195,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:35.762148,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:35.765748,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:35.770258,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:35.774748,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:36.789970,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    [2011/08/13 15:05:36.794634,  0] smbd/service.c:988(make_connection_snum)
      canonicalize_connect_path failed for service share, path /data/share
    /data ist wie gesagt ein gemounteter Ordner auf einem 2TB RAID0

    Sowohl /data als auch /data/share gehören dem user smbuser.
    share ist zudem das Homeverzeichnis von smbuser.
    Beide Ordner haben rx Rechte für user group und all

    P.S. auch ein Ordner außerhalb von /data geht nicht
     
  5. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Ja die Adresse deines Servers. Also die Hostadresse des Rechners auf dem der Dienst läuft.

    Versuchs mal mit
    Code:
    chmod -R a+x /data/share
     
  6. #5 Eydamos, 13.08.2011
    Eydamos

    Eydamos Jungspund

    Dabei seit:
    12.03.2011
    Beiträge:
    17
    Zustimmungen:
    0
    Wie bereits gesagt ist auf dem Ordner bereits r und x für alle gesetzt.
    Ich habe aber des Rätsels Lösung gefunden.

    Überltäter ist hier SELinux.

    Stelle ich SELinux ab komme ich auf die Freigabe und kann alles machen was ich will.

    Mit folgendem Code kann man SELinux bis zum nächsten reboot ausschalten.
    Code:
    echo 0 > /selinux/enforce
    Allerdings ist dies nicht unbedingt sinnvoll.
    Siehe dazu auch folgenden Beitrag:
    http://www.crypt.gen.nz/selinux/disable_selinux.html

    Man sollte also eher gucken das man die Rechte in SELinux passend einstellt als die "erweiterte" Rechteverwaltung abzuschalten.
    Werde mich wohl etwas mit SELinux beschäftigen. Wennn ich eine Lösung mit aktiven Rechten finden sollte poste ich sie hier.
     
  7. sinn3r

    sinn3r Law & Order
    Moderator

    Dabei seit:
    28.12.2006
    Beiträge:
    2.764
    Zustimmungen:
    0
    Ort:
    Wentorf
    Hab ich überlesen, aber schön das du eine Lösung gefunden hast.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

bind failed on port 445 und 139

Die Seite wird geladen...

bind failed on port 445 und 139 - Ähnliche Themen

  1. Arch Linux via Hamachi zu bestehendem VPN verbinden

    Arch Linux via Hamachi zu bestehendem VPN verbinden: Guten Tag zusammen! Ich betreibe zu Hause einen kleinen Server für Minecraft und samba file sharing und möchte diesen nun zu meinem bestehenden...
  2. Kontextmenü mit einem Skript verbinden

    Kontextmenü mit einem Skript verbinden: Abend, wenn ich z. B. eine simple Umwandlung eines Bildformates in ein anderes über das KDE-Kontextmenü (Servicemenü nennt es sich im KDE oder...
  3. Verbindungen in iftop

    Verbindungen in iftop: Hallo, habe gerade ein bisschen mit iftop auf meinem Server rumgespielt, und da werden mir dutzende Verbindungen über den Port 53625 angezeigt....
  4. Cyanogen bindet Microsoft Cortana ein

    Cyanogen bindet Microsoft Cortana ein: Cyanogen hat in sein modifiziertes Android-System die Sprachsteuerung von Microsoft aufgenommen. Zwar ist Microsoft Cortana auch als allgemeine...
  5. cd mit Bindestrich im Verzeichnisnamen...?

    cd mit Bindestrich im Verzeichnisnamen...?: kann gelöscht werden