Auf PDC umstricken

Dieses Thema im Forum "Samba" wurde erstellt von Schildi, 11.07.2006.

  1. #1 Schildi, 11.07.2006
    Schildi

    Schildi Jungspund

    Dabei seit:
    31.05.2006
    Beiträge:
    24
    Zustimmungen:
    0
    Hallo,

    mein Samba läuft, mit dem Windows PC kann ich alles machen wie ich es mir vorstelle, aber ich würde das Ganze um PDC erweitern wollen. Ich habe diverse Tutorials mal gelesen, aber es fehlt mir da noch an etwas vertrauen. Wie gehe ich am besten vor, das mein laufendes System hinterher nicht total im Eimer ist. Reicht es wenn ich nur die smb.conf sichere, oder brauch ich noch mehr? Ich habe auch schon den einen oder anderen Versuch gemacht, allerdings erhalte ich vom Windows Clienten, wenn ich auf Domäne umstellen möchte, die Fehlermeldung das der Name nicht aufgelöst werden konnte. Also ein DNS Problem das ich nicht nachvollziehen kann. Wie soll ich nun vorgehen?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 theton, 11.07.2006
    Zuletzt bearbeitet: 11.07.2006
    theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Sichere am Besten erstmal alle Konfigurationen, die zu Samba gehoeren (lmhosts, smb.conf, secrets.tdb, smbpasswd und smbusers duerften wohl die wichtigsten sein). Die Netzwerk-Namen von Rechnern in einem Samba-Netzwerk werden nicht mit einem DNS aufgeloest". Eben dafuer ist u.a. der Domaincontroller verantwortlich.
     
  4. #3 Schildi, 11.07.2006
    Schildi

    Schildi Jungspund

    Dabei seit:
    31.05.2006
    Beiträge:
    24
    Zustimmungen:
    0
    Okay, dann kann ich noch weniger mit der Meldung anfangen. :) Oder der Samba wollte doch noch nicht.
     
  5. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Der PDC wollte wohl noch nicht. Da hast du bestimmt noch einen Fehler in der Konfiguration. Normalerweise sollte man aber die Hostnamen einfach in der /etc/hosts auf die IPs mappen koennen und unter Windows gibt's so'ne Datei auch irgendwo (ich glaub c:\<win-ordner>\system32\etc\hosts o.ae.).
     
  6. #5 Schildi, 11.07.2006
    Schildi

    Schildi Jungspund

    Dabei seit:
    31.05.2006
    Beiträge:
    24
    Zustimmungen:
    0
    Ja, so hatte ich auch angenommen das mit der hosts gearbeitet wird, nachdem ich per Ping auf dem Namen eine Antwort bekomme, müsste das aber soweit in Ordnung sein. Das am Windows Client müsste ich nochmal ausprobieren. Das heisst das man dies grundsätzlich machen sollte? Ich denk jetzt an Firmen mit zig Clients, da rennt doch kein Admin rum und ändert überall diese Datei!? Wenn der PDC läuft kann man es automatisieren, aber bis dahin? Hmm...
     
  7. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Man sollte es nicht grundsaetzlich machen, aber es ist in einem kleinen Netzwerk meist die unkomplizierteste und damit effektivste Loesung. :D
    Wenn der PDC laeuft, automatisiert sich das ganze ja von allein, wenn du die Rechner in der Domain anmeldest. Normalerweise muss der PDC dazu aber nicht ueber den Namen ansprechbar sein. Du solltest also erstmal rausbekommen, warum dein PDC die Anfragen nicht beantwortet. Hinweise darauf duerften in den Logs zu finden sein.
     
  8. #7 phrenicus, 11.07.2006
    phrenicus

    phrenicus Routinier

    Dabei seit:
    24.05.2006
    Beiträge:
    253
    Zustimmungen:
    0
    Ort:
    Tübingen, Germany
    In größeren Netzwerken _wird_ es in der Regeln per DNS gemacht, wenn es alles neue Windosen sind. In älteren Umgebungen gibt es WINS:
    Auf Deinem SAMBA-Server konfigurierst Du in /etc/samba/smb.conf:

    Code:
    [global]
    ...
    wins support = yes
    name resolve order = wins bcast
    
    Und auf dem Windows-Client (je nachdem, was für ein Windows) kann man unter den Netzwerk-Einstellungen einen WINS-Server eintragen, falls gewünscht.
    Dann siehst Du den WINS-Cache unter /var/lib/samba/wins.dat oder /var/lock/samba/wins.dat (je nach Distribution).

    Poste doch mal Deine smb.conf, vielleicht finden wir einen Fehler.

    Gruß
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 Schildi, 12.07.2006
    Zuletzt bearbeitet: 12.07.2006
    Schildi

    Schildi Jungspund

    Dabei seit:
    31.05.2006
    Beiträge:
    24
    Zustimmungen:
    0
    Das ist jetzt die letzte Konfiguration die ich probiert habe. Einfach abgetippt und noch nichts angepasst, ich habe auch die Beispielkonfiguration aus einem Samba-Buch genommen und hatte genau den gleichen Effekt.

    Code:
    # smb.conf is the main Samba configuration file. You find a full commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
    # samba-doc package is installed.
    # Date: 2006-05-02
    [global]
    	# Identifikation des Server und der Arbeitsgruppe
    	workgroup = MyGrp
    	netbios name = MyPDC
    	server string = Samba %v (PDC) @ MyPDC
    
    	# Grundeinstellungen für die einzelnen Shares.
    	# Um eine höhere Sicherheit zu gewähren,
    	# wird global ersteinmal alles verboten
    	# und in den jeweiligen Shares die Rechte dann vergeben
    	browseable = no
    	public = no
    	writeable = no
    	guest ok = no
    
    	# Die Log-Files für Samba
    	log file = /var/log.%m
    
    	# Die Definition des PDC's
    	domain master = Yes
    	prefered domain = yes
    	domain logons = Yes
    	os level = 65
    	security = user
    
    	# Logon Einstellungen für Windows
    	logon drive = Z:
    	logon path = \SAMBA_PDCprofiles\%U.pds
    	logon home = \SAMBA_PDCprofiles\%U
    	logon script = %U.bat
    	update encrypted = yes
    	password level = 4
    
    	# Die Administratoren des PDC
    	domain admin users = root
    
    	# Performance Einstellungen
    	short preserve case = yes
    	max log size = 5000
    	case sensitive = no
    	default case = lower
    	mangle case = no
    	dead time = 15
    	read raw = yes
    	write raw = yes
    	socket options = TCP_NODELAY
    	oplocks = yes
    	fake oplocks = no
    	debug level = 2
    	preserve case = yes
    	getwd cache = yes
    
    	# Drucker Einstellungen
    	printing = cups
    	load printers = yes
    	add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
    	guest ok = no
    	local master = Yes
    	preferred master = Yes
    	read only = Yes
    	guest ok = no
    	read only = Yes
    
    [homes]
    	path = /home/%u
    	comment = Benutzer-Homeverzeichnisse
    	writeable = yes
    
    [netlogon]
    	path = /home/netlogon
    	browseable = no
    	writeable = no
    	comment = NetLogON
    	read only = Yes
    	write list = root
    	read only = Yes
    
    [profiles]
    	path = /home/profiles
    	browseable = no
    	writeable = yes
    	comment = Benutzerprofile
    
    [public]
    	path = /home/public
    	browseable = yes
    	writeable = yes
    	guest ok = yes
    	comment = Öffentlicher Ordner
     
    
    Ich bin dann immer etwas vorsichtig wenn ich so etwas aus einem Buch abschreibe und dann klappt es nicht, ich fang dann ungern das "rumprobieren" an. Tippfehler finde ich aber auch keinen. :/

    Edt: Ach ja, Client ist ein Windows 2000 wo parallel auf XP läuft, in der Hinsicht sollte es von den beiden keine Probleme geben.
     
  11. #9 phrenicus, 12.07.2006
    phrenicus

    phrenicus Routinier

    Dabei seit:
    24.05.2006
    Beiträge:
    253
    Zustimmungen:
    0
    Ort:
    Tübingen, Germany
    So,

    es gibt ein Programm namens testparm, mit dem man die Konfiguration auf Fehler testen kann. In Deinem Fall sagt das:

    preferred domain gibt es nicht und gab es meines Wissens auch nie.
    domain admin users gab es früher mal. Hast Du ein so altes SAMBA?
    Dasselbe gilt für mangle case.

    Außerdem schreibst Du in der [global]-Sektion:

    Zum einen ist public=no und guest ok=no dasselbe. Zum anderen sind alle vier Einstellungen für Shares und nicht für [global].

    Des weiteren hast Du so einiges doppelt drin.

    Das Logfile nach /var/log.%m zu packen ist auch nicht klug. Setz das doch nach /var/log/samba/log.%m.

    Räum das mal bitte auf, dass man als Mensch was lesen kann. Dann sehen wir weiter.

    Gruß
     
Thema:

Auf PDC umstricken