Anmeldeporblem-Debian

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Katze93EMO, 20.04.2008.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. #1 Katze93EMO, 20.04.2008
    Katze93EMO

    Katze93EMO GESPERRT!

    Dabei seit:
    05.02.2008
    Beiträge:
    83
    Zustimmungen:
    0
    Ort:
    /dev/null und /home/kevin
    So, da mein letzter Thread geschlossen worde, mach ich nen neuen auf^^
    Und jemand da, der mir helfen würde?^^

    (EE) AIGLX: Screen 0 is not DRI capable
    steht im xorg.0.log...
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 bitmuncher, 20.04.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Wird das DRI-Modul und das GLX-Modul in der xorg.conf geladen?
     
  4. #3 Katze93EMO, 20.04.2008
    Katze93EMO

    Katze93EMO GESPERRT!

    Dabei seit:
    05.02.2008
    Beiträge:
    83
    Zustimmungen:
    0
    Ort:
    /dev/null und /home/kevin
    Wie finde ich das heraus?
     
  5. #4 bitmuncher, 20.04.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    In deiner xorg.conf ist eine Abschnitt, der mit 'Section "Module"' beginnt. Dort müssten die Zeilen 'Load "glx"' und 'Load "dri"' drin sein.
     
  6. #5 Katze93EMO, 20.04.2008
    Katze93EMO

    Katze93EMO GESPERRT!

    Dabei seit:
    05.02.2008
    Beiträge:
    83
    Zustimmungen:
    0
    Ort:
    /dev/null und /home/kevin
    ich finde es nicht, vllt überlesen?
    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"de"
    	Option		"XkbVariant"	"nodeadkeys"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"		"/dev/input/mice"
    	Option		"Protocol"		"ImPS/2"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Synaptics Touchpad"
    	Driver		"synaptics"
    	Option		"SendCoreEvents"	"true"
    	Option		"Device"		"/dev/psaux"
    	Option		"Protocol"		"auto-dev"
    	Option		"HorizScrollDelta"	"0"
    EndSection
    
    Section "Device"
    	Identifier	"nVidia Corporation GeForce Go 7700"
    	Driver		"nv"
    	BusID		"PCI:1:0:0"
    EndSection
    
    Section "Monitor"
    	Identifier	"Standardbildschirm"
    	Option		"DPMS"
    	HorizSync	28-64
    	VertRefresh	43-60
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"nVidia Corporation GeForce Go 7700"
    	Monitor		"Standardbildschirm"
    	DefaultDepth	16
    	SubSection "Display"
    		Modes		"1280x800"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Configured Mouse"
    	InputDevice	"Synaptics Touchpad"
    EndSection
    
     
  7. #6 bitmuncher, 20.04.2008
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.171
    Zustimmungen:
    0
    Der Abschnitt fehlt bei dir offenbar vollständig. In dem Fall solltest du ihn einfach hinzufügen.

    Code:
    Section "Module"
            Load            "glx"
    EndSection
    
    Und natürlich den X-Server neustarten. Evtl. ist es auch notwendig die Section "Device" noch zu erweitern:

    Code:
    Section "Device"
    	Identifier	"nVidia Corporation GeForce Go 7700"
    	Driver		"nvidia"
    	BusID		"PCI:1:0:0"   Option      "RenderAccel" "1"
            Option      "AllowGLXWithComposite" "1"
            Option      "backingstore" "1"
            Option      "TripleBuffer" "1"
            Option      "NoLogo" "1"
            Option      "NvAGP" "3"
    EndSection
    
    Dazu musst du dann allerdings den Treiber von NVidia verwenden und nicht den OpenSource-Treiber. Daher der andere Driver-Name. Such einfach mal nach 'nvidia linux howto' bei Google. Da finden sich genug Anleitungen, wie du den Treiber korrekt einrichtest.
     
  8. #7 Katze93EMO, 20.04.2008
    Katze93EMO

    Katze93EMO GESPERRT!

    Dabei seit:
    05.02.2008
    Beiträge:
    83
    Zustimmungen:
    0
    Ort:
    /dev/null und /home/kevin
    [qoute]Und natürlich den X-Server neustarten.[/qoute]
    Hab ich schon gesagt, das ich mich nicht anmelden kann?
     
  9. #8 sim4000, 20.04.2008
    sim4000

    sim4000 Lebende Foren Legende

    Dabei seit:
    12.04.2006
    Beiträge:
    1.933
    Zustimmungen:
    0
    Ort:
    In meinem Zimmer
    Mach mal die Tastenkombination
    Code:
    Strg + Alt + F1
    Da haste n Terminal, wo man alles wunderbar machen kann.
     
  10. #9 Goodspeed, 20.04.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Die Fehlermeldung hat nichts mit Deinem im alten Thread zusammengewürfelten Problem zu tun.
    Da der Login-Manager (GDM, KDM, was auch immer Du installiert hast) funktioniert, hat das nix mit dem X-Server zu tun.

    Und da Du immer noch nicht erzählt hast, was a) als Session angeboten wird und wie Du b) Gnome installiert hast ... wird Dir mit hoher Wahrscheinlichkeit auch keiner weiter helfen können ...
     
  11. #10 Katze93EMO, 21.04.2008
    Zuletzt bearbeitet: 21.04.2008
    Katze93EMO

    Katze93EMO GESPERRT!

    Dabei seit:
    05.02.2008
    Beiträge:
    83
    Zustimmungen:
    0
    Ort:
    /dev/null und /home/kevin
    also nochmal...
    Gnome-Abgesichert, Terminal-Abgesichert, X-Client, vorherige Sitzung, und noch anderer unwichiger müll(wenn ich sag, es ist unwichtig, dann ist es das auch:D)
    Na ich habs garned installiert, das hat es doch während der debby.installation gemacht...
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Ich machs mir mal wieder schwer, ich les deine ICQ nummer aus Quelltext aus, obwohl sie in deinen Profil steht, wie ich gerade merk^^
     
  12. #11 Goodspeed, 21.04.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Na dann schau mal, ob metacity installiert ist.
    Was haste denn vor Deinem "mysteriösen" Neustart gemacht?
    Installier z.B mal fluxbox und schau, ob der als Session funktioniert ...
     
  13. #12 Katze93EMO, 21.04.2008
    Katze93EMO

    Katze93EMO GESPERRT!

    Dabei seit:
    05.02.2008
    Beiträge:
    83
    Zustimmungen:
    0
    Ort:
    /dev/null und /home/kevin
    Na, nimmst du mich mal im icq an?
    [root@localhost guest]# chmod 777 /media/hd/home/kevin/.metacity/*

    Da gibts einen ordner session...
    Denke mal, das es installiert ist... Wie kann ich das heruasfinden? Von ner live cd aus? mit dpkg -i ?
    Vor den Neustart... apt-get dist-upgrade und verschiedene Pakete installiert, und im /home Verzeichniss einige unsichtbare Dateien ausgetauscht(das kann es aba ned gewesen sein, da ich einen anderen user auch schon probiert habe...)
    apt-get install fluxbox? Nur wie?
    Mit Strg+Alt,etc. vor der anmeldung, habe ich kein internet, also geht auch kein apt-get...
    So, ich mach dann mal langsam los, muss 6Uhr raus,---schule...
     
  14. #13 Goodspeed, 21.04.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    k.A. was das mir sagen soll ..
    Hab ich von einem Ordner gesprochen?
    www.debiananwenderhandbuch.de
    z.B.?
    siehe oben
    Dein Netzwerk hat nichts mit der Anmeldung als User am System zu tun ...
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 Factory, 21.04.2008
    Factory

    Factory Routinier

    Dabei seit:
    21.12.2004
    Beiträge:
    445
    Zustimmungen:
    0
    Ort:
    Bochum - NRW
    ehm...

    Möchte nur mal meine meinung eusern hoffe :D das es ok ist sonst einfach beitrag killen.

    Also A. wenn man debian installierst ist X eigentlich perfekt eingestellt.
    B. möchte man volles 3D haben kann man die nvidia packete installieren und in der xorg.conf das "nv" gegen "nvidia" tauschen zack X läuft des weiteren.

    und würd ich einfach sagen ab in die bash und mal fix denn x neu installieren :brav::) mit dpkg --reconfigure x-server soweit ichs noch weiss.
    Liegt daran :D das letzte mal wo ich x neu machen musst ist jahre her.

    Ja ^^ das wars von mir soweit...


    MfG
     
  17. #15 Goodspeed, 21.04.2008
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    @Factory: Ganzen Thread gelesen? X funktioniert ... es kommt ja der Login-Manager.
     
Thema:

Anmeldeporblem-Debian

Status des Themas:
Es sind keine weiteren Antworten möglich.