Umlaute

tiptel170

Tripel-As
Beiträge
166
Hallo,

mein samba-server hat folgende problematik:

Unter windows wenn ich eine datei speicher mit "ä" oder "ö" ..., dann wird dies auch im explorer korrekt dargestellt.

Schaue ich dann auf die festplatte von meinem server, dann sind die umlaute mit fragezeichen ersetzt worden.

Wenn ich dann auf das freigebene nfs-verzeichniss darauf zugreifen möchte mit der datei mit den umlauften, dann sind die auch mit fragezeichen umbenannt.

Lege ich auf meinem server eine datei an mit einem sonderzeichen, dann wird dies auf dem NFS-Server korrekt angezeigt, auf dem samba-server, wo ich dann mit dem windows darauf zugreifen möchte, dann ist die datei mit "wirren" zeichen benannt worden.

Hat da jemand einen lösungsvorschlag?

Hier die smb.conf:
Code:
# Umlaute darstellen 06.02.2010
        unicode = yes
        display charset = ISO-8859-15
    #   dos charset = 850
        unix charset = CP850
    # ISO-8859-15
        character set = ISO8859-15
        client code page = 850

Samba version: samba-3.4.5

Gruss tiptel170
.
.
.
EDIT (autom. Beitragszusammenführung) :
.

Gelöst:

Code:
# Umlaute darstellen 06.02.2010
        unicode = yes
        display charset = ISO-8859-15
    #   dos charset = 850
        unix charset = CP850
    # ISO-8859-15
        character set = ISO8859-15
        client code page = 850

Alles einkommentieren:

Code:
# Umlaute darstellen 06.02.2010
#        unicode = yes
#       display charset = ISO-8859-15
    #   dos charset = 850
#        unix charset = CP850
    # ISO-8859-15
#        character set = ISO8859-15
#       client code page = 850

Jetzt passt es mit den sonderzeichen.
 
Zuletzt bearbeitet:

Ähnliche Themen

Zugriff Ubuntu 16.04. auf Freigabe 18.04. LTS nicht möglich

Samba 4 Gast Zugang unter Ubuntu funktioniert nicht

Windows clients können nicht mehr auf lange laufendes System zugreifen

Server will nicht in die Domain

Falsche Rechte gesetzt beim Anlegen von Ordnern via Samba-Client

Sucheingaben

kodi nfs charset

Oben