Teledat 300 PCI + Suse 8.1

Langdar

Böhser Onkel
Beiträge
15
Hallo zusammen,
dies hier ist mein erster Beitrag und gleich hab ich ein Problem.
Da das seinerzeit ziemlich günstig war, habe ich mir das interne DSL-Modem von Eicon geholt. Die Karte ist baugleich mit der Teledat 300 PCI von der Telekom.
Dort auf der Downloadseite kann man sich auch einen Linux-Treiber downloaden, der jedoch nur für Suse 8.0 sowie Redhat 7.2 und 7.3 vorgesehen sind. Die höchste Treiberversion dabei ist 2.4.18. Suse 8.1 hat nun aber den Kernel 2.4.19 und auch Gentoo 1.4 hat diesen Kernel.
Meine Frage nun:
Ist es irgendwie möglich, die Module, die für den älteren Kernl vorgesehen sind, auch irgendwie unter dem 2.4.19-er Kernel zu verwenden. Neukompilieren geht leider nicht, es gibt keinen Quellcode. Weiß da vielleicht jemand eine Lösung?
Dirk
 

rygar

Routinier
Moderator
Beiträge
335
Hi,

du kannst versuchen das Modul mit dem Befehl insmod zu laden :

insmod -f modul

Damit zwingst du insmod das Modul obwohl es fuer einen anderen Kernel ist zu laden.

Das kann natuerlich auch zum Absturz des Rechners führen.... Ich würde es trotzdem mal versuchen.

mfG,

Rygar
 

Langdar

Böhser Onkel
Beiträge
15
Danke, Gott war das schnell :-)

Danke für den Tipp, werds heute abend gleich mal probieren. Doch jetzt noch eine Zusatzfrage:
in dem Archiv sind halt die Module in Verzeichnissen für Suse und Redhat. Kann es sein, dass die nun irgendwelche Distributionsspezifischen Besonderheiten aufweisen? Oder besser gesagt, ist es vielleicht besser, das Redhat-Modul zu nehmen, oder lieber Suse?
Dirk
 

rygar

Routinier
Moderator
Beiträge
335
Ich denke, Du solltest das SuSE Modul nehmen.

Das Problem ist, die Distributionen setzen nicht die Original Kernel ein, sondern bauen noch Patches ein....

Die sind natuerlich bei RedHat und SuSE unterschiedlich.

Damit du dann keine Fehlermeldung bei "normalen" Laden mit modprobe bekommst baut Eicon dann 2 Module.

mfG,

Rygar
 
Oben