System freezt nach Installation von nouveau beim booten

Diskutiere System freezt nach Installation von nouveau beim booten im Anwendungen Forum im Bereich Linux/Unix Allgemein; Hallo, ich weiss, dass Crossposting nicht sonderlich erwuenscht ist, jedoch konnte man mir bisher weder im Arch Linux Forum, noch in den...

  1. vlast

    vlast Jungspund

    Dabei seit:
    07.07.2013
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo,

    ich weiss, dass Crossposting nicht sonderlich erwuenscht ist, jedoch konnte man mir bisher weder im Arch Linux Forum, noch in den linuxforen bei der Lösung meines Problems helfen, deshalb wende ich mich jetzt nun an euch.

    Pack die Links im Anschluss unten dran, damit man weiss, was bisher vorgeschlagen/versucht wurde.

    Also, das Problem ist wie folgt:

    (Habe den Post aus dem Arch Linux Forum kopiert, ist ja nicht nötig, dass alles nochmal genau so geschrieben wird.)

    ich bin relativ neu bei Arch Linux, nutze es seit ein paar Wochen und bin eigentlich sehr zufrieden damit. Habe mittlerweile PlayonLinux/wine am laufen und ein paar Spiele funktionieren super. Jedoch ist mir immer wieder folgender Fehler in der Konsole aufgefallen:

    err:winediag:xrandr12_init_modes Broken NVIDIA RandR detected, falling back to RandR 1.0. Please consider using the Nouveau driver instead.

    Habe bisher den proprietaeren Nvidia Treiber unter KDE am laufen (meine Grafikkarten ist die GeForce G9300M und laut Wiki wird ja fuer aeltere HW ohnehin der OpenSource Treiber empfohlen).

    Habe also per pacman xf86-video-nouveau nouveau-dri installiert, die /etc/mkinitcpio.conf mit nano angepasst (MODULE "nouveau") und anschliessend mkinitcpio -g /boot/initramfs-linux.img ausgeführt.

    Außerdem habe ich die Datei /etc/X11/xorg.conf.d/20-nouevau.conf angepasst, gefolgt vom reboot.

    Allerdings bleibt Arch beim booten nach dem Punkt [ OK ] Reached target graphical Interface stehen. Es tut sich nichts mehr (eigentlich nutze ich GDM als LoginManager). Ich kann zwar per CTRL+ALT+F2 in die Konsole wechseln (habe dann nouveau wiede entfernt und nvidia installiert) aber mit nouveau startet der LM erstmal nicht. Sobald der proprietaere Treiber wieder drauf ist funktioniert alles wie gehabt.

    Arch Linux Forum:
    https://bbs.archlinux.de/viewtopic.php?id=25423

    linuxforen.de
    http://www.linuxforen.de/forums/showthread.php?t=276178


    Ich hoffe, jemand kann mir helfen!


    Vielen Dank und MfG!
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 schwedenmann, 12.01.2014
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.656
    Zustimmungen:
    3
    Ort:
    Wegberg
    Hallo

    was sagt denn lsmod ?


    Hattest du vorher, als du noch nvidia hattest, nouveau ev. geblacklistet ?


    mfg
    schwedenmann

    P.S.
    Normalerweise benötigst du keinw 20-nouveau.conf, ist jedenfalls bei Debian nicht nötig.
     
  4. #3 marcellus, 16.01.2014
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Um den nouveau treiber zu verwenden musst du ansich nur folgendes machen:

    du stellst das kernel modul und den user space treiber zur verfügung, also kernel modul + xf86-video-nouveau und stellst sicher, dass xorg den treiber auch verwendet.

    Schau ob das kernel modul geladen ist, das kannst du überprüfen mit:
    Code:
    lsmod | grep nouveau
    wenn das passt dass für deine grafikkarte der nouveau treiber verwendet wird und nicht der proprietäre, was sagt denn:
    Code:
    grep Driver /etc/X11/xorg.conf.d/*
    sollte keine Rückmeldung kommen passt es auch, dann verwendet xorg was gerade da ist, Hauptsache es kommt nicht:
    Code:
    Driver "nvidia"
    Wenn das alles passt sollte xorg zumindest versuchen den nouveau treiber zu verwenden, wenn es dann noch immer nicht geht tipp einfach in dein terminal
    Code:
    startx
    ein und schau was du für eine Fehlermeldung bekommst, dann können wir weiter schauen.
     
Thema:

System freezt nach Installation von nouveau beim booten

Die Seite wird geladen...

System freezt nach Installation von nouveau beim booten - Ähnliche Themen

  1. xmms freezt System ein

    xmms freezt System ein: Hallo,... folgendes Problem,...ich muss jedesmal um xmms nutzen zu können, im kmixer das Modul IEC958 5V unter "Advanced" zu finden,...
  2. Linux "vergisst" Dateisystem?

    Linux "vergisst" Dateisystem?: Hallo zusammen! Aufgrund des von mir hier beschriebenen Problems habe ich nun die halbe Nacht "durchgearbeitet", da ein komplett neues Konzept...
  3. Problem mit Windows auf Ordner auf dem Linuxsystem zuzugreifen

    Problem mit Windows auf Ordner auf dem Linuxsystem zuzugreifen: Ich mache gerade meine ersten Schritte mit Linux und würde gerne auf Dateien meines Linuxsystems auch mit Windows zugreifen, ich bin am...
  4. Systempartition um den Speicherplatz der zweiten Disk erweitern

    Systempartition um den Speicherplatz der zweiten Disk erweitern: Guten Tag liebe Leute Ich habe einen virtuellen Server mit 2 Disk a je 25GB. Nun möchte ich, das meine Hauptpartition um diese zusätzlichen 25GB...
  5. Debian VM Klonen und parallel betreiben? Systemanpassungen

    Debian VM Klonen und parallel betreiben? Systemanpassungen: Hallo, ich habe vor eine Debian Maschine als Prototyp aufzusetzen... (als vSphere VM).... Diese Maschine will ich dann x-mal klonen und in div....