SuSE 8.2 und Asus A7N8X mit onboard LAN

Dirk

Mitglied
Beiträge
35
Hallo!
Ich habe das Asus-Board A7N8X mit nforce2 Chipsatz. Wie bekomme ich das Onboard LAN zum Laufen unter Suse 8.2? Yast erkennt es richtig und will auch das richtige Module (nvnet) benutzen. Doch leider ist das wohl nicht mit beim Suse-Kernel 2.4.20 dabei. Auf der nvidia-Seite gibt es dafür wohl rpm's, allerdings sind die für den Kernel 2.4.19.
Also habe ich versucht, mir 2.4.20 selber zu kompilieren um dann die nforce-Treiber aus der tar.gz von nvidia nachzuinstallieren.
Doch dummerweise bricht das Kompilieren bei "make bzImage" ab.
Jetzt weiss ich nicht mehr weiter, was ich machen soll!
Könnt ihr mir helfen?

Mfg Dirk
 

merc

Foren As
Beiträge
98
Welche fehlermeldung gibt er denn genau aus?
 

Dirk

Mitglied
Beiträge
35
Habe gerade noch versucht, den Kernel 2.4.19 von Suse zu installieren, doch der verursacht Konflikte mit dem 2.4.20er.
Ich sehe als einzige Rettungsmöglichkeit jetzt einen selbstkompilierten Kernel. Da der aber ja mit Fehlern abbricht, poste ich hier noch mal die Fehlermeldung:
ld -m elf_i386 -r -o ide-probe-mod.o ide-probe.o ide-geometry.o
gcc -D__KERNEL__ -I/usr/src/linux-2.4.20/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=athlon -nostdinc -iwithprefix include -DKBUILD_BASENAME=ide_cd -c -o ide-cd.o ide-cd.c
In file included from ide-cd.c:318:
ide-cd.h:440: error: long, short, signed or unsigned used invalidly for `slot_tablelen'
Da ich nicht glaube, dass ein Fehler im Kernel-Code ist, schätze ich, dass das wohl mit gcc 3.3 zu tun hat.
Weiss da jemand Rat?

Danke im voraus, Dirk
 

Dirk

Mitglied
Beiträge
35
Genau die Treiber habe ich auch ausprobiert. Die RPM's, die NVidia dort zur Verfügung stellt, sind für Kernel < 2.4.20.
Die Treiber als tar.gz-Version zum Selbstkompilieren habe ich sonst unter Gentoo benutzt, doch jetzt in meiner Suse-Installation lässt sich der Kernel nicht kompilieren (siehe mein vorheriges Posting). Nur woran liegt das? Ich hab mir übrigens die Kernel-Sourcen direkt von Kernel.org gezogen. Müssen die vielleicht für Suse gepacht werden? Oder gibt es Probleme mit gcc 3.3? Soweit ich weiss, ist das ein Pre-Release.

Mfg Dirk
 

devilz

Pro*phet
Beiträge
12.245
Boah k.A. !

Ich hab mit meinen Kernel unter Gentoo noch NIE probleme gehabt :)
 

Dirk

Mitglied
Beiträge
35
Ich hatte unter Gentoo auch keine Probleme, doch als ich den X-Server von 4.2 auf 4.3 "geupdated" habe, liefe meine Graka nicht mehr (Radeon 9500). Nach ner XFree 4.2 neuinstallation liefs immer noch nicht wieder, dann hab ich Gentoo runtergeschmissen (auch aus Ungeduld, kompilieren dauert einfach zu lange :-) ).
Irgendwie bin ich jetzt inner Zwickmühle, unter Suse und Mandrake funzt mein LAN nicht, unter Gentoo meine Graka nicht :-(
 

MTS

Kaiser
Beiträge
1.242
du sagst du wilslt den kernel 2.4.20 selbst kompilieren. Also ich hatte früher auch mal suse und in Kombination mit den Sources von kernel.org hatte ich auch immer richtig kranke probleme ;)
nen kumpel hat das auch nicht so wirklich hinbekommen.
Also erstmal solltest du unbedingt die Suse sources von dem 2.4.20 ziehen (wenn du das schon gemacht hast ignorier das )

Ziemlich wichtig dabei is eingetlich dass du standardoptionen von suse alle so lässt. aktivier einfach die sachen die du noch dazu haben willst.
Woran das genau liegt kann ich dir leider nicht sagen ... aber ich sag immer ... ausschlussverfahren ...
fehler in ide_cd ... also hau erstmal das entsprechende dingen raus und schau was dann passiert.
kommen dann immer wieder fehler isses wohl der kompiler oder so ..

Ich wüsste aber auch keinen Grund warum die nforce SOURCES von der nvidia seite nicht gehen sollten ... haste die schon probiert??
 

Dirk

Mitglied
Beiträge
35
Ja, die nforce-sources sollten wohl funktionieren, sobald ich es schaffe, einen Kernel zu kompilieren:-)
Und das wird hoffentlich klappen sobald ich die Suse-Kernel-Sources habe. Habe nämlich nur die ersten beiden Suse-Cds, die anderen sind noch am downloaden...
 

devilz

Pro*phet
Beiträge
12.245
Original geschrieben von Dirk
Ja, die nforce-sources sollten wohl funktionieren, sobald ich es schaffe, einen Kernel zu kompilieren:-)
Und das wird hoffentlich klappen sobald ich die Suse-Kernel-Sources habe. Habe nämlich nur die ersten beiden Suse-Cds, die anderen sind noch am downloaden...


... das letzte Wort hab ich jetzt mal dezent übersehen !!!
 

MTS

Kaiser
Beiträge
1.242
Also einmal : Die Suse kernel sources findest du auf deren ftp, da brauchste die cds nicht für.

und zweitens sollten die nvidia sources meiner meinung nach sources für module sein. da kannste dir das mit dem kernel sparen, die müsste man auch so installieren können. Du trägst die dann nur passend so ein, dass sie bei jedem start geladen werden.
 

Dirk

Mitglied
Beiträge
35
Ja, die RPM's, die Nvidia anbietet, wurden für 2.4.19 kompiliert, daher muss ich mir die wohl selber kompilieren. Ich habe irgendwie in Erinnerung, dass die Suse-Kernel-SRPMS ganz miese dependencies haben, daher warte ich lieber drauf, bis ich die entsprechenden Suse-CDs habe und alles problemlos von Yast auflösen lassen kann. Es fehlen eh nur noch ein paar KB, sollte also im Laufe des Abends fertig sein...
 

brainache

Ubi libertas, ibi patria!
Beiträge
80
... das letzte Wort hab ich jetzt mal dezent übersehen !!!


Wieso denn das?? Zwar kann man die SUSE CDs normalerweise nicht aus dem internet downloaden, aber immerhin lässt sich suse komplett über einen router per ftp installieren, und generell ist es doch erlaubt die suse cds weiterzugeben oder etwa nicht?

Wer kann hier mal die rechtliche Lage klären???
 

Dirk

Mitglied
Beiträge
35
Ja, Suse darf man frei kopieren, für Open Source Software bzw. Software, die unter der GPL steht, darf man nämlich kein Geld nehmen, nur z.B. für die Datenträger.
Und jetzt sind die Suse-CDs fertig, ich werde jetzt mal austesten, ob's jetzt funktioniert...
 

MTS

Kaiser
Beiträge
1.242
hmm. ja mach du mal, aber ich rede von ganz NORMALEN Sources.
nicht diese suse src rpm sch****

da kannst du dir doch auch nen tar.gz archiv laden. das funktioniert bestimmt!!!
 

Dirk

Mitglied
Beiträge
35
Ich glaube, ich fange gleich an zu weinen, dass klappt immer noch nicht:

linux:~/nforce # insmod nvnet
Using /lib/modules/2.4.20-4GB-athlon/kernel/drivers/net/nvnet.o
/lib/modules/2.4.20-4GB-athlon/kernel/drivers/net/nvnet.o: kernel-module version mismatch
/lib/modules/2.4.20-4GB-athlon/kernel/drivers/net/nvnet.o was compiled for kernel version 2.4.20-athlon
while this kernel is version 2.4.20-4GB-athlon.
linux:~/nforce #


Obwohl ich die Suse-Kernel-Sourcen installiert habe, meckert der immer noch. Kann ich es irgendwie hinkriegen, dass die Kernel-Sourcen wie bei 2.4.20-4GB-athlon sind? Anscheinend gibt es da Unterschiede. Er hat übrigens bei "make bzImage" beim Kernel kompilieren abgebrochen, gleich in der ersten Datei, weil ihm wohl irgendwelche Funktionen-Deklarationen fehlen. Sonst hätte ich einen neuen Kernel booten können und dafür die nvidia - Module kompilieren können.
Irgendetwas läuft hier grandios falsch! Weiß jemand noch einen Rat?

Wenn das so weiter geht, wechsel ich wieder zu Gentoo...

Mfg Dirk
 

MTS

Kaiser
Beiträge
1.242
also erstens ... haste das mit den tar.gz sources schon probiert?? wenn nicht --> sofort!!


2.) hast du diesesn neuen 4GB-athlon kernel jetzt selbst kompiliert??? wenn ja ... einfach die $GB funktion ausschalten, brauchste eh nicht.


3) Zu gentoo würde ICH ja so oder so wechselns *ggg*

wenn alle stricke reißen:
bitte schreib nochmal genau was du jetzt schon alles geupdatest hast, wovon du welche sources hast etc.
ich hab den Überblick verloren....
das kriegen wir schon hin .. habe meine halbes Leben lang kernel kompiliert :P
 

Dirk

Mitglied
Beiträge
35
1) Gentoo ist zwar wohl ganz cool, aber das ewige kompilieren dauert mir zu lange, und mir sind keine Geschwindigkeitsvorteile aufgefallen!
2) Der 4GB Kernel kommt von SuSE, der ohne 4GB war von mir,
besser gesagt, ich habe die Sourcen vom SuSE Kernel einfach installiert und dann die NVidia Module kompiliert. Und beim insmod'den, sagt insmod, dass die Module für 2.4.20 kompiliert wurden, 2.4.20-4GB aber sein sollte.


Hier nochmal der Kram, den ich ausprobiert habe:
- rpm von nvidia mit vorkompilierten Modulen, leider geht's nicht, weil die für 2.4.19 sind.

- versucht, Kernel von kernel.org selber zu kompilieren, gcc hat aber mit Fehlern abgebrochen, wobei ich glaube, dass das an gcc 3.3 liegt, ich hab nämlich unter anderen Distros 2.4.20 zum Laufen gekriegt (Fehlermeldungen irgendwo weiter oben in meinen früheren Postings)

- tar.gz von nvidia versucht zu kompilieren, benötigt aber die Kernelsourcen. daher:

- nun Source-Kernel-SRPMs installiert, versucht diese zu kompilieren, bricht aber auch ab mit "missing prototype" Fehlern, was wohl drauf hindeutet, dass irgendwas mit dem Makefile nicht stimmt, oder irgendwelche includes nicht stimmen

- dann versucht, nochmal die tar.gz von nvidia zu kompilieren. Das klappt nun auch. Doch die Module zu laden, scheitert daran, dass ich noch den ursprünglichen Suse-Kernel draufhabe, der nicht direkt aus den Kernel-Sourcen mit der gleichen .config kompiliert wurde. insmod merkt das, und will die Module nicht laden. Fehlermeldung siehe mein vorheriges Posting.

Hoffe, es ist verständlich was ich hier hingestümpert habe :-)

Mfg Dirk
 

MTS

Kaiser
Beiträge
1.242
nvidia braucht also die kernelsources :
und natürlich auch welche die zu deinem kernel passen
1) starte yast, installier die kernelsources von da, rekompiliere die tar.gz sache
2) geht das nicht. lade die PASSENDEN suse sources, mit der versionsnummer deines kernel ausm inet. musst die ja nur installieren. den kernel haste ja scho drauf

3) Unsicher / Unsauber: lade die passende kernelversion von kernel.org ... packe die nach /usr/src ändere den linux - link auf dieses verzeichnis. versuche die nvidia sources zu kompilieren
 

Dirk

Mitglied
Beiträge
35
Mit den Suse-Kernel-Sourcen funzt das ja auch nicht. Die kompilieren nicht durch. Und die Module müssen gegen den Kernel gelinkt werden, bei dem ich sie laden möchte. Doch es kompiliert leider kein Kernel durch! Immer irgendwelche blöden Compiler-Fehler.
 

Ähnliche Themen

[openSuse10.2] SATA mal wieder...

Sucheingaben

SuSe8.2. a7n8x edeluxe

Neueste Themen

Oben