Space escape funktioniert nicht im dialog

satriani

SysLion
Beiträge
40
Hallo liebe Leute,

wie im Titel bereits erwähnt, werden die Leerzeichen weder mit Backslashs noch sonstige Tricks mit " oder ' escaped
So sieht der Ausschnitt aus dem Code aus:
Bash:
....
dialog --stdout --backtitle "Settings" \
    --checklist "Please select" 0 0 0 \
    $([ "$(/usr/local/sbin/zpool get all zroot | grep 'encryption')" ] && echo "UseZFSencrypt "Enable\ ZFS\ Encryption\ feature" on") \
....
Das ist das falsche Ergebnis
1608569953599.png
Und so sollte es aussehen nur halt mit den Leerzeichen statt Unterstrich
1608569883554.png

Danke für eure Vorschläge im Voraus.
 

Ähnliche Themen

Falsche Rechte gesetzt beim Anlegen von Ordnern via Samba-Client

Squid nur zum maskieren der eigenen IP, nicht für Webserver auf port 80

Pure-ftpd mit Postgre

Oben