proFTPd Softlink geht nicht

Diskutiere proFTPd Softlink geht nicht im Anwendungen Forum im Bereich Linux/Unix Allgemein; Hallo, ich habe folende proftpd config: <Global> RequireValidShell off </Global> DefaultRoot ~ <Limit LOGIN> DenyGroup !ftpuser...

  1. #1 SeriousPat, 28.07.2011
    SeriousPat

    SeriousPat Mitglied

    Dabei seit:
    15.05.2009
    Beiträge:
    35
    Zustimmungen:
    0
    Ort:
    Bonn
    Hallo, ich habe folende proftpd config:

    Code:
    <Global>
    RequireValidShell off
    </Global>
    
    DefaultRoot ~
    
    <Limit LOGIN>
    DenyGroup !ftpuser
    </Limit>
    
    Funktioniert soweit wunderbar.
    Jetzt habe ich in Home Verzeichnis des entsprechenden Users ein softlink nach "/var/www/test/" angelegt. im system funktioniert er. über ftp wird er angezeigt, aber wenn ich drauf gehe sagt der ftp client " No such file or directory"

    woran liegts?
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 kartoffel200, 29.07.2011
    kartoffel200

    kartoffel200 AMD Fanboy Since 2003

    Dabei seit:
    12.03.2007
    Beiträge:
    938
    Zustimmungen:
    0
    Ort:
    L wie localhost
    Poste doch bitte Verlinkung ( ausgabe ls ) sowie die Berechtigungen.
     
  4. foexle

    foexle Kaiser

    Dabei seit:
    02.05.2007
    Beiträge:
    1.104
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    /var/www/test gehört dem loginuser ?
    falls nicht, ist r und x für other gesetzt?
     
  5. #4 floyd62, 29.07.2011
    floyd62

    floyd62 Routinier

    Dabei seit:
    01.05.2007
    Beiträge:
    323
    Zustimmungen:
    0
    So wie ich das sehe, packst du den User mit der Option "DefaultRoot ~" doch in ein chroot-Jail unterhalb seines Home-Directories. Von da aus kann er dann nicht mehr auf /var/www/test zugreifen, weil das System innerhalb des Jails damit dann wohl versucht, effektiv auf /home/xyz/var/www/test zuzugreifen - das würde zumindest die erwähnte Fehlermeldung "No such file or directory" erklären.

    Ich würde vorschlagen, zum Testen die "DefaultRoot"-Option temporär abzuschalten. Sollte der Zugriff auf /var/www/test dann funktionieren, kannst du ja noch versuchen, anstelle eines Softlinks einen bind-mount zu verwenden - habe allerdings keine Ahnung, ob das besser läuft ;-) ...

    Wenn das Ziel sein sollte, z.B. dem Owner eines vhosts auf diese Weise Zugriff auf seine Daten zu ermöglichen, könnte man das Ganze evtl. auch umgekehrt angehen, d.h. die Daten effektiv im Home-Directory des Users anlegen, und dann von /var/www aus Softlinks anzulegen (müsste man dann natürlich z.B. mit FollowSymLinks in der Apache-Config auch scharf schalten).

    Gruss, A.
     
Thema:

proFTPd Softlink geht nicht

Die Seite wird geladen...

proFTPd Softlink geht nicht - Ähnliche Themen

  1. proftpd Verwaltung

    proftpd Verwaltung: Mahlzeit, ich finde leider keine Lösung ich hoffe Ihr habt eine Idee. Ich habe ca. 30 proftpd Server. Bis jetzt läuft die Authentifizierung...
  2. Proftpd/TLS Probleme

    Proftpd/TLS Probleme: Tach Leute, bitte bedenkt, das ich Anfänger bin und gerade ein wenig Linux Erfahrung sammeln mag. Ich habe mir proftpd auf dem Server...
  3. Proftpd und FritzBox 7270?

    Proftpd und FritzBox 7270?: Hallo Community, ich habe proftpd auf Debian 5.0 installiert und soweit auch configuriert. Mittels FileZilla kann ich per sftp auch auf den...
  4. proftpd auf 1 nic lauschen lassen?

    proftpd auf 1 nic lauschen lassen?: Hallo zusammen :-) Wie stell ich das an das proftpd nur auf einer nic lauscht? Folgende konfiguration: 2 nics mit 2 verschiedenen ip´s...
  5. Apache und ProFTPD auf FAT Dateisystem

    Apache und ProFTPD auf FAT Dateisystem: Hi, ich suche eine Lösung und fasse mich mal kurz ohne lange Begründungen sonst könnte das ein ziemlich langer Text werden: - Habe unter...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden