Problem mit Thinkpad Keyboard in xorg

Diskutiere Problem mit Thinkpad Keyboard in xorg im Gentoo Forum im Bereich Linux Distributionen; Hallo, ich habe vor kurzem auf meinem Thinkpad X24 ein Gentoo installiert, funktioniert auch alles prima, bis auf das Keyboard unter xorg. Die...

  1. sym

    sym Funktionalist

    Dabei seit:
    30.10.2006
    Beiträge:
    43
    Zustimmungen:
    0
    Hallo,

    ich habe vor kurzem auf meinem Thinkpad X24 ein Gentoo installiert, funktioniert auch alles prima, bis auf das Keyboard unter xorg. Die Sondertasten funktionieren alle, nur die Tastenkombinationen machen Probleme. Ein ALT+1 ergibt zum Beispiel in einer xterm "±" anstatt die entsprechende Funktion auszuführen. Das ist vor allem in Irssi sehr nervig.

    xorg-x11 liegt in der Version 7.1 vor, der entsprechende Abschnitt in xorg.conf sieht wie folgt aus:
    Code:
    Section "InputDevice"
            Identifier  "Keyboard0"
            Driver      "kbd"
            Option      "XkbRules"   "xorg"
            Option      "XkbModel"   "pc105"
            Option      "XkbLayout"  "de"
            Option      "XkbVariant" "nodeadkeys"
    EndSection
    
    Ich weiß nun nicht genau ob es ein Konfigurationsproblem in xorg selber oder nur von der xterm ist. Wäre super wenn ihr mir helfen könntet.

    Gruß
    sym
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Schau mal nach, ob du irgendwelche xkb-Optionen eingeschaltet hast (z.B. bei KDE im Kontrollzentrum). Deine xorg.conf-Einstellungen sind jedenfalls korrekt. Die nutze ich auch auf einem Thinkpad. Ansonsten mal einen Blick in deine xterm-Konfiguration werfen, denn dann ist das Problem eher dort zu suchen.
     
  4. sym

    sym Funktionalist

    Dabei seit:
    30.10.2006
    Beiträge:
    43
    Zustimmungen:
    0
    Vielen Dank für die schnelle Antwort. Ich habs jetzt hin. Es war tatsächlich ein Konfigurationsproblem der xterm. Die Lösung habe ich hier gefunden. Dort heisst es:

    Ich habe also in meiner .Xdefaults die Zeile xterm*eightBitInput: false eingefügt. Nun funktioniert alles prächtig :))
     
  5. zyon

    zyon undeadlyBSD

    Dabei seit:
    03.11.2005
    Beiträge:
    333
    Zustimmungen:
    0
    Ort:
    Göttingen
    Code:
         51 Section "InputDevice"                                                   
         52     Identifier  "Keyboard0"                                             
         53     Driver      "keyboard"                                              
         54     Option      "XkbModel" "pc105"                                      
         55     Option      "XkbLayout" "de"                                        
         56     Option      "XkbOptions" "ctrl:nocaps"                              
         57 EndSection                                      
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Problem mit Thinkpad Keyboard in xorg

Die Seite wird geladen...

Problem mit Thinkpad Keyboard in xorg - Ähnliche Themen

  1. Lösung zu USB-Problem bei Thinkpads

    Lösung zu USB-Problem bei Thinkpads: Hallo, diesmal keine Frage sondern eine Lösung zu einem Problem mit dem ich mich lange herumgeschlagen habe bzw. das auch viele andere...
  2. NavynOS auf IBM Thinkpad R50 - Bootprobleme LiveCD

    NavynOS auf IBM Thinkpad R50 - Bootprobleme LiveCD: Ich möchte auf meinem IBM Thinkpad R50 gerne NavynOS installieren. Ich brenn mir die Live-CD und lege sie beim Systemstart ein. Dann ladet die CD...
  3. Problem bei der installation einer Sun Netzwerkkarte

    Problem bei der installation einer Sun Netzwerkkarte: Guten Morgen zusammen, beim installieren einer zusätzlichen Netzwerkkarte habe ich ein Problem. Die Karte wird nicht automatisch installiert. Es...
  4. Problem bei der Vergabe von Sciherheitsinformationen auf eine Freiagbe

    Problem bei der Vergabe von Sciherheitsinformationen auf eine Freiagbe: Liebe Community, zurzeit arbeite ich an eine Active Directory Domäne die mittels Samba läuft. Dazu habe ich einen AD DC auf Debian 8.7 mit Samba...
  5. Netzwerkproblem ? , wo ud wie suchen

    Netzwerkproblem ? , wo ud wie suchen: Hallo Folgende Problem: Testserver ist i686 Debian-unstable , auf dem läuft primär der apt-proxy apt-cahcer ng. Zugriff im Moment nur per ssh....