Problem mit Thinkpad Keyboard in xorg

Diskutiere Problem mit Thinkpad Keyboard in xorg im Gentoo Forum im Bereich Linux Distributionen; Hallo, ich habe vor kurzem auf meinem Thinkpad X24 ein Gentoo installiert, funktioniert auch alles prima, bis auf das Keyboard unter xorg. Die...

  1. sym

    sym Funktionalist

    Dabei seit:
    30.10.2006
    Beiträge:
    43
    Zustimmungen:
    0
    Hallo,

    ich habe vor kurzem auf meinem Thinkpad X24 ein Gentoo installiert, funktioniert auch alles prima, bis auf das Keyboard unter xorg. Die Sondertasten funktionieren alle, nur die Tastenkombinationen machen Probleme. Ein ALT+1 ergibt zum Beispiel in einer xterm "±" anstatt die entsprechende Funktion auszuführen. Das ist vor allem in Irssi sehr nervig.

    xorg-x11 liegt in der Version 7.1 vor, der entsprechende Abschnitt in xorg.conf sieht wie folgt aus:
    Code:
    Section "InputDevice"
            Identifier  "Keyboard0"
            Driver      "kbd"
            Option      "XkbRules"   "xorg"
            Option      "XkbModel"   "pc105"
            Option      "XkbLayout"  "de"
            Option      "XkbVariant" "nodeadkeys"
    EndSection
    
    Ich weiß nun nicht genau ob es ein Konfigurationsproblem in xorg selber oder nur von der xterm ist. Wäre super wenn ihr mir helfen könntet.

    Gruß
    sym
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Schau mal nach, ob du irgendwelche xkb-Optionen eingeschaltet hast (z.B. bei KDE im Kontrollzentrum). Deine xorg.conf-Einstellungen sind jedenfalls korrekt. Die nutze ich auch auf einem Thinkpad. Ansonsten mal einen Blick in deine xterm-Konfiguration werfen, denn dann ist das Problem eher dort zu suchen.
     
  4. sym

    sym Funktionalist

    Dabei seit:
    30.10.2006
    Beiträge:
    43
    Zustimmungen:
    0
    Vielen Dank für die schnelle Antwort. Ich habs jetzt hin. Es war tatsächlich ein Konfigurationsproblem der xterm. Die Lösung habe ich hier gefunden. Dort heisst es:

    Ich habe also in meiner .Xdefaults die Zeile xterm*eightBitInput: false eingefügt. Nun funktioniert alles prächtig :))
     
  5. zyon

    zyon undeadlyBSD

    Dabei seit:
    03.11.2005
    Beiträge:
    333
    Zustimmungen:
    0
    Ort:
    Göttingen
    Code:
         51 Section "InputDevice"                                                   
         52     Identifier  "Keyboard0"                                             
         53     Driver      "keyboard"                                              
         54     Option      "XkbModel" "pc105"                                      
         55     Option      "XkbLayout" "de"                                        
         56     Option      "XkbOptions" "ctrl:nocaps"                              
         57 EndSection                                      
     
Thema:

Problem mit Thinkpad Keyboard in xorg

Die Seite wird geladen...

Problem mit Thinkpad Keyboard in xorg - Ähnliche Themen

  1. Lösung zu USB-Problem bei Thinkpads

    Lösung zu USB-Problem bei Thinkpads: Hallo, diesmal keine Frage sondern eine Lösung zu einem Problem mit dem ich mich lange herumgeschlagen habe bzw. das auch viele andere...
  2. NavynOS auf IBM Thinkpad R50 - Bootprobleme LiveCD

    NavynOS auf IBM Thinkpad R50 - Bootprobleme LiveCD: Ich möchte auf meinem IBM Thinkpad R50 gerne NavynOS installieren. Ich brenn mir die Live-CD und lege sie beim Systemstart ein. Dann ladet die CD...
  3. Mageia 7.1 patcht Boot-Problem bei AMD Ryzen 3000 CPUs

    Mageia 7.1 patcht Boot-Problem bei AMD Ryzen 3000 CPUs: Mageia hat kurzfristig mit Version 7.1 ein Point-Release veröffentlicht, um einen Boot-Fehler mit AMDs Ryzen 3000 CPUs zu beheben, der einige...
  4. ip6tables Problem

    ip6tables Problem: Hallo zusammen, ich hab ein Problem kann aber keinen Fehler finden, äußert sich wie folgt, ich habe endlich für ein System in Netz eine IPv6...
  5. VDSL 50 FRITZBOX 7490 PROBLEM?

    VDSL 50 FRITZBOX 7490 PROBLEM?: Hallo ,ich besitze seit letzter Woche VDSL 50 also eine 50000er Leitung. Im Router wird mir allerdings unter "DSL Informationen" 109,34 Mbit/s...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden