Problem mit locales...

whitenexx

Doppel-As
Beiträge
148
Hi zusammen!
Auf meinem neuen vServer (Debian 4.0 Frischinstallation) habe ich die locales umgestellt, also auf UTF-8 für die Systemumgebung. Leider werden jetzt viele Sachen die Umlaute wie "äüö" enthalten falsch dargestellt. z.B. bei Vim.
Siehe Screenshot. Kann mir einer sagen welche locales ich denn nun bei dpkg-reconfigure locales ankreuzen muss!? Natürlich will ich ein deutsches locale und am besten UTF-8.

Hier mal ein paar Screenshots und Log aus der Bash:
http://ubuntuusers.de/paste/34066/



Danke schonmal!
 

Wolfgang

Foren Gott
Beiträge
3.978
Dateien, die im latin_1 gespeichert sind, stellen unter utf8 ihre Sonderzeichen nunmal nicht richtig dar.
Da hilft nur entweder alles umconvertieren (iconv) , oder aber die Locale auf einen anderen Wert setzen.

Zum Kompilieren ist es für root in jedem Fall günstig, LANG=POSIX und LC_ALL=POSIX zu verwenden.

IMHO haben im Code Umlaute eh nix zu suchen.
Und als root ist man selten unterwegs.
 

whitenexx

Doppel-As
Beiträge
148
Ich habe folgende Einstellungen vorgenommen und das Problem besteht leider IMMER NOCH! :(



Edit: Kannes vielleicht an meinem SSH Client liegen? Putty unter Windows Vista Premium (ich weiß das ist Schrott, aber meine HDD ist putte und ich hab schnell Vista auf die kleine HDD installt, weil ich keine Lust auf Treiberfirkelleien unter Linux hatte)

Da hilft nur entweder alles umconvertieren (iconv) , oder als die Locale auf einen anderen Wert setzen.
Was ist denn das beste?
 
Zuletzt bearbeitet:

whitenexx

Doppel-As
Beiträge
148
Und Deinem PuTTy mußt Du das dann schon auch mitteilen.
Daaaanke!!! Das wars! Alles funktioniert super! Vielen Dank! Warum bin ich bloß nicht darauf gekommen!? Ich dachte immer da gibts nen automatischen Mechanismus der die locales überträgt oder so^^

Naja Danke Leute!
 

Wolfgang

Foren Gott
Beiträge
3.978
Daaaanke!!! Das wars! Alles funktioniert super! Vielen Dank! Warum bin ich bloß nicht darauf gekommen!? Ich dachte immer da gibts nen automatischen Mechanismus der die locales überträgt oder so^^

Naja Danke Leute!

Kann zwar über Windowsprogramme nichts sagen.
Aber woher soll denn dein PuTTy das wissen?
Unter MS läuft ja IMHO alles mit dieser cp1252.
Damit du verstehst was da passiert:
Klick

Gruß Wolfgang
 

whitenexx

Doppel-As
Beiträge
148
Danke, noch ganz kurz, damit ich kein neues Thema öffnen muss:
Restarting OpenBSD Secure Shell server: sshd. (sagt der mir wenn ich ihn restarte)

Ist das der OpenSSH Server? Oder ein anderer? Weil sshserver war schon beim vServer vorinstalliert.
 

whitenexx

Doppel-As
Beiträge
148

whitenexx

Doppel-As
Beiträge
148
Ok, also den OpenBSD SSH Server habt ihr auch alle? bzw. die meisten? Ist das der beste, sicherste? (Man weiß ja nie ;) )
 

Wolfgang

Foren Gott
Beiträge
3.978
Hallo
Soll man das kommentieren?

Sagen wir es so, wenn ich diese Einladung annehmen würde, dann bekäme ich wahrscheinlich Ärger. :-)



Der Name steht da.

Und OpenBSD SSH ist mit Sicherheit Closed Source, sieht man doch am Namen. :devil:

So far, the Universe is winning:devil:
Der Glaube an deine Sig. scheint unerschütterlich.

Ok, also den OpenBSD SSH Server habt ihr auch alle? bzw. die meisten? Ist das der beste, sicherste? (Man weiß ja nie ;) )

Er ist immer nur so sicher, wie er konfiguriert wird.
:oldman

Gruß Wolfgang
 

whitenexx

Doppel-As
Beiträge
148
Ihr seit ja nett...
Ich wollte eigentlich nur wissen was ihr so nutzt, könnt ja sein das es eine viel bessere und weitaus mehr verbreitete Alternative gibt.
Das mit der Sicherheit ist mir durchaus bewusst. Habe u.a. schon den Port und Root-Zugriff geändert.
 
G

Gast1

Gast
Ich wollte eigentlich nur wissen was ihr so nutzt,

Nur um Deine Erinnerung aufzufrischen:

Ist das der OpenSSH Server? Oder ein anderer? Weil sshserver war schon beim vServer vorinstalliert.


Das mit der Sicherheit ist mir durchaus bewusst. Habe u.a. schon den Port und Root-Zugriff geändert.

Und was hat das Verlegen des Ports mit _wirklicher_ Sicherheit zu tun?

Die ganz brunzdummen Scriptkiddies hält das vielleicht ab und die Logs hält es sauber, das wars aber schon.
 

Wolfgang

Foren Gott
Beiträge
3.978
Viel sicherer: ssh-key einrichten. Login über Username verbieten
Am sichersten: deamon sshd stoppen. *g*
 
G

Gast1

Gast
Einer geht noch, einer geht noch drauf ...*rumgröhl*

und dazu noch ein: ifdown eth0 *g*

Und vorher noch ein gepflegtes

Code:
shutdown -h +2
absetzen. *g*

(Wer schneller tippt, der darf das gerne auch mit 1 probieren.)

//Edit:

*Grummel* das geht ja laut manpage nur in Minuten oder hh:mm, WARMDUSCHER!!!1111ELF
 
Zuletzt bearbeitet von einem Moderator:

Ähnliche Themen

perl: warning: Setting locale failed.

SLES10: Locale-Settings Problem

Oben