Problem mit GCC / Binutils

Diskutiere Problem mit GCC / Binutils im Anwendungen Forum im Bereich Linux/Unix Allgemein; Hi, Ich habe folgendes Problem: egal was ich mit GCC kompiliere, wenn ich die anwendung ausführen will, kommt folgende meldung:...

  1. #1 branleb, 25.05.2008
    Zuletzt bearbeitet: 25.05.2008
    branleb

    branleb Livin' free

    Dabei seit:
    02.06.2007
    Beiträge:
    114
    Zustimmungen:
    0
    Ort:
    /home/mine
    Hi,
    Ich habe folgendes Problem:
    egal was ich mit GCC kompiliere, wenn ich die anwendung ausführen will,
    kommt folgende meldung:
    Code:
    {-shade@bumbleblee-} => [~/code/projects]
    (21:50:52) ./hello
    -bash: ./hello: Keine Berechtigung
    
    Das hier ausgeführte beispiel ist ein hello world, aber auch anderer Code geht nicht...


    Code:
    {-shade@bumbleblee-} => [~/code/projects]
    (21:46:56) echo $LD_LIBRARY_PATH
    /usr/lib/xorg:/usr/lib:/usr/local/lib:/usr/lib/gcc/i686-pc-linux-gnu/4.2.4/:/usr/lib/libstdc++-v3/:/usr/lib:/usr/local/lib:/usr/lib/gcc/i686-pc-linux-gnu/4.2.4/:/usr/lib/libstdc++-v3/
    {-shade@bumbleblee-} => [~/code/projects]
    (21:46:59) echo $PATH
    /usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.2.4:/usr/qt/3/bin:/usr/games/bin:/home/shade/.scripts:/home/shade/bin:/opt/bin:/opt/TeamSpeak2:/opt/VirtualBox:/home/shade/.scripts:/home/shade/bin:/opt/bin:/opt/TeamSpeak2:/opt/VirtualBox
    
    Die ENV müsste eigtl stimmen, das war das was ich per google gefunden hatte...

    Programmversionen
    Code:
    {-shade@bumbleblee-} => [~/code/projects]
    (21:47:02) gcc -v
    Es werden eingebaute Spezifikationen verwendet.
    Ziel: i686-pc-linux-gnu
    Konfiguriert mit: /var/tmp/portage/sys-devel/gcc-4.2.4/work/gcc-4.2.4/configure --prefix=/usr --bindir=/usr/i686-pc-linux-gnu/gcc-bin/4.2.4 --includedir=/usr/lib/gcc/i686-pc-linux-gnu/4.2.4/include --datadir=/usr/share/gcc-data/i686-pc-linux-gnu/4.2.4 --mandir=/usr/share/gcc-data/i686-pc-linux-gnu/4.2.4/man --infodir=/usr/share/gcc-data/i686-pc-linux-gnu/4.2.4/info --with-gxx-include-dir=/usr/lib/gcc/i686-pc-linux-gnu/4.2.4/include/g++-v4 --host=i686-pc-linux-gnu --build=i686-pc-linux-gnu --disable-altivec --enable-nls --without-included-gettext --with-system-zlib --disable-checking --disable-werror --enable-secureplt --disable-multilib --enable-libmudflap --disable-libssp --disable-libgcj --with-arch=i686 --enable-languages=c,c++,treelang,fortran --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu
    Thread-Modell: posix
    gcc-Version 4.2.4 (Gentoo 4.2.4 p1.0)
    {-shade@bumbleblee-} => [~/code/projects]
    (21:47:51) ld --version
    GNU ld (GNU Binutils) 2.18
    Copyright 2007 Free Software Foundation, Inc.
    This program is free software; you may redistribute it under the terms of
    the GNU General Public License version 3 or (at your option) a later version.
    This program has absolutely no warranty.
    {-shade@bumbleblee-} => [~/code/projects]
    (21:48:11) ldd --version
    ldd (GNU libc) 2.6.1
    Copyright © 2007 Free Software Foundation, Inc.
    Dies ist freie Software; in den Quellen befinden sich die Lizenzbedingungen.
    Es gibt KEINERLEI Garantie; nicht einmal für die TAUGLICHKEIT oder
    VERWENDBARKEIT FÜR EINEN ANGEGEBENEN ZWECK.
    Written by Roland McGrath and Ulrich Drepper.
    
    Code:
    {-shade@bumbleblee-} => [~/code/projects]
    (21:48:14) file hello
    hello: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.9, dynamically linked (uses shared libs), not stripped
    {-shade@bumbleblee-} => [~/code/projects]
    (21:48:36) ldd hello
    ldd: warning: you do not have execution permission for `./hello'
    	not a dynamic executable
    
    hat mir jemand einen Tipp, was ich noch machen könnte ?

    Mein System ist gentoo, aktuellstes portage, keine portage overlays
    2.6.24.4-vanilla kernel

    //EDIT:
    x-bit ist natürlich gesezt, root darfs auch nicht ausführen ...
    Code:
    {-shade@bumbleblee-} => [~/code/projects]
    (21:50:55) ls -lasv hello
    8 -rwxr-xr-x 1 shade users 7902 25. Mai 12:41 hello
    {-shade@bumbleblee-} => [~/code/projects]
    (21:52:38) sudo ./hello
    Passwort: 
    sudo: unable to execute ./hello: Keine Berechtigung
    

    MfG Branleb


    //! EDIT:
    Habs gelöst.
    in der /etc/fstab war noexec unter den mount optionen drin ...
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Problem mit GCC / Binutils

Die Seite wird geladen...

Problem mit GCC / Binutils - Ähnliche Themen

  1. LFS Problem (Kap: 5.4) Binutils

    LFS Problem (Kap: 5.4) Binutils: Hallo. Von welchem Ordner aus soll man das eingeben? Was soll da rein? mkdir ../binutils-build cd ../binutils-build Vielen Dank
  2. Problem bei der installation einer Sun Netzwerkkarte

    Problem bei der installation einer Sun Netzwerkkarte: Guten Morgen zusammen, beim installieren einer zusätzlichen Netzwerkkarte habe ich ein Problem. Die Karte wird nicht automatisch installiert. Es...
  3. Problem bei der Vergabe von Sciherheitsinformationen auf eine Freiagbe

    Problem bei der Vergabe von Sciherheitsinformationen auf eine Freiagbe: Liebe Community, zurzeit arbeite ich an eine Active Directory Domäne die mittels Samba läuft. Dazu habe ich einen AD DC auf Debian 8.7 mit Samba...
  4. Netzwerkproblem ? , wo ud wie suchen

    Netzwerkproblem ? , wo ud wie suchen: Hallo Folgende Problem: Testserver ist i686 Debian-unstable , auf dem läuft primär der apt-proxy apt-cahcer ng. Zugriff im Moment nur per ssh....
  5. Verständnisproblem Samba / LDAP

    Verständnisproblem Samba / LDAP: Hallo zusammen! Ich habe unter Ubuntu 16.04 einen LDAP und Samba Server aufgesetzt. Diese scheinen auch ordnungsgemäß zu funktionieren, sodaß ich...